Regular “Lost Connection to DCS Rossini DAC” message on Mosiac


Before I go on, I do realise there have been other similar posts but I believe mine is subtly different in that it’s not impacting playback of music through my Rossini.

When I first open Mosiac on my iPad to use my Rossini and also when I’ve been listening to music (an album or playlist) for a while (say 20 mins) and then decide to find some other music via Mosiac, I regularly get the message “Lost Connect to DCS Rossini DAC (58545), Attempting to Reconnect)”. After 2 or 3 seconds, connection is re-established and all is ok.

I don’t get any drop-outs when playing music, absolutely rock solid over many months, it’s only when I “wake up” Mosiac to choose music. And I don’t have to have moved away from Mosiac to different App on my IPad, it happens with Mosiac left as the open App on my iPad.

Clearly it’s only an irritation as it doesn’t impact playback but if anyone has any ideas to fix it I’m all ears!

Btw, I realise the reference 58545 is simply the serial number of my DAC.

Many thanks, Mike.

1 Like

I get exactly the same phenomenon with my Bartok

1 Like

On vivaldi as well


If you set your phone/tablet not to go to sleep then do you get the same issue?

Best Regards

Phil Harris

1 Like

Hi Phil, let me give that a try this evening. Thanks, Mike.

As far as I can tell, the “issue” is that Mosaic Control operates in a stateless fashion; once its no longer the focused application on iOS, for example when the iDevice sleeps (or some other heavy application is used), Mosaic Control loses the DAC’s state information.

Once Mosaic Control comes back into focus, it re-issues an mDNS query and gets a dump of the DAC’s complete state. During that 1-2 seconds is when you see that “Lost Connection” screen (which in my opinion is a bit of a misnomer, it should just say “Please wait…”).

If your home network has more than a few extra hops between your WiFi Access Point and your dCS DAC, expect a couple of additional seconds of delay to the whole process.


It may be worthwhile to try and set a static IP address on the DAC via its web browser console settings. In a small, well functioning network this should not be necessary but it won’t harm either.

1 Like

Yeah, no harm fixing the IP address on the dCS unit, but it won’t solve or reduce the time that “Lost Connection” takes though.

I know this for a fact because my system has fixed IP addresses, but I also occasionally encounter this though just for a second or two tops (which is why I dug into trying to understand the problem in the first place :grin:).


Yes, I already have a status address assigned for my Rossini.

I tried Phil’s suggestion of turning off auto-lock on the iPad and I’m still getting the lost connection message but, I have to say, on a much less frequent basis. As I an estimate I’d say it reduced the occurrences by at least 50%.

Regards, Mike.


I have found if i keep the device in my hand and keep it awake ( your theory) it doesn’t occur. It is such a small issue it isnt much of a bother

1 Like

I agree, it’s not a major issue, I just wondered if there was a simple fix or if something could be done in the next version of Mosiac. It doesn’t interrupt playback which of course is the key thing.

Cheers, Mike.

Without wanting to sound like I’m taking a pop at Andre because his thinking behind his suggestion itself is absolutely sound, DON’T set a static IP address on the unit itself unless you really have to, ideally reserve an IP address in your routers DHCP reservations table instead.

The reason being that in three years time when you’ve well and truly forgotten what you’ve done and you change ISPs and the replacement hateful ISP supplied P.O.T. router they give you is on 192.168.1.x rather than 192.168.0.x and your dCS streamer vanishes BUT when you look at the display you don’t notice the .1.x instead of .0.x and you go nuts trying to find out what’s gone wrong you’ll be really really annoyed by the time you remember that you set a static IP address and for us it’s much harder to chase down these sorts of problems when devices are set to static IPs on a different range. :slight_smile:

…but otherwise Andres suggestion is bob on!



This issue is a little annoying but I can live with it for sure, that said if I were weighing up 2 similar machines and one had this issue it would be enough for me to go the other way.

As far as I can see the DCS does not lose connection with the cloud so playback isn’t interrupted.

In an ideal world, Mosiac could browse music without connection to DCS, that way the reconnection wouldn’t really be a noticeable issue.

One thing does strike me is the connection you use to Rossini. If you have a laptop and connect this via USB then this will time out . This is a battery saving option set a default by the computer manufacturer and needs to be defeated in the “power” settings.

Also see the FAQs. Your local files need to be served by MinimServer 2 and other software is not guaranteed to work.

What I meant was…

Get rid of the lost connection screen (replace with cached versions) and run reconnection in the background.

Hi Graham,

You couldn’t really pre-cache in that way … we are obviously aware of this thread and that the “Lost Connection” message is causing issues with some people (oddly I don’t get that problem even if I let my devices sleep, by the time my phones or tablets have woken up they’ve reconnected) so we’ll definitely look into what can be done.


Hi Pete, I’m not sure which post that was directed at but I use an iPad (not computer/USB) and I have a Melco N1Z with Minimserver 2 installed.



I too use a Melco with my Vivaldi and there is no recurring problem with the connection ( discovery).

I know from the past that some have difficulty in maintaining connections given the settings in the software of their router or network switch. This may have bearing on the matter but it needs the input of one of our network experts like @Anupc.

1 Like

I have the same issue with my Ipad and dcs rossini player, 80% of the time when picking up the Ipad there is the message of lost connection, it takes 2 to 5 seconds to re-connect, tried a new Ipad, exactly the same. Although annoying I have learned to live with it.
It is strange that on the same Ipads there is no problem with the Aurender conductor app, which is alway immediatly available

This has been one of my biggest frustrations of moving to dCS so if someone can find a solution it would certainly enhance my appreciation of the brand. I have to look at that swirling icon about 80% of the times I pick up my iPad and look at Mosaic. Having little experience of such software I assumed it was inherent in all streaming type packages and was a significant factor when I upgraded from Bartok to Rossini, I went for the Rossini Player so I could avoid using Mosaic or any network if I choose to; just and old style CD and remote control - excellent.

It’s also interesting that the dealer had no idea how to deal with it and as usual blamed my internet service despite the fact that I also run TV, iPhones, iMac, iPads, printer etc. etc. on the same network without any problems. But in my experience, whenever anything which uses a network has a problem the blame is always laid on the network because basically the electronics/software is beyond the capability of customer facing businesses.

So it’s intriguing that this thread has appeared recently. I’m not the only one.