Clicks and pops, Puccini Uclock

At my wits end here.

I am using an iMac as a server, connected to a UClock via USB that then connects to a Puccini player/processor for digital to analogue conversion. All was running brilliantly until I upgraded the iMac to High Sierra. Now I get persistent clicks during playback.

I’ve ensured the UClock is recognized by the iMac as a digital source, and selected it at 48,000 hz as a 2 bit 24 integer midi device via the midi interface screen on the iMac. I’ve tried changing the sample rate and still get clicks (more like a signal dropout)

I’ve used the menu on the Player/processor to ensure the UClock is locked to the iMac, and the locked gear sample and UPS shows up in the display window.

I heeded the advice here to make sure the iMac is locked to the UClock master clock, and called Apple for some assistance–their response was to make sure the clock on the iMac is showing the correct time-- not the answer i needed.

I am running DCS Software version 1.21 on the player/processor, and have asked DCS for a cd with the newest software versions for download and eagerly await their response.

I am at the point where i am thinking about bringing the iMac to an Apple specialist and forcing it back to the previous operating system i was using to see if that resolves the problem. The other alternative is to just sell the DCS gear and go a different way and i really don’t want to do that. But, i can’t seem to fix the problem and understandably find it quite annoying…

Any help offered would be greatly appreciated.


Dave Mitchell
Yorktown VA

You didn’t mention what software you’re using on the Mac? If anything that’s likely where your problem probably is.

I’m using Apple Music.

I can’t help much as I have no experience with playing back lossy-compressed music on my dCS systems. By the way, High Sierra is almost 3-years old, why not upgrade MacOS to something more recent??

Apple Music Playback is not necessarily lossy. It just depends on whether you are using Music for streaming (AAC and lossy) or for playback of your own lossless local files,

1 Like

Ahh, I stand corrected :blush:. I haven’t touched Apple’s native music playback in years, didn’t realise they’ve started supporting lossless files as well.

It’s actually not new. iTunes has played lossless files [AIFF and ALAC] from the start. Up until Apple started integrating iCloud/iTunes, I played AIFF files all the time. Before I started using bit-perfect/error-checking rippers, I ripped to full AIFF files in iTunes. You may be thinking of early lack of support of WAV files, but that’s not the only lossless codec, and iTunes (and now Music) have played WAV files directly for some time now.

I think that is where your problem is. The clock is not a digital source, nor is the Puccini player.

I am also a Windows user so my knowledge of Apple is minimal but I think that MIDI and the Windows sound engine have similarities but I apologise in advance if my expectation is not correct.

Your source is the Apple music player, not the Puccini /UClock equipment. The Puccini ( think of it and the clock as if they were one) is usually called by computers the Audio Device or Speaker ( whichever term they use). This should be selected as the default replay device.

The Puccini is an asynchronous DAC and it controls the timing of the computer in sending the data. What you have looks like you have set up a conflicting system of timing which is resulting in the clicks.

Have you got the user manuals for the Puccini and Uclock?If not you can find them here:

dCS manuals are very well written and should explain the correct setup.

1 Like

Thanks for the assistance gents…i am stuck on OS High Seirra because mine is a n old iMac (2010) and he newer operating systems will jam it up.

I have poured over the DCS manuals and am still stumped. When I open the MIDI controller, over on the left hand side of the screen it shows a built in mic, a built-in input, a built-in output, then the UClock. If I select the UClock the right side of the screen it shows the UClock in bold at the top of the page and below that it shows the clock source as default with no opportunity to change that (I think it should show the UClock as the clock source. So, the IMAC recognizes the UClock, but won’t allow it to act as the master clock.

I’ll keep plugging away at it–if any DCS personnel happen to be monitoring this conversation sure would be nice yo hear from ya…

Dave Mitchell
Yorktown, VA

1 Like

submitted below directly to DCS Technical Assistance today, 28 Feb 20.

I have a Pucinni player/processor that was working brilliantly in my system for several years, up until i upgraded my OS to High Sierra. I am using an iMac as a server and have it connected via USB to the UClock. Everything was working splendidly until the OS upgrade. I am limited to OS High Sierra due to the vintage of my iMac. I am getting intermittent pops and clicks during playback.

I have poured one the DCS manuals and am stumped. When I open the MIDI controller, over on the left hand side of the screen it shows a built in mic, a built-in input, a built-in output, then the UClock. If I select the UClock the right side of the screen tells me the source is Default, and there is no opportunity to change that. It also shows the Puccini in bold at the top of the page and has the clock source as default with no opportunity to change that. So, the IMAC recognizes the UClock, but won’t allow it to act as the master clock.

On the player/processor menu i have:

Control 1.21
Display 1.20

DAC source is RCA1

RCA 1 is set to upsampling

Clocking settings shows shows locked gears

After all that, the display screen on the player/processor shows RCA1, UPS, and locked gears.

I still hear clicks and pops when i play music from my iMac thru the UClock and player/processor DAC.

Can ya help me figure this out please.

Also, some time ago i asked if there were any updates I need to make to my equipment, and if so if you could send me aCD with those. Doubt the problems lies therein, but needs updating irrespective.

Thans in advance what will hopefully simple fix to this

Dave Mitchell
Yorktown, VA

Dave, I sure hope you get this figured out. I an understand that an OS upgrade might contribute to this, but for the life of me, do not know why.

Thanks Greg, I really have been searching for the source of this problem for way too long…close to the point of ditching the UClock (I’ll keep the Puccini player/processor) and getting a DAC to handle digital to analogue conversion from the IMac. Last time I moved my system around it took a week to get the settings and corrections right with the UClock/IMac interface…ugh.



You know, I love to tinker with this hobby of ours. But this is way too much inconvenience. I hope it works out ASAP.

The UClock is the device that has the USB input, so it is recognized as the Digital source (back in the days where asynchronous USB to SPDIF were the norm).

@mitchell1079 since you are at your wits end on this, there are 2 possible solutions I can think of before dCS support:
Hard way is a firmware update for the UClock device, there might be an offline method of this, so dCS or dealer can do if necessary.
An easier method is to trial a software such as Audirvana which in simple terms gives a more direct connection (exclusive mode) from iMac to UClock. Check first if the latest still supports your OS, since software need to keep in line with the modern OS versions.

1 Like

Trying Audirvana is a great suggestion. And I am pretty sure they still have versions supporting High Sierra.

1 Like

Yes indeed! El Capitan is the minimum requirement, so OP should be ok for the trial to troubleshoot this issue.
One more suggestion is the choice of USB port, as some share the same Bus with other devices, and finally a trying a different USB cable- the likelyhood is that the spec compliant one is less likely to induce clicks and pops.

Thanks for the advice–I’ll try a software fix with Audionirvana. I was running Pure Music for a bit and recall it had a buffer so that might help too.

I discovered that if I create an aggregate device in the MIDI widow, the UClock shows up as the clock source but i still get clicks and pops.

Just to ensure i am correct, the iMac recognizes the Puccini. The Pucinni tells the iMac it will be the master clock and dictates data transfer rate. For some reason, my iMac won’t let the UClock act as the master clock.

I’ve tried every USB port on the IMac and the Puccini us the only thing plugged into it.

I ran a systems report and the USB Bus shows the following

Built in I sight
Internal memory card reader
Bluetooth USB host controller
IR reader

Maybe the Puccini needs to be listed first and have full control of the clock, but i don’t know how to rearrange the order if that matters…

I’m getting ready for a major system relocation in my home and need to either fix this before that or come up with a different DAC approach using my IMac as a server. McIntosh preamps with internal DACs are current focus…

Thanks for all the advice


No joy on Audio Nirvana trial test…i hope to hear from DCS next week…


You shouldn’t set the Puccini as Master as you are using the U clock. There is also no wordclock input to your computer. Set the Puccini synch as W ( wordclock) or Audio.

NB: I would like to check this advice by the looking at the Puccini manuals but none are available via the dCS “documents” webpage as it seems to be not functioning this weekend.

EDIT: I have now been able to look at the Puccini and U Clock manuals thanks to Anupc. The wordclock setup is a bit different to the bigger dCS DAC s and clocks. I had therefore misunderstood your posting. In fact there is no ability to set the Puccini player as a master for synchronisation. The wordclock out facility seems only to operate when playing discs. I agree with Anupc’s further advice below.

Both the U-Clock and the Puccini Player Manuals are on the support page;

The USB device order should not matter. Also, you shouldn’t need to setup an Aggregate midi device, MacOS typically does a good job of automatically negotiating with the USB device for the appropriate setting, including Async-USB clocking.

You might want to double-check that you’re following the instructions on page 7 & 8 of the U-Clock manual to the letter, and that the U-Clock’s USB Audio class is set for Audio Class 2.

Outside of that, if you’re still having clicks & pops with the iMac playback, you might want to test out some other source, like an iPhone with a Camera connection KIT for USB, or a Windows PC first before you call in dCS support.

Best of luck! :grinning: