As usual, Rossini Player update to 2.10 was a pain

Soon after the announcement, I opened Mosaic and went to Support → Versions and saw the update was there.

Clicked on the button to download and install.

Mosaic continued and soon got to the circling animation saying it was updating the FPGA… which was news to my Rossini Player, which was happily playing audio and didn’t notice anything was happening, even after fifteen minutes.

Per usual, I figured it needed a power cycle, so I did that.

This time it came up and said it was downloading the firmware update. It got to about 1024/4096 and said CHECKSUM!!!

That’s not good, so another power cycle.

This time when it powered up, it said it was performing a network update. Fifteen minutes later… no progress at all.

OK, another power cycle.

This time, it started with the downloading firmware update message again, got to 4096/4096, installed the upgrade and told me to restart.

One last power cycle and voila, it’s running 2.10.

I really wish I knew of a better way to upgrade, but this is pretty much how it’s gone every time there’s been a Rossini firmware update.

One additional fun fact - the Expanse controls are only visible from the front panel under Settings → Audio; Mosaic doesn’t show anything different in any of its menus.

1 Like

We having been discussing this here:


Indeed. I feel your pain. I described my laborious process in the thread Erno linked.

1 Like

Easy upgrade, switched the power off/on, forgot to move my ethernet cable to the fast side of my Melco S100, started the upgrade process, about 15 minutes after it asked me to reboot the power and the install was completed.

Has been worse in the past, happy that it went smooth this time.
Will try it tonight with my headphone.


I’m happy to say all went smoothly here too (although I did get some instruction from dCS)

Generally I follow these steps for updates (when I see one):
1- Power cycle the Rossini
2- Go to the Rossini webpage (easiest is to try dcs-rossini.local in a browser)
3- Update from there (second tab)
4- Power cycle when told to do so

Have people followed this protocol and had any issues?



I gave your way a go, Miguel — zero problems.

(Just in case, I shut down Roon beforehand too.)

1 Like

I’ve not had problems with any firmware upgrades in the past but I’ve looked at dCS’ firmware update process in detail, at the packet flow level, it couldn’t be simpler, but things like Firewalls or VPNs can definitely screw with it.

Perhaps we can help dCS get to the bottom of this if those who’ve had problems can describe in detail the chain involved from your dCS Ethernet port all the way to you ISP demarcation device at your home.

ps: :thinking:I wonder just how many people tried to firmware update immediately after the announcement yesterday, I wouldn’t put dCS Firmware Server congestion out the question :rofl:


I didn’t even remember it had a web page; I’ve always tried via Mosaic.

I have no VPNs nor firewalls aside from what my ISP provides on their end.

I did this exactly and had two failed updates. 3rd time was the charm for some reason.

I should note that the Rossini 2.1 update is a full control board update to the Rossini unit, not simply an app update or network board firmware update. This is much more like updating the BIOS for a PC, then reinstalling Windows whilst also updating every single driver.

The vast majority of issues which I have seen with updates are rectified by a hard power cycle of the unit before starting the update process, and the rest tend to come down to local network issues which for one reason or another prevent the unit from properly communicating with the update server to download the update (resulting in error messages). As @Anupc suggests, firewalls and VPNs are potential causes to temporarily bypass if issues do arise. Simplifying the network chain in cases where issues are experienced is a very good place to start.

With all that being said, these comments have definitely not gone unheard. We are going through and thoroughly stress testing the update procedure on the back of these comments to see if we can improve the process to provide a smoother experience in future.


Thanks James. Would it be possible to add a FAQ topic about the firmware upgrade process of all dCS units, with step by step instructions? This might help a lot of users to get it right from the beginning.


FWIW, I followed the procedure I posted exactly and I was done without a glitch in 15 minutes.

1 Like

Hi @James - Thx for the detail.

When will the dCS Mosaic iOS app be updated to control Expanse on the Rossini?

1 Like

Yes, me too. But many users still do not get it. Upgrading firmware while playing music, starting the upgrade through Mosaic, and then finding out a reboot should have been done first, connecting through Roon during the upgrade, etc. I think a FAQ topic that gives step by step instructions, with do’s and don’t’s would be helpful as a referrence to all.

I think the safest and most missed step is restarting Rossini prior to the update.

1 Like

All plain sailing - power cycled prior to update. Gained access to the web interface via IP address and started the update.

All smooth and done within 15mins

1 Like

The problem I had with this and every previous update was the failure of either the Rossini front panel or Mosaic to indicate when it was time to power cycle.

Through step 3 everything is fine and both the display and Mosaic indicate “updating network board”.

The problem is no message is ever displayed indicating time for a reboot. After 30 minutes of “nothing” I power cycle the Rossini and the update proceeds smoothly with the display indicating “downloading xxxx of 4096”

1 Like

In my case, I didn’t have this issue. Rossini’s display eventually said something along the lines of “PLEASE RESTART”


I would say Mosaic could have a warning sign saying - “Please power cycle before updating”.