Vivaldi song truncation

‘Twas suggested I start a new thread to try and figure out why my Vivaldi stack (DAC/Clock/Upsampler) is truncating the first half a second of DSD songs I play from my NAS. I am not using Roon etc, just relying on Mosaic for control.

The drawing for connections in the manuals is kinda busy so I distilled it down to the below to help me trace the connections:

Clock Group #1 output #1 to DAC input #1
Clock Group #1 output #4 to Upsampler input #1

Clock Group #2 output #5 to DAC input #2
Clock Group #2 output #6 to Upsampler input #2

Unit settings are below:

Upsampler is set to Auto wordclock
DAC is set to Auto wordclock

Upsampler clone mode is set to off

DSD pass thru is set to on

I’ll keep trying to figure this out and appreciate everyone’s help.



I also have this issue with high-Rez recordings from Quboz. Here are the info windows on the DAC and Upsampler when I play Pneuma by Tool at 24bit/96 hz.

The DAC shows a lock to W1, and the Upsampler locks to W2.

And are your Upsampler AES outputs connected to AES inputs 3 & 4 of the DAC?

Yes they are

In Roon you can adjust the re-sync delay to accommodate changes in formats. You find that under Audio-then your DCS device.

I never use Mosaic for listening to music so I can’t comment on fixing the issue.

To help track down the problem do you lose the first fragment of music from Qobuz if you play it in native format i.e. turn off the upsampling? So play a track from Qobuz that is 16/44.1 and then select one @ 24/96. When DAC switches from 16/44.1 to 24/96 is there a loss of music with the 24/96 track? Then stop the 24/96 track and start it again or pick another 24/96 track. Do you lose the first fragment again?

BTW, your front panel displays seem fine.

I don’t use Roon, and would hate to have to get another subscription on top of Quboz to fix this…Mosaic does all I need it to

I’ll try that when I get home tonight, thanks

I understand that sentiment.

Mitch, what UPnP Server are you using by the way? (my apologies if you’ve stated it previously/elsewhere that I didn’t catch :grin:).

Hi Mitch,

First thing to check here is that the RS232 cable is connected between the units properly. Easiest way to check this is to raise or lower the volume control on the DAC (physically via the front panel volume control) and see if the change is mirrored in the Mosaic app. The buffer should ideally be turned on.

The Sync Modes shown on the displays of the units are correct. Each unit shows which clock input is being used to clock the audio rate on the input of the product – in the case of playing a 24/96 file into the Upsampler, that will be using W2 (being a 48k based rate). For your info, the Upsampler is actually using both clock rates, as upsampling to DSDx2 means changing to a 44.1k based rate. As the input rate is 96k, the Upsampler shows W2. For the DAC, as it is then receiving DSDx2 (44.1k base rate), it shows W1 as the clock input being used. No need to worry there.


I’m away from home for a couple days and will check this when I return, thanks so much for helping me. I love the setup; how it sounds, and how it looks…

I just bought a Shunyata Everest which will replace the Denali, and sit on the table to the right of the rack. So, why is this important to DCS, and me? The Upsampler moves from above the DAC to the empty shelf space, and each component has its own position. Symmetry counts too…




I’ll check that when I get home…




I use Minim on my NAS. I ran the diagnostic process you described above with same result.

Volume changes made directly on the DAC reflect in the mosaic app, so following James’ logic the RS 232 connection is solid.

I’ll dive behind the rack and disconnect and reconnect all the clock connections and see if that solves the problem. I’ll do the same for the RS232 connections.

Thanks for your help.


Curious to hear what you guy come up with! I have that problem each time the DAC swaps from using a Dual AES connection (e.g. due to the Upsampler being set to DSD128 upsampling) to a single AES connection (playing back DSD64 natively with “Upsampler DSD Pass Through” engaged). As I’m too lazy to figure out a better solution, I’m inserting a “Ghost Track” (an empty 4-second DSD64 track) at the beginning of DSD64 track lists (except for the first track of an album, where this problem rarely comes up as there’s usually enough of a delay), which gives the stack ample time to switch from Dual to single AES.

Greetings from Switzerland, David.

Hey David. That sounds like a lot of work to me. So now we know I am lazier than you. :wink: Moreover, my guess is that it doesn’t solve the problem when one is randomly switching tracks. I don’t recall your playback software (Mosaic?), but this is starting to sound like a widespread situation. I never underestimate the difficulty of implementing software, but am wondering if it’s time for Mosaic to include a resync delay feature like Roon.

It’s definitely a problem, a solution would be most welcome, as long as sound quality isn’t affected, I don’t much care about a delay.

Greetings from Switzerland, David.

Speaking of laziness, one only has to cue a track only once in Mosaic, at which point one can flip it around all day…

Greetings from Switzerland, David.

1 Like

Greg, can’t happen (and it’s not needed), because unlike Roon, Mosaic is just a Control point, theres no music bit stream flowing through it, so it can’t “add” any silence bit stream like the Roon Core can.

Roon’s Resync delay is primarily designed for AES/EBU & S/PDIF interfaces to have time to properly sync to the incoming synchronous bit streams. In effect, the combination of “Buffer” ON setting on the Vivaldi DAC plus it being able to detect the actual incoming bit rate, serves pretty much exactly the same purpose as Roon’s Resync delay.


David, in a properly setup Vivaldi stack connection of Upsampler to DAC, there shouldn’t be a need to keep alternating from Dual AES to single AES settings between them. You should be able to leave it at Dual AES and every source rate should play just fine. Why do you need to switch? :thinking: