UPnP Server not detected

Since a few days dCS Mosaic does not detect MinimServer on my LAN any more. My network setup is as follows:

MinimServer is detected without any issues by Volumio 3 on the Odroid (see network schematics), so MinimServer seems to be functioning normally

I am wondering if there is an issue with the latest version of Mosaic? I am seeing the same issue on an Android tablet and on an iPad.

Rudi, the current version of Mosaic Control (1.1.3) has been around for over 10 months, the way it’s architected, it won’t suddenly not work properly.

I’m guessing the more likely cause of the issue you’re seeing is something else that has changed in the rest of your setup.

Here are a couple of things I can think of to check;

  1. MinimServer 2.1 - there was a MinimServer 2.1 update 214 released a couple of days ago. Did your Synology update to that, and did that break something dCS Mosaic related? (I’m still on 2.0 so I can’t tell if theres anything wrong with 2.1/214)

  2. Multicast on your Asus’ Wireless interface - On your Asus AC68, make sure “Wireless multicast forwarding” in Enabled. On the Asus unit’s config menu, [Advanced Settings] → [Wireless] → [Professional tab] → [Wireless Multicast Forwarding] → Enable

  3. IPTV - Again on your Asus, ensure the TrendNet connected Port is not enabled for IPTV. On the Asus config menu; [Advanced Settings] → [LAN] → [IPTV tab] → [Choose IPTV STB Port] → None

Can’t think of anything else at the moment. Give those a check and let’s see what happens :crossed_fingers:t2: :wink:

Thanks @Anupc
Thorough as usual :grinning:

Instead of reconfiguring the ASUS WLAN access point, I have replaced it with a plain Netgear GS108 switch and that seems to have done the trick. My layout now looks as follows:

Glad to hear it’s resolved :smiley: :+1:t2:

Curious about what the original problem was though. Which GS108 model did you get? There are a couple of different versions; the GS108T (v2 & v3) Managed version is especially interesting as it’s among the cheapest Switches around that can be configured as an IGMP Snooping Querier.

I have installed a plain GS108 that I had in storage.
Yes the “T” models are super. The GS716T even has two SFP cages, which would allow to attach the Melco S100 directly (sans Trendnet)

Actually I noticed that my second diagram is not quite correct. The GS108 is connected to the LAN directly and the ASUS hangs off the GS108. I have corrected the diagram.

1 Like


i have the same sort of problem and you advises me in another post to simply cut off any igmp on the lan. so can you please clarify one more time

UPNP logouts on network bridge sn 54449 - 1.13 (119) , 1.13(506),1.02

on my lan, i have changed for an asus routeur which give me the possibility to cut igmp or not
my actual switch (aqvox se) is a igmp (but non maneagable) version so i can’t turn off. switch rev is c6.
but with this configuration, igmp enabled, i have still upnp drop out or non discovering
usually, i unplug the ethernt link of dcs, wait a little, replug, and it’s ok for a while
modifying the delay doesn’t solve.

so i ordered another non igmp switch to aqvox. in fact it’s the same but on an older revision basis (c2 or c5) of the switch wich isn’t igmp (but still non manageable)

Reading you, i thought (wrongly?) that’s the goal was to have no igmp unit at all to avoid the upnp non discovering problem

was i wrong ?
if yes, why is my set still not working also i have full only igmp working links ?

so it should be in fact a problem with the network bridge himself ?


Hey again Pierre.

You’re not wrong.

By the way, the feature that needs to be turned off is not IGMP, but “IGMP Snooping ”.

It’s called “snooping” because IGMP is actually a layer 3 protocol, while most Ethernet switches are purely layer 2 device, but snooping allows them to recognise the IGMP packets in order to provide filtering function for multicast traffic.

The dCS Network Bridge has no problems operating in a normal Ethernet network, so, it’s very highly unlikely that it’s the cause of your problem.

The more likely case is even your new AQVOX Switch is doing something wrong. Are you sure about the model, and does it definitely have IGMP Snooping turned off? (AQVOX not a proper networking company, they just OEM from D-Link).

Hi Anupc

i have made the last update in 1.2
dcs staff tell they don’t think it will give sonic differences
but i have and very real, even (or why?) i have a non dcs dac (AMR)
by the way, it’s two full days i have no upnp problem
perhaps it will come back but i don’t hope about.

my question is :
what about the update content about the network bridge part
a driver update somewhere ?
do you know about ?

i am beginiing th think that perhaps the aqvox is not involved.



Glad to hear that :smiley:

Sorry, I don’t quite understand. :thinking:

i wonder why i have now no more problem without changing anything but the 1.2 dcs upgrade.

i see on the web that 1.2 upgrade was on the mosaic software, and on the transport functions.
so i wonder if you know about any related change (ethernet driver and so on) that will explain

i am now with 3/4 days without trouble, but in the past, problem happened to come back after a while (one or two week)

it’s important cause on the other side my switch manufacturer is working to send me a non igmp version
which is perhaps not necessary if the change to do was on the dcs side

hope i am clear for you


Ahh, I see.

Well, there doesn’t seem to be any changes to the underlying TCP/IP networking aspect of the Mosaic 1.2 upgrade - thats where any change would have had an impact to your problem.

One thing to keep in mind is that with the Mosaic 1.2 upgrade, when you reboot the dCS, as part of the power-up sequence, it will re-issue IGMP requests out into the network; I’m guessing your AQVOX has seen that and ensured that the dCS connected port has no multicast filters.

However, sooner or later, the AQVOX will timeout it’s multicast filter table, and if it doesn’t immediately see another IGMP request and response, it could re-block multicast to the dCS connected Ethernet port. At which point you’ll have the problem again.

So, still a good idea to switch to an AQVOX that doesn’t have IGMP snooping permanently on by default :grinning:

Yes you are right, cause last evening i had the same problem
Aqvox send me the new switch this morning.
takes some days to come
i will update the post

by the way one point is obvious, although not really explained or predictable by the team
1.2 upgrade had a real effect on my set


New switch is running since two days without any upnp loss
will update in one or tqo weeks to be sure



The post can be closed now. Thanks to anupc for the solution.
No probleme occurs with the new switch (Aqvox modified on DLINK basis DGS 108 rev C2).


Hi everybody

Bad news. After a15 days ok, DCS NB has loose the upnp two times in one week
so the problem is still alive contrary to what i thought. can’t understnd. i have changed th router, the switch, and still the same. now i really thing the NB has the problem from the start. i read ethernet plug to be somehow sensitive. perhaps previous owner has made a mistake. don’t know. is there any solution to test. Although i will send back to my dealer.

on the router i have stopped the option

Disable IGMP proxy
The IGMP proxy feature allows a LAN-connected computer to receive suitable multicast traffic from the Internet. Check this box to disable the feature if you don’t need it.

Pierre, sorry to hear that :persevere:

The problem is likely IGMP Snooping, not IGMP Proxy; they’re totally different.

What brand/model is your Router, and UPnP Server? I don’t think you mentioned it previously.

In any case, I still suspect your AQVOX is where the problem is - I re-looked at their website, their Ethernet switch product details is full of rubbish :roll_eyes: My suggestion is you return it and get your money back, and replace it with something simple and good, like a Netgear GS108.

don’t be sorry cause your help is precious
it’s me with my sticking plaster bug…

here is the link to my new router (not an aqvox product… :smiling_face:)

can’t understand where i can play and change network parameters about igmp snooping
understand your position about my other supplier, but please understand two points :smiling_face:

  • first it obviously works however it’s done
  • second with the same switch and router, a lumin mini wasn’t loosing the upnp ?

i don’t affirm it’s a dcs point, but we have to admit it’s a complex problem, and that one of the things leaving to test is the DCS.

however it’s not ruinous to buy a netgear 108 to progress in the diag.
i will do and become an igmp problem hardware collector !.

by the way there are various model
i think i have to buy the manageable one ?


I’m totally with Anup here … UPnP discovery had issues with being flaky maybe 15-20 years ago (God do I remember the pain back then) but it’s now something that is so ubiquitous that it’s one of those things that “just works” and if it doesn’t then there’s an actual problem to actually be solved.

If you can just drop in a basic unmanaged switch as a test then that’s definitely a place to start - your router should be absolutely fine, I’m not a great NetGear fan myself but they’re generally solid and perform well enough.


1 Like

Your Router is fine, you won’t need to change anything on it :grin:

Get the one managed one, this one; https://www.amazon.fr/NETGEAR-GS108GE-Switch-Manageables-ProSAFE/dp/B000092RRM/

What’s your UPnP Server by the way? And is it connected directly to the same Ethernet Switch that your dCS is connected to?

i have ordered the mangaed one. will be there in 3/4 days
upnp is minimserver v2 under licence, installed on my two synology (116, 118, dsm 7 updated)
Minim 2.1.2 update 215