UPNP logouts on network bridge sn 54449 - 1.13 (119) , 1.13(506),1.02


still with my problem of upnp logout
earing music, everything perfect, then nothing
i go on upnp menu, and empty
usually 5/6 in the list cause of my network (2 nas synology, 2 upnp)
usb listening working

i have tried anything possible, but nothing decisif

reinstalling nas, two nas (syno 116 and 118 dsm 7 updated) with minimserver (updated, full licence → same problem)
changing option on routeur with or without dlna and so on → the same

if i disconnect network bridge and replug few minits after → everything correct again
sometimes a few hours ok; sometimes 15 minuts ok the same

it’s really bourring cause music is very very good when it works!

the last thing i can try : on synology it’s possible to give precise profile to the upnp (see image)
a lot of profiles are proposed, (see file) , but no one specific for dcs…

Can you give me an advice on which should be selected id useful
in the generics, you have defaut, dlna generic, generic non dlna, naim, realtek, synology, roku, sonos xbmc,…

next step will be for me going back reseller for the bridge to be checked


ps: i use dlink dgs108 swich which are said to be ok with igmp snooping : see under a part of the web page pf the product

IGMP Snooping

When Internet Group Management Protocol (IGMP) snooping is enabled, the DGS-108 listens to IGMP conversations between hosts and routers and maintains a map of exactly which links need IP multicast streams, resulting in greater efficiency and smoother performance.

Any links that do not need multicasts can be filtered, so you’re always in control of which ports specifically receive multicast traffic.

Hi Pierre, I hope I’m not misunderstanding the problem you’re facing, but it sounds like the UPnP servers on your network are not always found by Mosaic, is that correct? :thinking: If so, you’ve rightly suspected that maybe IGMP Snooping plays a part in this problem.

Since this IGMP Snooping issue keeps popping up every now and then here on the dCS Community, perhaps I can explain the issue plainly as it may also help others who might want to understand the underlying problem with IGMP Snooping on Ethernet Switches.

First, some background;

  • A basic part of the UPnP standard is to use Multicast packets to broadcast availability of the UPnP Server to Renderers & Control-Points (e.g. Bartok & Mosaic). The specific protocol used is SSDP - this is just for advertising service availability only, so there’s actually very little multicast traffic.

  • IGMP Snooping is a capability found on some Ethernet Switches (typically “Managed Switches”) that enables it to pass multicast traffic only to those connected client devices (e.g. dCS DAC) who’ve “joined” a multicast group, while filtering out multicast to all other ports.

  • Also associated with IGMP Snooping is something called a “Group Membership Interval”, this is a time-limit that an Ethernet Switch will maintain the list of clients who’ve joined to receive multicast packets. Once the timer expires, the Ethernet Switch will filter out multicast to that client/port on the original list unless the client device re-Joins membership to the multicast group.

  • Client will only request to rejoin the multicast group if queried by a designated multicast Router/Switch.

So, here’s the problem;

  • When a dCS DAC first boots-up, within a few seconds after getting it’s IP address, it will send out an IGMP multicast group join request (it actually sends out 2; one for UPnP SSDP Multicast group, and another for Apple Airplay).

  • With an Ethernet Switch that has IGMP Snooping enabled, it will notice (“snoop”) that IGMP Join request, and it will mark the (dCS connected) Ethernet Port to not filter out multicast traffic. So, when the UPnP Server advertises itself, the dCS DAC sees it, and Mosaic will list the UPnP Server.

  • After some time however, when the Group Membership interval has expired, the Ethernet Switch will just drop that Ethernet port from the “not-filter” list, and expect the dCS DAC to re-join when queried.

  • The problem is, in most Home LAN set-ups, there are no IGMP Query Routers/Switches, so no one asks the dCS DAC to rejoin the multicast group! When that happens, multicast packets can’t reach the dCS DAC because the Ethernet Switch filters them out! And the UPnP Servers disappear from Mosaic.

So, there are a couple of ways to solve the above problem, but the simplest and most efficient way is to turn OFF IGMP Snooping, so that multicast packets are never filtered out on any port.

But if you have an Ethernet switch like the D-Link DGS-108 (and those who OEM that switch) where IGMP Snooping cannot be turned off, then you’ll have “intermitten” problems with UPnP discovery. :laughing:


Hi Anup

Many thanks first

your post is crystal clear, and i assume it’s really the heart of my problem.
it’s perhaps also an explanation why other bridge hasn’t the same problem (ie Lumin)
cause i have made the test on my home…
I have made a query for support to Dlink and to OVH (my adsl provider/r
But you are certainly right and dlink won’t let me stop IGMP. So i have to live with
all the more one of my two dlink is an audiophile upgraded 108 which is rather costly…
So my question is :slight_smile:
Assuming my router support IGMP, it should work ?
i have to look about parameters to activate named like “SSDP”
will i solve my problem with an appropriate router ?



that was exactly my problem with my switch- so I changed switch vendor and it works now!


good news cause this problem is bourring…
what have you bought ?


I bought Innuos PhoenixNET.
Be warned: it takes almost one week to burn in, don’t test it “out of the box”:slight_smile:

thanks a lot
By the way, i have to found cheaper
you are an happy guy !

some détails please cause you seems both to be accurate about igmp
my set is a router, then a switch near the router, then an audiophile switch through a 20 meter ethernet to go to my hifi set

Aqvox tell me he can stop igmp on his SE switch (modified dgs-108)
he will send me one in a fex days
but what about the two other
shall i have to stop igmp on the other switch ?
shall i have to stop igmp on router (if concerned) ?

hope i am near of the holly grail !

If the Aqvox is the Switch that your dCS is connected to, then, yes, having IGMP Snooping disabled on it should solve your issue, but…

If your upstream Router & Switch also have IGMP Snooping enabled, it will likely be a problem as well unfortunately. :persevere:


at this time, i know my enemy.
i consider to simply remove the upper stream
for the router i cross my fingers…and ask the provider

thanks again

1 Like

Only a concern if your UPnP Server is connected to that Router. If both your UPnP Server and dCS are connected to the Aqvox Switch (without IGMP Snooping), then you’re good, no need to worry about the Service Provider Router :+1:t2: :grin:

perhaps another very good news for me
synology/minimserver and DCS are effectively connected to the same switch
so i won’t depend on my provider support (not so efficient…)
for information about dlink 108, aqvox tell me that only c6 revision (my actual) has IGMP
So he is going to send me a swap unit (very friendly indeed)
cause C2 and C5 versions, if still vailable, have not.

as i wrote in another post, problem was solved by changing the dlink switch for en rev2 model which isn’t IGMP. thanks anupc