UPnP disconnects

I have my NAS hard drive hooked up thru a gigabyte switch to play music on my Bartok from my NAS I have to power down the Bartok then restart it or I get a message no UPnP player present. After reboot I can play thru the NAS for an hour or two then I loose the NAS connection again. My Oppo 205 is also connected to the switch and if I turn it on I can play from the NAS even when the Bartok can’t see it
Any idea what’s happening or how to fix this? I have spotty internet so the NAS is my only option at times
Thanks mike

Same exact problem I have with my Bartok and minimserver (Synology NAS). Im relatively new with Bartok - minimserver/NAS setup, working fine for about a month then suddenly showing “no UPnP servers available”. I set up a DHCP reservation (IP address) in my router but still same problem.
Was able to see a post here with the same problem, the suggested change of switch didn’t work, currently no update for any solution.
Hope somebody comes up with a solution.

1 Like

Erwin, I’m sure we can figure out what’s going wrong in your setup.

Are both your Bartok and Synology directly connected to the switch ports on the Router? But you also mentioned a “change of switch”, how does that fit into your setup?

Erwin and i seem to have the same problem. my setup is my router is upstairs with a cat 8 cable from it to a switch along side the Bartok. the switch has a LG tv, Fire Cube, Oppo 205 , the synology NAS and the Bartok hooked to it. after reading Erwins post last night i tried changing to a different Switch and could play music from the NAS, i tried again this morning and got the same message No UPnP servers Available, turned on the Oppo and it see the NAS still. maybe next try a different cable from Switch to Bartok?
happy for any other suggestions

Mike, if you could play music on the Bartok from the NAS last night, then that would imply there’s no issue with your Bartok’s Ethernet cable to the switch. Ethernet Cables are almost never intermittent as such, nevertheless, just check that your Bartok has a proper IP address allocated to it by your Router.

A couple of questions though;

  1. What switch is it that you’re currently using that sits alongside the Bartok (brand and exact model)?
  2. What UPnP Server software are you running on your Synology?
  3. Whats your Mosaic Control App running on, and I assume it’s connected over WiFi to your Router upstairs?
  4. Do you also use a PC or a Mac to normally access your NAS? And how is it connected to your network?

Anupc, thanks for replying
the switch next to the Bartok is a Netgear ProSafe gigabit switch GS108v4
i am using an Iphone 10 to run Mosaic on the Bartok
questions 2 and 4 will have to wait, i cant get my Surface Pro to see the NAS so i will have to dig out an older computer to view the software.
thanks mike

Mike, not sure if you meant as a network attached (via SMB or NFS), but if your Surface Pro connects to your WiFi properly, you should be able to access the Synology’s DSM Web interface over HTML. Just point your Web browser to the Synology’s IP address with a port “:5000” appended to it. For example, “” as the URL.

The Bartok is connected to a switch while the NAS is directly connected to the router thru a LAN port.
Sorry about the statement on “change of switch”. I was referring to a post with a similar problem where changing the switch did not work. I did not try changing the switch myself.
I tried rebooting the switch after which the Bartok connects to the minimserver in the NAS. However, after about an hour, “no UPnP servers available” shows back again in the Bartok.
I can access the audio files (not transcoded) from the NAS (minimserver folder) in my MacBook thru network connection.

Erwin, what Switch is the Bartok connected to (brand/model), and what about the Router (brand/model)?

That’s good, so the NAS is properly connected to the network. Was your MacBook connected over WiFi to the Router, or over a LAN cable to the Switch? I assume from your MacBook you were accessing the MinimServer folder via SMB/CIFS or AFS, yes?

In your case, since your NAS and Bartok are sitting on different LAN segments, there could be some impediment to multicast advertisement packets flowing properly between them. So, maybe we should check the basics; what are the IP addresses of your Synology, your Bartok, and your MacBook?

Anupc, the switch where the Bartok is connected is NETGEAR Nighthawk AC1900 Wi-Fi Range Extender EX7000, while the router where the NAS is directly connected is NETGEAR R6400v2.
The MacBook is connected to the router over WiFi, while accessing the MinimServer is via afp (afp://
IP addresses:
The NAS has its IP address reserved, the rest are dynamic.
Will removing the Bartok from the switch and directly connecting it to the router?
Is there a configuration that is preferentially recommended?

…will removing the Bartok from the switch and directly connecting it to the router make the connection more secure and consistent?..

Anupc , got the surface pro connected to the NAS yesterday and reinstalled an august 21, update, rebooted the Bartok and all worked well all day. Got up this morning and same error message. Looked at my NAS settings and i have it hibernating from 2am to 4am, so i am thinking that for some reason the Bartok only sees new devices on the network when it is rebooted. I will turn off the hibernation sequence on the NAs tonight and see if that cures the problem.

Erwin, your setup looks pretty reasonable, I can’t immediately tell if there’s anything wrong with it as such.

That said, you should probably check and turn OFF (as in un-check) a couple of settings on both your Router and the Extender (if you don’t already have the User Manuals, get them online; R6400v2, EX7000)

On the Router, be sure to turn OFF UPnP (see Page 54), and turn OFF DLNA (see Pages 94 and 96), and turn OFF IGMP (see Page 107)

On the Extender, turn Off DLNA (see page 56).

By the way, I assume the Extender is connected via an Ethernet cable to the Router, and not over WiFi? If it’s interconnected over WiFi, like in a WiFi Mesh, it would be a bad idea to separate the NAS and Bartok, and you might want to put them together on the same switch instead.

Mike, did you mean system hibernation? If so, yeah, probably a good idea to try turning that off. If its HDD hibernation though, it shouldn’t affect your UPnP Server functioning properly, you don’t need to turn that off.

What UPnP Server are you using on the Synology?

Anupc, my synology NAS is using media server as its UPnP player. i poked around in it and didnt understand alot of the settings, i did come across a setting to shorten advertisments if having trouble connecting to a device i changed it from 940 to 800. still had the error again this morning. i did turn off all hibernation modes. i think i need more help with setup of the media server, i will research it on the web.
i am a punch card kinda computer person so Dnla etc. makes no sense to me.

You should install MinimServer on the Synology NAS. It’s what dCS recommends you use as a media server; and it’s very easy to do from the Package Center.

1 Like

Mike, as Paul suggests, it’s not a bad idea to switch to MinimServer for full compatibility sake.

That said, Synology’s Media Server is pretty rudimentary and should work. If the Bartok is unable to see it after a couple of hours, something else might still be going wrong on your network.

I’ve got a Synology NAS as well (which I don’t normally use for any UPnP Services). I just installed Media Server on it with its default configuration. So far it’s always responded to my Mosaic queries (on both my Bartok and Vivaldi). I’ll let it run for couple of days and see how it operates.

In the mean time, one questions and one suggestion;

  • What’s the brand/model of your main Router? Just wondering if it’s doing something funky. Your Netgear GS108v4 Switch is a very basic unmanaged Switch, it can’t be doing anything wrong.

  • When next you have an error accessing the UPnP Server from Mosaic, don’t do anything else just try the following;

  1. Login your Synology DSM Web UI from your Surface Pro
  2. Open the running Media Server settings (like you did when you changed the “SSDP advertisement interval”)
  3. On the left column instead of [General Settings], select the [DMA Compatibility] section
  4. At the bottom of that section you should see a [Device list] button under “Change the settings of UPnP/DNLA devices…”, Click on that button without changing anything
  5. In a new pop-up window titled [Device list], you should see an active list of UPnP Devices that the Synology Media Server sees on your network at that point. Check that your Bartok shows up check-marked on that list (it’ll show up as “Rygel Developers dCS Bartók HDAC”).

If the Bartok does show up on the list, try Mosaic again and see if you still get an error. If theres no error this time, then the problem is likely something to do with the Synology/Media Server. If the Bartok is not on that list though, then there’s likely a network problem somewhere.

Anupc i installed MinimServer last night prior to reading your latest reply had to turn off Media Server and reboot the NAS to get it to work. after it installed the Bartok saw it and played music from my music folder with no issues, this morning i get the error message again, so i go upstairs and get the make and model of my Router its a TP-Link AC1750, about a year old. i also think i found out why i lose the Connection nightly i forgot i put a timer on the router and incoming radio, to shut off for 30 minutes nightly. (when i have internet issues thats the first thing my provider has me do) , So now i no why the signal is getting disconnected now i still need to figure out why the Bartok doesnt reconnect to the UPnP server, my oppo which is connected to the same switch sees the UPnP while the Bartok doesnt until i reboot it.

Mike, actually, UPnP/DNLA doesn’t operate with a permanent “connection” between the Server and Renderer (or Control point). The way it works is that the Server and the Renderer (Bartok) will discover each other by independently advertising its availability over the network via an IP multicast packet every so often (thats the “SSDP advertisement interval” configuration on the Synology Media Server - it advertises itself every 15mins by default), and then acknowledging the other.

If the nightly power shut-off fix doesn’t solve the problem, I’d suggests the same as for Erwin (though technically it shouldn’t be impacting your setup :thinking:).

Pull down the User Manual for the TP-Link AC1750, if you don’t already have it handy.

Access the Router’s configuration Web UI, should be at its default LAN address of Make sure to Disable both IGMP Snooping and IGMP Proxy (described at the bottom of Page 76, and on page 77).

Hopefully that addresses the issue. Can’t imagine what else could be going wrong :crossed_fingers:t4:

One of the unfortunate problems with UPnP/DLNA; it doesn’t always work the same across various vendor implementations. :man_shrugging:t2:

Hi Anupc, my apologies for this late reply. I have been observing my Bartok-server connection for the past several days.
After I turned off the UPnP, DLNA, and IGMP in my router, the Bartok still shows “no UPnP servers available”. I rebooted the Bartok and it worked for about 24 hrs and eventually disconnected again. Finally, I changed my switch to Linksys SE2500 and so far it has been working (a little over 24 hrs). I’ll continue to observe and update you, and Mike!
Although the Linksys SE2500 is a basic unmanaged switch, I don’t know if my previous switch, Nighthawk AC1900 WiFi Extender EX7000, is a managed one (difference?).