Update and Rossini Issues

Dear All,

I thought I’d give you a quick update re my coming back into dCS ownership… Ups and downs basically.

As I previously posted; I bought an ex-demo Bartok around 6 weeks ago which I was extremely impressed with. So much so, I couldn’t resist upgrading almost immediately to a Rossini player which I bought from a dealer who took it (the Rossini), as a trade in. I also managed to buy a Vivaldi master clock at an obscure auction of the contents of an estate. I have to say that both made a fantastic upgrade to the SQ and I am very, very happy!

Unfortunately, from the get go with the Rossini it would periodically drop out of tracks (simply stopping) and then resuming around 5 seconds later. The dealer I bought the unit from was very helpful and offered several options to resolve the issue including taking the unit back. He also passed on a message from James at dCS suggesting re-booting the router. This worked for a long time with no issues. Alas, the issue has arisen again and simply re-booting the router and the Rossini doesn’t work for very long. The time it takes for the problem re-surface varies but sometimes it’s as little as a couple of tracks from start up. MQA tracks (especially 24 bit) seem to trigger it but it happens on CD quality tracks too.

For clarity, I have the Rossini connected to my Virgin media router via a single high quality cable with no switches or other equipment between them. I have also run the Bartok, (which I still have), an Aurender S10 and an Auralic Aries femto (although wireless) with the same arrangement with no issues.

Has anyone had similar issues or offer any advice re this? I guess I should get back in touch with the dealer to get it sorted but I am enjoying the music it’s creating so much I’d rather not part with it for several weeks if I can avoid it.

Please let me know your thoughts…

1 Like

Stephen, can you share a little more info about your network setup, server, control app (Roon or Mosaic), etc. This sounds very much like a network issue rather than a Rossini issue, but that’s just speculation on my part at this point.

1 Like

Hi Greg,
Yes, I think you’re right and that is what James said. I have to admit I am not very IT savvy but my ‘network’ consists of a Virgin Media router which connects from the Virgin TV module and that’s it. Broadband come via cable.
The issue happens with the Mosaic app and is almost identical with the Tidal app.
Is that any help?

Stephen I am not one of the forum’s experts on networks which, as Greg suggests, may well be where the problem lies. So with a view to helping others who have better knowledge than me a little clarification may help.

You say that Rossini drops tracks. I am assuming that you mean tracks streamed from a streaming service but you haven’t actually said so. Do tracks using UPnP from say, NAS, drop? Are tracks dropping out playing silver discs with your Player?

You say that the issue arises only with Rossini Player and not Bartok. As far as a network originated fault is concerned both should act in the same way. The two machines may however be running different firmware. Mosaic has two components, the app which you are using to control either of the machines and some firmware in each machine. They should all match but it is possible that one is different and has not been updated to the latest version v. 1.4.1 Please check using the front panel display or Mosaic via the three line “hamburger” menu ( top left hand corner)/support/versions.

With regard to the the Mosaic app are you using an Android or iOS version? If iOS please identify the iOS version you are using as the latest ones do have settings that can cause problems though dropping tracks is not one that I have come across. Still, worth consideration.


Thanks Pete. Your input is much appreciated.

When I get a chance I’ll take at look at all the issues you’ve raised tomorrow.



1 Like

I dont know crap from shinola but to me it sounds like a clocking issue… as if the 44/48 isnt locked down. Somehow it sees a different sampling input and either shifts from 44(based) to 48 (based) but doesnt shift back. May not do anything but its a thought

Are you trying the Rossini with or with out the Vivaldi external clock?

Good thought Augusto but it really shouldn’t make any difference to the drop out problem suffered by the OP. The external clock does not affect the music signal data at all. The internal clock of either Bartok or Rossini Player is slaved to it. A glitch caused by synch failure should not last for 5 secs and this should not happen as the correct frequency is automatically selected by the clock.

Thanks for all your input everybody.

I am using the Rossini with the Vivaldi clock. The clock has group 1 locked to 44.1 and group 2 locked to 48. It seems to switch between the two when required without issue and the Rossini always shows the word clock icon on the screen as it should.

With respect to software versions and updates; when viewed on Mosaic it shows the following:

App Version: 1.4.1 (146)

Front Panel Version: 2.10

Control Board Version: 2.10

Network Board Version: 1.3.0 (509)

When I check for updates on Mosaic it says there is an update for the firmware to 510. When I ty to download this it seems to take an age (with a message ‘downloading upgrade’) and then either states there was an error downloading the upgrade or it fails to complete the download and goes back to the message ‘check for updates’.

I’ve turned the Rossini off and back on and it is currently trying to download the upgrade but progress appears to be very slow. Is there anything else I should do when ugrading the firmware or is this unlikely to be the issue causing the problem?

Many thanks.


A couple of futher points:

The status when viewed on the Rossini shows:

Main: 2.10

Network: 509

So it would appear the Rossini and Mosaic currently have the same versions.

The player spins and plays discs perfectly and without any issues.

Hi Stephen,

Can we start with some basics please?

Firstly - regarding the update. If you are still having issues and the Rossini isn’t displaying either a message saying not to turn off or a progress bar then please turn off your Rossini at the wall or at the rear panel for 30 seconds, power it back up again and restart the update - that should then go through.

I can’t see anywhere for which specific sources this is an issue?

I see you can play CDs but do you have any other external sources connected, if so do they have any issues?

What streaming sources are affected by this issue?

What does the display show when the issue occurs?

Can you disconnect the clock and let me know whether you still have the same problem? I’d like to get a handle on whether this is a “network” issue or a “clocking” issue and this is the easiest way to isolate that answer.

Best Regards

Phil Harris

1 Like

Hi Phil,

I have turned off the main power switch at the rear and removed the power cable for a couple of minutes before re plugging and switching back on. The display just shows the usual items ie NETWORK on the top half and the filter and clock icons together with volume in the lower half. I restarted the download sequence on Mosaic (on an ipad) and there is a progress bar above which it shows a message ‘Downloading update…’ The progress is quicker re the bar moving now.
There are nomessages re the update on the Rossinin display.

I have no other sources connected to the Rossini. I am running Tidal master drect from my Virgin Media router via a good quality ethernet cable. It is only tidal streaming that is affected both when using the Mosaic or Tidal apps.

I have disconnected the clock and it made no difference. Re-booting the router has a temporary effect of allowing streaming to play correctly for while but not very long. Sometimes it is just a few tracks before the problem reappears.

Thanks for your help.



Sorry, I did not answer one of your questions:

When the issue occurs the play/pause icon disappears and the clocking (word bit length section) goes back to zero. No other changes.


Right… the download progress bar went right across but a message came up on mosaic: ’ Failed to download firmware!’ with another message ‘CHECK FOR UPDATES AGAIN’ in a tab below. This has happened previously.

I have to go out for a while now but any further suggestions would be much appreciated for me to try this evening.

Many thanks for your assistance with this.


Hi Stephen,

OK … so we’re looking at a network side issue and not a clocking issue - that moves us forwards.

If there’s a problem downloading the update AND and issue with streaming then it is definitely looking like there is a network problem so lets start to chop that side down for options…

So let’s swap over the network cable from the “Main” Ethernet connection to the “Loop” Ethernet connection and lets see if you get the same streaming issue (we’ll get back to the firmware update in a bit).



1 Like

Good morning.

So, I switched the ethernet cable to the ‘loop’ socket yesterday evening after which it ran for a straight four and a half hours without any issues. I played mainly MQA and 24/192 tracks which tend to induce the dropping out problem.

It has been playing for a further two hours this morning with the ethernet cable still plugged into the ‘loop’ socket and still no issues.

Just to clarify; there have been no issues whatsoever since swapping the cable to the ‘loop’ socket.

I am obviously pleased it’s working fine with this new plug in arrangement but I’m not sure what this tells us?



1 Like

Hi Stephen,

Right - that gets us a bit further along…

You said you are using a “High Quality” network cable … what sort of network cable are you using?



1 Like

Hi Phil,

It is an Audioquest Vodka RJ/E ethernet cable. It is 5m long as my previous set up had a longer distance from the router to the streamer.



1 Like

Steve, is it “possible” that the ethernet cable was not fully inserted (clicked) into the original port.

Several years ago I was having dropout problems after making some changes and when I went to troubleshoot by swaping out ethernet cables I found that I had failed to fully insert one cable at a switch.

1 Like

Hi Jim,

Yes, I did check that previously. The cables are a bit of a fiddle to get fully into the sockets and click into place.

I’ve just removed it and clicked it back into the main ethernet socket. It’s possible that I did not check sufficiently thoroughly before. We’ll see how we go…



1 Like