RS232 issues after system move


I recently moved my 3 box Vivaldi stack. After hooking everything back up I’m having issues with the RS232 connection. I can control the volume and put both the DAC/Upsampler into standby with Mosaic, but I can’t control any other DAC functions and the system info for the DAC is all zeros.

I already went through the manual and the FAQs here and checked everything suggested. I confirmed every item listed in these two FAQ entries:

Performing the suggsted volume test confirmed it’s an RS232 issue.

I even confirmed conductivity of the serial cable with a multimeter to ensure it was not damaged (2 pins are connected between the upsampler and DAC). Everything looks fine there. The cable has been removed an reseated multipel times too.

I have tried factory resetting both units. I have tried restoring my saved config on both units. I have powered down both units, let the DAC fully power up then started the upsampler.

I seem to be out of options at this point. Is there anything else I can try? Some kind of hard reset perhapes? I’m running the latest firmware on both units.

As you have checked that all of the connections are correct the first thing I can think of is whether or not the versions of the Mosaic control app and the network board in the Upsampler match. Are they both 1.1.3? I would also double check that you have got the correct plug in the correct RS232 socket. It is easy to make errors even when you are convinced it is OK especially if you are working on the rear panel “blind” behind an equipment rack - I’ve done it myself - even after checking :roll_eyes:.

I assume that you have tried a reset of the stack by powering everything off from the rear panel switch, waiting a minute or so then rebooting? NB: the factory reset is not a full system reset AFAIK it just returns the optional settings ( filters, display panel brightness etc.) to their default setting as they left the factory. I see that you have powered down “both” units but say that you have a 3 box system.

Other than that you seem to have checked that the RS232 interface is set to Binary on Upsampler and DAC and that there is not a cable fault by checking the pins with a meter.

Hi Pete, thanks for the reply.

I’m using the latest version of everything. All the same versions were working fine before I moved the stack. I have also plugged/unplugged that RS232 cable many times and checked each time that the connections were correct. I have good visibility behind my rack.

My third box is the clock. I don’t think there’s any way keeping that powered up would impact this behavior, the only connection is the clock cables. I don’t like to turn it off so it can maitain optimum temperature/stability.

I did double check the Binary/Text setting, and both units are on Binary.

Was hoping someone from dCS might be able to suggest some sort of hardware reset. Let’s see.

If, when you powered down the units, you did this from the front panel buttons then this will not reset the system. It needs to be done from the rear panel switches. If you have done this and the issue remains then, given the other actions that you have taken, it is sounding like something that dCS themselves may need to provide advice on. Let me know.

Power down was always done via the rear panel switches. Hoping someone from dCS can offer some advice!

They are back from the Christmas/New Year break on 4th January when , hopefully @James or @Bashcroft may be able to respond.

@James, @Bashcroft, any ideas on what I could try here?

Many thanks,

Hi Jeff,

Just to confirm, are you using the original 3-way ‘Y’ RS232 cable that comes with Upsampler? If so, can you check that you definitely have the Upsampler, Transport and DAC ends of the cable connected to the correct places? Having the ends of the cable mixed up could well cause this behaviour.

Also, check if you don’t have any “bent pins” anywhere; this would be on the device-side of the RS232 connections as the cables themselves are all female-female. DB9 (and the bigger DB25) male connectors are notorious for this - I speak from (almost ancient) experience…