Rossini Apex dac is non responsive

All of a sudden, my Rossini Apex dac has become totally unresponsive.

Multiple switch off/on and power recycling cannot fix it. Even I tried Factory Reset but that neither fixes it.

As I switch on the Dac, it goes to the last selected input. But within a few seconds, it becomes unresponsive with the screen showing multi-color dots.

Urgent help is appreciated !!!

I bought this Rossini Apex Dac on June 2022.


Hi Sourav. I am sorry to hear of this. Unfortunately this sounds like it is not the result of incorrect configuration or something that can be fixed by just pressing a few buttons:

I have not come across this issue before but the screen defaulting to coloured dots seems to me to support the idea that there may be a physical fault. You seem to have attempted the obvious things to try first. Fortunately it appears to still be under warranty. Therefore my advice is to contact your dealer a.s.a.p. However before this you may want to try :

[email protected]

Hi Sourav,

Sorry to hear this, it is not what you were expecting from your Rossini Apex!

Does it look similar to what happened to me:

@Ermos No. My Rossini is booting back and then hanging with coloured dots on the screen.


Sourav. I don’t know exactly why you are saying “no” to @Ermos . He does not say that his experience is identical but similar.

I hope that you read the entire link that he posted which continues:

That seems very similar to what is happening in your case. So maybe the timing isn’t exactly identical and he saw lines, you saw dots. However as well as sound ceasing you both found the display providing random images not information.

Although the precise cause of the issue is not discussed I think that the relevant point is that he needed to contact his dealer and had the Rossini replaced. I cannot predict whether the same thing will need to happen in your case but you should prepare yourself for this eventuality or the need for a replacement part being fitted.

1 Like

@PAR Yes you are right. I did not see the full post. Seeing now. Mostly a similar issue.

However, in the last 1 day I kind of figured out the cause and have some fix for the issues.

Seems like the Rossini was not able to reboot properly because of some (I don’t know what it could be) connection/data coming from my Roon Neucleus. Most probably, it was creating the dCS Clock to go haywire. (I set up the clock to Master, but it was automatically changing to Auto Wordclock whenever Roon was sending data/trying to connect).

So I first disabled Rossini as the device from all of my Roon Remotes. Then I did a power cycle of Rossini, left for 10-15 mins, and did the Factory reset. After that, Rossini rebooted properly and became stable.

Even after that, any data coming from Roon through my Naim NDX2 (output of NDX2 set in digital output model) to Rossini on SPDIF was having a clocking issue. I was hearing (and seeing in dCS display) reclocking sound every now and then.

So next I restarted the Roon server, powered cycle the router, took the ethernet cable out of the ethernet wall port and left for 10-15 minutes, then connected back the ethernet cable.

After that, now Rossini as a device is enabled in my (one) Roon Remote. Running the Roon in Radio mode for almost the last 16 hours. Things are working fine so far. Keeping my fingers crossed.


1 Like

Glad to hear is working even if I am unsure exactly what you have done. I understand the need for a DAC but otherwise why are you feeding a Roon certified streamer ( Naim) into another Roon certified streamer (Rossini)?

Hi Sourav,

I’m not aware of any way that Roon or the Roon Nucleus could affect your Rossini’s ability to start up - should you encounter the same issue again I would strongly suggest contacting your dealer to get your Rossini checked over.

Best Regards

Phil Harris


Phil @Phil, thanks for the input.

This problem surely has something to do with Roon, as I recently added Roon Nucleus two weeks back to my audio stack. And after that, I am kind of continuously and heavily using it.
The screen becoming unresponsive happened on and off within the first few days, but switching off (and then on) the Rossini was solving it. Then, last Friday, switching off/on did not work at all.

I am closely watching Rossini by feeding it from Roon using Roon Radio to see if the problem occurs again. If again this problem happens I would surely contact my dealer.

Thanks again.


@PAR Good question.

I had NDX2 before buying Rossini. I did not sell it after I bought Rossini as I very much like NDX-2’s album art capability. Sometimes I just use NDX-2 as a streamer, feeding the digital output to Rossini (as Dac) over spdif.

On what I exactly did to solve the problem (I am still watching and keeping my fingers crossed) -

  1. Took out the ethernet cable
  2. Restarted the Router by switching it off and on (after few minutes)
  3. Put the ethernet cable back.
  4. Restarted the Roon server
  5. Restarted Rossini


Don’t want to be a distant driver - from New York! : ) - just noting that many on this forum use Roon + Rossini/Vivaldi (including Apex).

In my experience Roon does a (very) good job at software/system integration. Plus, as a software solution, there is very good tracing on errors.

I agree w Pete and Phil that this would not be the first place I would look for the problem.

Glad you got it solved!

1 Like


It is not necessarily a Roon problem. It may also be a problem in dCS’s RAAT implementation in Rossini (or in Mosaic probably).

Here is more context and background.

I have been using this Rossini Apex Dac for the last 1.25 years, pretty exhaustively without any problem. But mostly I was using it with Rossini Transport. Sometimes, I have used it with Roon for a few hours of listening. But at that time, my Roon core was running in Mac Mini (2015).

Recently, I decided to go for Roon Nucleus as running Roon Core on an old Mac Mini had problems. Half of the time, the Roon Server was down for some reason. After getting the Nucleus, I have been almost running Rossini with it for 6-8 hours daily for the last 2 weeks.

So what has changed between Rossini working flawlessly and this problem is using Rossini with Roon Nucleus extensively. There are a few more things. I was kind of never stopping the Streaming from Roon Remote. At the end of the day, I was constantly stopping the system just by putting the Rossini in stand-alone mode (from the front panel switch). Also, I was using multiple Roon Remote simultaneously (from iPhone, iPad, Mac pro).

Given all these, I am sure the problem is getting triggered by using Roon Nucleus. But the problem may be on Rossini’s side. The Rossini may be trying to incorrectly connect to previously open sockets from Roon’s side when I was restarting it after power recycling. It could not handle some situations where multiple previously opened Roon connections it was trying to connect to, and probably the memory was getting corrupted, and it was going into a hanged state within a few seconds of the restart.

Watching it closely now. So far, It has been working fine with continuous streaming from Roon Nucleus for the last 1.5 days. But this time, I am always stopping the music from the Roon Remote (and clearing the queue there) so far.


1 Like

To update here for everyone’s help/curiosity.

The Rossini Dac is playing flawlessly with Neucleus for last 2 months. Never faced the problem again. Even randomly stopping the play by putting the Dac in standby mode did not make the issue appear again.

Seems to me the problem was because of some extreme congestion in the network which Rossini was not able to handle. Restarting the network switch and power cycling all devices solved the issue (just rebooting Rossini was not any help).

@Phil I shall suggest that this extreme case may be added in troubleshoot guide of Rossini with the solution that helped.

By the way, again back to listening to my Rossini Transport mostly. I am realizing the difference even more now (of using the transport over the network/server based music).

Thanks for everyone’s help/support.