Problems with Mosaic

I have been using my Network Bridge with Roon for about a year, without any problems.

On a whim, I decided to try using Mosaic and uPnP, and was shocked to find that it sounded significantly better to me than Roon (I know that it shouldn’t). This makes me tempted to use it all the time, despite the loss of functionality, but…

I find that I can play a few tracks and then it stops, and I get a message saying that the Network Bridge can’t be located, and that I should search for another device. When I do this, the Bridge is located again, but I may or may not be able to restart the music.

Details of the system:

Control via iPad Mini running IOS 13.2.2 (I’ve tried deleting the app. on this and reinstalling several times).
Synology RS214 NAS
Draytek 2860 vn plus router
Cisco SF 200-24 switch
Netgear mini switch (for hi-fi/video)
Cat 6 ethernet cabling
Mac mini (Roon Core)
Nagra Classic DAC

All network connections are wired (apart from the iPad).

Of course, if we can figure out why Mosaic sounds different from Roon (and fix it) that could be a solution.

Perhaps you can clarify: you say you are “using Mosaic and UPnP”. Do you mean UPnP server software?
If so I suggest you might like to try using MinimServer instead. This could run on either your NAS or Mac mini. I’ve been using this combination for a few weeks with no problems at all as regards maintaining connection to the Network Bridge, and with excellent sound quality.
Incidentally you might like to search the web for comparisons of the sound quality from Roon with that from other server software. From what I’ve read many find Roon sound quality poorer.

If the message was something like ‘can’t find music server’ then, perhaps, you could blame the upnp software but if the app is saying it can’t see the bridge then isn’t that something else?

Is this playing a complete album? I mean you select an album and then the error happens a few tracks in? Does the bridge stop playing despite the app saying it can’t see it? I mean can the bridge still see the upnp server?

Hi David

Thank you for your reply.

I have been using the media server that comes with the Synology NAS. Thinking about it, it may be that the NAS doesn’t have sufficient processing power to be used in this way (it couldn’t run Roon, for instance), though I don’t have a huge music library on the NAS (about 8,000 tracks).

I’ll try MinimServer on the Mac and report back (thank you for the suggestion).

Yes, I’ve heard of others saying that Roon compromises the sound. I’ve always assumed that it couldn’t if used only as a core and not an end-point. Now I’m not so sure.

At DavidL’s suggestion, I installed MinimServer on my Mac mini today. The Bridge control software can see MinimServer and the files in my music directory (previously it could always see the media server on the NAS), and it can play a track or two, but then it stops. In other words, no improvement compared to using the NAS media server.

I’ve allocated fixed IP addresses to both the Mac and the Network Bridge. No apparent effect.

I’ve also restarted the Bridge a couple of times. No effect.

All continues to play in Roon.

So it sounds to me that the issue is a breakdown in the app seeing the bridge… I don’t think it’s anything to do with the type or upnp/dnla server you are running.

Sounds like a simple issue of a poor wifi network connection from the tablet/phone. With roon the connection from the controller (roon software) to the streamer is a lan cable. The app on your phone/table is having to use wifi and we all know how rubbish wifi is!!

So is this with the phone or tablet right next to your router i.e. perfect wifi connectivity?

1 Like

The behavior you are seeing is typical when there is an issue on the network between the Bridge and the UPnP server. There are a number of possible reasons for this but the most common is the use of a managed switch that is not configured correctly.

Can you please describe your network setup?

As in my original post, here are the details of the system:

Control via iPad Mini running IOS 13.2.2 (I’ve tried deleting the app. on this and reinstalling several times).
Synology RS214 NAS
Draytek 2860 vn plus router
Cisco SF 200-24 switch
Netgear mini switch (for hi-fi/video)
Cat 6 ethernet cabling
Mac mini (Roon Core)
Nagra Classic DAC

I don’t think the switches are managed (though the Cisco could be). How can I tell, and how can I get the settings (I can log into the router)?

I can see two potential problems here.

  1. The SF200-24 is not a gigabit switch and this can cause some issues for some devices when they attempt to negotiate flow control. This can break the stream and cause dropouts in playback.

  2. The SF200 is a managed switch (all of the 200 and 300 series Cisco switches are). This can also cause issues.

I can’t tell you if the Netgear is managed without knowing the model number.

I would recommend swapping out the SF200 for an SG110. These are all unmanaged and just pass traffic unmolested. It’s also gigabit which will increase the overall performance of your network by a factor of 10.

It’s interesting to see just how many posts I see on ‘a.n.other’ hifi forum which are related to trying to sort issues where fancy managed switches have been used. A thread I’m reading at the moment has over two and a half thousand posts about using switches… generally Cisco brand! I’m all for keeping things simple so I use just standard, dumb, non-managed gig switches.

Thanks, Andrew.

I’ll investigate replacing the Cisco switch, as you suggest.

Will report back in due course.

Unfortunately, there’s a natural tendency to think that a more fully-featured product is “better” than one that is more pedestrian. In many cases this is correct, but in networking there is a serious tradeoff. Managed switches have lots of useful features, but with those features comes a need for “management.” These are not set-and-forget devices and in some cases require consistent care and feeding to keep them working correctly. This is well beyond the capabilities of a lot of people and can get into some concepts which are second-nature to networking professionals, but extremely confusing to those who do not have that background.

The features brought on by managed switches are rarely needed in a home environment. I can only think of a couple of cases where there was no other way to solve certain problems. As long as someone was available to look after them they worked well.

Unmanaged switches are fast, reliable, and they are truly plug-and-play. For the vast majority of people this is all that is needed.

Finally, just to be perfectly clear. There is no performance advantage in an audio system to using managed switches. None whatsoever. In fact, they can often reduce performance when misconfigured.

So do you have suggestions for good, ‘dumb’, gig 8 port switches?

I use a Netgear GS108 that works fine.

As mentioned above I’ve had very good results with the Cisco GS100 / GS110 series. I’ve also had good results with most of the GS series switches from Netgear, but its important to get the non-managed version (which has the dark blue case). The managed ones are in a grey case.

Cheers… tbh my cheap-n-cheerful Tenda switch seems to be okay but it’s a bit long in the tooth.

What about the Cisco SG100D-08? This seems to be fairly low cost and is big enough for my needs.

Works great. I have several of them.



I have had 2 Netgear GS108 in my network for 7 years with no problems.

Reporting back as promised.

Replacing the managed switch with the unmanaged gigabit switch cored most issues.

A residual problem is that some AIFF files won’t play. Wrong kind of tags, apparently.

While investigating these issues, I have replaced my Mac mini with a Roon Nucleus (on loan at the moment), and now I think that Roon (with the new switch and the Nucleus) sounds as good as Mosaic on its own. Also, Roon plays all of my AIFF files - so that’s the overall solution, I suppose.