No UPNP servers available

Dear DCS and DCS community. Tonight, all of a sudden, my dCS Bartok lost connection to my Minimserver. When I select UPNP as a source in Mosaic, it states “No UPNP server available”. At the same time, using mConnect, I can access my Minimserver and even play tracks from it on the Bartok as a renderer. So, I know that Minimserver is up and running and that Bartok can render tracks from it, yet Bartok itself doesn’t see any UPNP servers and cannot browse them. I tried Reset Streaming Interface from the browser accessing the Bartok URL but that did not help. My Bartok is connected directly to the network router and so is the ThinkPad running Minimserver. I looked at seemingly similar topics here but did not see this problem and hence I am stuck. Can someone help or direct me to where to seek help. Thank you

Have you rebooted your Bartók by switching it off with the toggle power switch?

If not, I suggest that you do so, leaving the unit powered off for at least 30 seconds.

Thank you, Jonathan. I did. And disconnected the power cable too. Overnight. None of that helped. Rebooted my router and internet modem several times. No difference.

In which case, please send an e-mail to dCS support;

[email protected]

I’m tagging @Phil

Thanks, Jonathan, done. Fingers crossed.

No problem.
I’m confident that the dCS support team will be able to help resolve the issue.

Tried swapping the network patch cables? Pretty rare but the odd one does fail/act up.

Try a rescan on Minim.

Hope you get it sorted.

Thank you, Gus. None of that made a difference. Contacted dCS Support and awaiting to hear back fro them.

Today, after starting my DCS Rossini and selecting Minimserver as the source, after playing 2 songs, the music stopped playing. DCS I heard noises (switching of relays in Rossini which accompany the startup after turning off the rear power switch)) Mosaic was looking for the device at that time, reporting no connection with Rossini. After a while, Mosaic found Rossini, but after selecting the disc to play, an error message appeared. After restarting Mosaic, I received the message “No UPNP servers available”. Resetting network devices and Rossini did not change anything. Tidal via Mosaic works without any problems. Like others, Minimserver is visible on the network. Is there any solution to this problem?

This looks like an identical problem to the one reported by @rado6666 above.

It does not necessarily seem to be a network issue of the usual variety as the report indicates that only UPnP is showing the error message and that other Mosaic functions are fine.

Such a coincidence is unusual but not all users at any one time are using UPnP and I wonder if there are further examples?

I have checked UPnP on my Vivaldi/Melco installation and all seems normal. However MinimServer2 software comes in different versions for different server brands so if there is an issue with this it may not show up with Melco.

I am speculating that there might have been an update for paid versions that has a bug with certain servers? However I do not know and as @rado6666 referred this to dCS support I am am tagging @Phil regarding your seemingly identical issue.

We are already in touch with Rado and Robert has contacted us this morning - if anyone else has issues can they please contact ME at [email protected]

We have a few people (three so far) reporting UPnP issues so we want to get to the bottom of those however if there was a general “UPnP in the new version is broken” problem then we’d have many more than three - one of those three reports is also (oddly) from a Beta tester who didn’t report any issues (as far as I’m aware) with UPnP with the Beta version so we’re quite curious about this.




The problem in my case concerns not only MinimServer but also other UPNP servers that Mosaic has seen before. I have had JPlay UPNP server installed on my computer for a long time and the UPNP server seen by Mosaic was on the TV. Now none of them are visible through Mosaic. If the problem only affected Minimserver, the others should be visible. I am sure that all three servers are up and running properly. MinimServer has not been updated for a month and only now after updating the network card the problem appeared. So this applies to the clock configuration because I also have a Rossini clock. Yesterday I connected it and today there was a problem with the UPNP servers. Unfortunately, turning off the clock and turning on the dac itself did not help.

This just FYI.

Rossini Apex + Clock. Updated to latest network board version 513.

No issues with UPnP at all. I have Minim running on 2 devices - Melco N1A and QNAP 653D, all on latest versions.

Good luck to dCS tech on finding a common denominator.


The dCS Clocks have no part in anything to do with UPnP discovery or otherwise, contrary to what you might have read elsewhere.

The Clock affects the synchronous parts of a dCS component, whereas UPnP is completely contained within the asynchronous operations (network board, so, Ethernet/IP facing); they’re quite distinct and separate and have little to do with each other.

Resetting the Clock is not going to help when you have networking problems.

Just a note as this is a discussion that always occurs when ever we (and by “we” I mean any company that I’ve been with up to now - several not in the HiFi or AV world even) or any other company do a firmware update …

We will usually spend a very significant amount of time testing updates before they go out to ensure that they work correctly, we also use the same development tools that are used throughout the world, the same compilers that are used by millions of other developers, the same iOS and Android software libraries that are used by hundreds of thousands of other developers and the code that we submit to the Apple Appstore and the Google Playstore goes through many thousands of automated checks by Apple and Google to make sure that we haven’t used any undocumented calls into libraries or haven’t tried to do something in a way that we shouldn’t have that would make the code reliant on a specific release or build of the underlying OS but may break things for anyone else.

No-one reinvents the wheel when writing code nowadays - that was something that wasn’t the done thing even going back 40 years when operating systems were much easier to code for and you could release anything into the world that you wanted to because no-one was checking your work before you did so - today libraries of functions such as those used for network discovery or UPnP browsing are used worldwide by thousands of developers daily and so “obvious” issues in libraries get picked up, identified and resolved very quickly so the chances of a software release happening with a specific function suddenly being “broken” are almost infinitely small

dCS in the grand scheme of things are still a “small” company in that we don’t have a millions of users out there and we don’t force firmware updates to take place without the user agreeing but we do have many tens of thousands of units out there (lets go with 50,000 just for an easy number to work with) and we can see the overall traffic to our update servers (although we can’t see the specifics of who has been to them) so we know that by the end of the first weekend after a firmware update then a large proportion of dCS units out there (lets say 30,000 of that original 50,000) will have been updated.

Obviously I “do” support for dCS… I have a browse around in here to try to keep an eye out for if anyone needs a bit of help - you guys are generally pretty on the ball and either flag up anything interesting that I need to be aware of or try to help out yourself (thanks guys) - and of course we have distributors and dealers in the various territories that we cover - so of course that does help a little with what ultimately gets as far as me but we don’t get that many issues flagged back up on here and I don’t come in on a Monday morning to 20,000 emails and support tickets.

Last firmware update I had twelve reports of “My unit won’t update” (I’m sure there were others that didn’t get as far as me) … and all but three of those were resolved by power cycling the unit and then doing the update after a reboot.

Here we’ve got three reports from three separate customers (across three very different territories) of UPnP issues - now that doesn’t mean that we’re not concerned by these because the numbers aren’t big, to be honest I’m probably more concerned by small numbers rather than big numbers because big numbers would generally indicate that someone’s made an obvious mistake at this end and although annoying / embarrassing that should be easy to fix.

These reports will need to be worked through and could take a long time (although we hope not) to get to the bottom of but HOPEFULLY they’ll provide some information about what are referred to as “edge cases” (odd situations or scenarios that we would never have thought of or been able to plan for) that can then be fed back into the software team if they are things that we can program defensively for…

This is why we also really need to get logs back from people when they have issues updating units, the software guys ask us to try to get information back to them from people who are having update issues because they have built a resilient updater and for 99.9%+ of people it is resilient but for maybe 50 out of that 50,000 updating causes problems and we need to get information back from those people that say “I always have issues updating my unit” because we really do need to know what is happening in their case that means that they always have issues so that we can try to improve the updater to allow for it.

OK - so I hope that kind of helps with how we try to deal with the incidents that invariably do crop up after firmware updates and why a handful of issues reported AREN’T an indication of a fundamentally broken or poorly tested release but ARE in fact of much greater importance to us than 20,000 reports of the exact same thing would be.

(Obviously let’s leave aside the impact that 20,000 reports of the same thing would have on me and my email folder.)

Anyway, that’s my morning waffle over … I need coffee!



Thank you, Phil. Digging into this UPnP situation is very much appreciated.

Hi Rado,
Has anything changed for you after the last update for MinimServer? Unfortunately not for me. Still UPNP servers unavailable.

I use Roon normally but just tried to contact my NAS through Mosaic and it’s not connecting. Same issue I presume. Will play about a bit more.

FWIW, I haven’t experienced any issues connecting with UPnP or Qobuz via Mosaic.

No doubt, the dCS sleuths will get to the bottom of whatever the issue is…

Hi Robert,

it is now nearly three weeks since you first reported the issue and we have inly received three similar reports here, none recently. I think that the responses that you have had indicate that it is not likely to be a Mosaic fault.

Importantly your new post changes the question. Instead of Mosaic you are now relating the issue to a MinimServer update. As I mentioned earlier MinimServer is available in various versions for different server brands. This means that other users posting here may not have the same issue as you. So if there has been a MinimServer update for your installation you may need to contact their user community forum. here is the address:

You will need to register. Of course this may be an error and you meant to write Mosaic.

If you want to contact Rado it is probably best if you page him. To do this you include the symbol @ before his moniker in your post here. I don’t know how this will work with your text to speech reader but this will automatically produce a menu of members whose moniker begins with ( in this case) the letter R. You then click on the menu item and an email will be sent . lookimg at his usage statistics he is not a regular visitor so this is probably the only reliable way for you.

Edit: I see @Omni has written while I was composing the above. This is still too small a number of reports to indicate a Mosaic issue. I suspect a network issue might be a cause, for example if the router/switch software has been altered.