Mosaic Skipping and Partial Playing Tracks

Hello, Happy Xmas, peace on earth etc, etc,
I thought I would fire up my Bartok and play some some music for a family gathering before lunch…
However the old gremlin of Mosaic skipping tracks and playing only portions of some tracks is still present. Some/many times it will not advance through the tracks clearly queued in the “Play Queue”.
This morning I have once again deleted the Mosaic app from my iPhone and reloaded it once again…it played the first track of a selected album beautifully, then refused to advance to track number two etc…so all to no avail. Further attempts resulted in track 1 playing, followed by track 8 and then nothing.
Usually I give up and switch it all off and keep the TV on in the other room for entertainment.
Luckily today on Xmas day there is plenty of choice on the 'telly.
I do feel that if I cannot overcome this in 2022 I will have to consider some sort of change…

My system is
Bartok Headphone type, latest update. XLR Line out at 6V.
Benchmark LA4 passive XLR pre-amp.
ATC SCM50 active towers plus a JL Fatham sub in a 2.1 configuration.
Iphone 13 with latest Mosaic and latest iOS.
I play Tidal and Qobuz higher quality only, hardly ever use the services now though as usually cannot advance beyond one track.
I have a 50/55 Mbps connection.
Because of the way UK houses are served with British Telecom Broadband (into the downstairs garage) I am connected wirelessly via a 1GB Devolo GigaGate wireless connection to the router (in the garage). A hardwire connection cannot be made without much building work of having doors open and cables trailing across the house.
I previously had wireless (in the same exact location) PS Audio DirectStream and all was well. I have mentioned this problem before and we appear no further forward.

Be well, Sean.

Hi Sean and I am sorry that this is affecting your Christmas.

There are a couple of potential solutions with your setup. Remember that Mosaic is in daily use by thousands of others without such issues.

The first that strikes me is the unusual connection between router and house, I will leave that for consideration by the network experts here such as @Anupc . However it being Christmas traffic here is low and may continue as such so you may not get any response on this for a while.

The second is that we have had reports of odd behaviour with Mosaic installed on iOS devices running iOS 15. The solution is to go to settings and disable icloud/ Private Relay. Try this.

Just a detail, but the LA4 is not a passive preamp, but an active one.

Hi Sean, and sorry to hear that you are having problems.

Although Mosaic is the “front end” to the player software inside the Bartok, it is actually the Bartok that does the heavy lifting of locating the tracks in the play queue and retrieving them from their source. Unless there is something wrong with the network board on your Bartok I think it could be the wireless connection between Bartok and router that is causing your issue.

I know you have said that running a cable from Bartok to router is not easy but I think it would be worthwhile to do it, if feasible, to determine if it solves the problem. If it does then you will know that the wireless connection is the problem in this case and can move forward from there. It would also be worth running a speed test from a PC connected by ethernet cable to the Bartok end of your Devolo GigaGate to get an indication of the actual download speed you are seeing there and also the latency which might be relevant to your problem.

If I understand you correctly BT have installed your master socket and router in the garage. I also have BT broadband but my connection comes into one of the rooms at the front of the house not the garage. I assume that you have internal landline BT telephone sockets in your house. If you do you should be able to have one of these sockets converted to be the master socket and move your router to that socket which might make it easier to then run a network cable to your Bartok.

I persuaded the BT engineer who installed my BT Broadband to use the internal telephone wiring to locate the master socket and router in the study on the other side of the house rather than in the room where the BT line enters the house. Depending on your internal telephone wiring you might be able to do the same but will probably have to pay for an engineer visit to do so.

I hope these thoughts are helpful to you. Best wishes, David.

1 Like

David Wiggins,

Yes, you are correct in most/all that you say.
I think the main issue here is that the dCS Bartok is not a “wireless” device, in that it needs a hard wire connection to a router. I think I recall there is a need for 2-way data movement which is only available via a hardwire connection.
I am of course trying to use it as a wireless device due to domestic wiring limitations. This problem went away for many months until recent software upgrades in Mosaic, Bartok and IOS (iPhone) saw it return with a vengeance. There was no problem whilst I had PS Audio equipment at any time. (Prior to that I was vinyl only, with the move to DAC being a HiFi box/rack/gear reduction exercise).
Most of our household tech, is wireless these days, those that are not usually being exited over time.
I would like to imagine that this “wireless” issue has crossed the minds of those at dCS as I bet I am not the only one wrangling with this.
If I had my time again I might have given this particular issue more attention in my selection criteria…

However I do appreciate the replies!

It may be I have a bigger problem…

I swapped the 1GB Devolo GigaGate, a “wireless” 1GB data transmission system (which used to work with Bartok fine) for the previous Devolo DLan 1200+, which uses the actual household wiring for signal transmission. This also used to work perfectly fine with Bartok. This known to be working, downgrade did not work as Bartok played a single tune and then skipped down the play list and exited.

So I opened up the garage and chocked doors open and ran a single data cable direct from my latest fully working BT Broadband Hub to the rear of the Bartok. Same issue no change. The Bartok recognises the network, loads and plays one HD track very nicely via Mosaic and then jumps down each track in the Play Queue until it passes the last track and stops. No more play.

Given that I am now connected direct to the fully operational router there is no more I can do now.
So I think the problem I am experiencing is an internal Bartok one…

I have switched all off and isolated power on each occasion in case of any shock to the units.
PAR Pete Rogers; Settings/iCloud/Private Relay (Beta) is set to off and always has been on my IOS device. Thanks.

I think I have had a sense of humour failure on this matter, so I have put the 'telly back on…

I am afraid that is not necessarily a correct conclusion. Virtually every example of this type of issue is caused by the network. Your router will have many available settings and I anticipate that one or more is not compatible with Mosaic. A solution is likely to be found simply by deselecting one or more of these settings via your router’s software ( usually accessible via your browser).

Of course one needs to have an idea of which setting to look at (e.g. IGMP Snooping). It is very unfortunate that this has happened during the Christmas/New Year period as not everyone is available to help. I am going to tag our network expert @Anupc and hope that he might be able to pick up on this when and if he is available.

Thanks Pete.
The whole system was working…nobody touched anything…and now its not…(sound of man screaming ARGHHHH…)
If a fairly standard BT Broadband router is not going to work with Mosaic fairly easily then I have very definitely found myself in the wrong situation.
I am just going to reboot the BT router one more time…
I do appreciate your input…well done!

Sorry Sean , but that is not likely to help. You need a bit of patience now until , hopefully, you can get detailed help on your router settings. Remember that BT will have preset them for what it imagines that an average user may require which will never suit all comers.

In the meantime back indeed to the telly. I can’t wait for the next episode of the new Around the World in 80 Days… :smiley:

Rebooted BT Broadband router for umpteenth time this Xmas and Mosaic/Bartok is now at least willing to play more than one track…however is still skipping through playlist and not stopping to play all tracks in order…

Track skipping problems when streaming Tidal and/or Qobuz are almost always Internet connectivity related.

It’s possible that the Bartok’s network board has a problem, but that’s highly unlikely and would not manifest as an intermittent problem as you’ve described it.

As David suggested, you might want to test the actual speed and latency of your internet connectivity - thats most likely where the problem is. Even if you haven’t changed anything in your setup, the number of other Internet users and usage among your neighbours will have a direct impact on the performance of your broadband (it’s heavily aggregated).

A quick way to test your Internet performance as how your Bartok would see it, is to connect a Laptop’s Ethernet port to the 2nd Ethernet port on the Bartok (turn off WiFi on your Laptop). Let your PC acquire an IP address from your Router via the Bartok, and test your internet speed with BT;

If you really believe the Bartok is at fault, your dCS dealer should be able to help.


Thanks for your assistance.
I have once again begged, borrowed and stolen data cables and connected via the second “Loop” port on the back of the Bartok. It is seeing:
On an older Macbook, using the Apple USB Ethernet Adapter I have 35.6Mbps download and 7.35Mbps upload. With the Apple Thunderbolt Ethernet I have 34.7 and 7.76.
On a newest latest 16" MacBook Pro there is no difference to the above readings using USBC/Thunderbolt3.
(This compares to pure WiFi on the same machines in the same area reading as 54.9Mbps and 8.38Mbps).
We used to have 8 and 10Mbps some time ago, which served OK but not wonderfully fast. We feel our current speeds are good. This is also the max BT can supply in our district.
These speeds were whilst other members of the household were using many/all iPads/iPhones/TVs/devices etc.

I think if the reality to getting the Bartok fully working relies on my neighbours or children not using X or Y internet enabled devices when I wish to listen to music then this will be a different matter…

I should add it makes not one jot of difference if I connect the Bartok direct via a long ethernet cable threaded through to the rear of the BT router in the garage. Same result for direct cable or via dLan or via GigaGate. Whichever physical method of connection is used the same speeds are seen and the same Bartok/Mosaic behaviour is seen.

When interrogating the BT Home Hub Broadband Router online with the BT app, it shows the Bartok as “connected”.

I am done…

Hey again Sean, your broadband’s download speed of 35Mbps is plenty for streaming to work fine. So, something else is going wrong in your setup :thinking: It’s still most likely network related rather than some hardware problem with your Bartok

A couple of things you can check;

  1. Verify that your Bartok’s streaming board is working fine - just load a couple of tracks onto a USB flash and plug it into USB2 on the Bartok and play them. If that works fine, your Bartok’s streaming board should be fine (both Ethernet and USB are on the same streaming board).

  2. Check that your Bartok’s DNS address is properly pointing to your BT Router, or to one of BT’s DNS servers. You can check your Bartok’s DNS via it’s webpage. The consequence of a wrong DNS is that your Tidal stream may be coming from somewhere other than the UK and that could cause the types of track skipping issues you’re facing.

Let see if the above will give us some additional clues as to what’s really going wrong (before any next steps). Good luck! :crossed_fingers:t2: :grin:


I quickly tried the second option you suggested and the Bartok is not pointing at one of BT’s DNS servers.
It is pointing at which is not on the page of BT’s DNS you linked through to.
Presumably I need to change this…how?

I think I have got to the point personally whereby this is all too much for me to play music!!

Be well, SeanS

OK so I have had yet another go at this and can see that one can override the DNS settings on the “network Settings” tab. I have overridden the DNS setting to the primary BT one of
Afterwards the Bartok shows exactly the same faulty behaviour with both Tidal and Qobuz.
I will check via the USB behind as you suggest when I can summon the attitude that does not involve dropping the Bartok from a height onto a concrete surface…SeanS

Sorry for jumping in. No dropping pleeease :blush: There will be a solution in time.

That IP address looks like the address of the router you have at home. You can check by entering that address into your webbrowser like this

The administration page of the home router should appear. If I get @Anupc right, that is fine then. Either @Anupc or your dealer or dCS should be able to help you along. I had a similar issue with my Bartók and the device had to go to dCS for repair.

Thank you for your help Marco.

This whole thing is too DIY for me, the moment I am having to reach out like this and start sorting DNS and checking this and that cables etc etc then I am done.

In truth I think going for a “DAC” has been an interesting trial, but my vinyl is in storage and needs to return. No seeking ethernet/router/codes/iOS/versions/updates/settings just to simply play a track or two…
Be well…SeanS

Hello Sean @SeanSullivan,

vinyl only is a viable solution to the issue. :slightly_smiling_face:

If you have an ‘IT guy’ in the future you can call in for initial setup and eventual glitches that makes the intricacies of network streaming workable for all who are legitimately uninterested in fiddling around.

Be well too! And may your new year unfold to be a good one.

Kind regards,

Network based computer audio (and a dCS Bartok is just a single box version of this) does initially require a steep learning curve for beginners as it is ultimately based round a technology that was not originally intended for home use but for professionally managed systems in a work environment.

There are basic home audio solutions that require less knowledge ( e.g. Sonos, Brennan etc.) but these are not intended for “ultra high end” use.

Whilst it can be daunting to look at things like configuring routers etc., with a small amount of time and patience it is quickly learnt and worth the effort. In the end it is little more challenging than configuring a new TV ( just clicking on the right menu items).

Moving to vinyl only is a great option ( I have always run a high end vinyl system as well as my digital one). However its viability depends upon your musical tastes. Outside of pop /rock music there still remain few new releases. However vinyl replay at a high end level also requires the acquisition of a lot of knowledge, for example regarding the settings and geometry of a pickup arm and cartridge, what VTA v. SRA means, arm length v. effective length, null points and alignment, azimuth, zenith etc. Basic electrical knowledge is also needed , for example how to match a cartridge to a phonostage, use of appropriate EQ etc.

If you have attained the knowledge for vinyl then adding the basics required for network audio should not be too challenging. It just requires a small amount of patience to learn. Once you “get it” you will have access to a far greater range of music than your own LP collection can provide.

So far Anup has just been running through some potential issues to isolate what you really need to pay attention to.

However I do appreciate that this is not for all. I have friends who are terrified of the whole thing. So if you decide that the small amount of technical knowledge needed lies outside of what you want to be involved with then I wish you every luck with your vinyl only system. It can be a very satisfying medium.


I can understand your frustrations, unfortunately the backend of how streaming works is rather complicated (keeping in mind these things operate at unprecedented scale and endpoint flexibility, so it’s somewhat necessarily complicated :grin:).

Also, you’re not alone in experiencing track skipping issues. If you Google “Tidal track skipping”, you’ll see loads of people complaining about various different hardware and software platforms experiencing the exact same issue.

Considering that you’d rather not “DIY”, my suggestion is to get your dCS dealer involved; whether it’s a possible hardware issue, or even a network issue, I’m sure they’ve encountered it before among their dCS deployments. :crossed_fingers:t2: