Mosaic keeps dropping Minimserver 2 link

I recently swapped out the Power line adapter feeding my Bartok for a Mesh Extender. All worked fine but then Mosaic in iPad started dropping link to Minimserver in uPnP menu. The Minimserver library shows up periodically but keeps disappearing. I have updated, rebooted, restarted everything without success. MConnect on my iPad sees the Minimserver library consistently and Mosaic will play files on the QNAP NAS using Jriver as server. Bubbleupnp also works with Minimserver on Android but not Mosaic. So Mosaic is the odd one out. Any suggestions?

I can’t offer any advice to solve the issue but you are not alone and Mesh systems have a record of causing problems. Just enter “Mesh” in the search box to view the history.

Keith, you could check a couple of things to ensure your Mesh setup is as “compatible” with dCS as possible. For a start, check the following;

  1. Check that all the multicast settings are properly enabled and that there’s no multicast filtering going on among the Mesh nodes

  2. Check and turn OFF “IGMP Snooping” on the Mesh devices

Generally, just these two will likely solve most issues associated Mosaic/dCS properly discovering UPnP Server without being interfered with. Other platforms/software may use other techniques to detect Servers, so it’s not always an apples-to-apples comparison with dCS/Mosaic.

Which Mesh WiFi APs are you using by the way?

I am using a Dlink Eagle Pro Mesh WiFi extender in isolation - not a full Mesh network per se. The device is simply paired with my Talktalk WiFi hub router using WPA so I have no control over its settings as such. I have just played an album from Minimserver but when it finished and I went to select another album the connection had dropped.

Keith, I took a look the manual for your Dlink, you’re right, there’s not a lot that can be configured.

Unfortunately, Dlink has a history of working poorly in dCS environments.

The following thread (and my explanation of what’s going on) is an example of another user who encountered the same issue as you with a Dlink Switch, who ultimately solved the problem by changing to an alternate Switch.



Unfortunately “consumer” grade kit does have a bit of a chequered history - especially when bringing in kit that sidesteps the “correct” way to do stuff, myself I’d say that you were doing well not having any issues with the Ethernet over Powerline adapters in the first place as they can also be very problematical in themselves.

We recently had a customer whose setup had been working absolutely fine for some time and decided to move everything over to an Eero mesh setup and in doing so Mosaic discovery and streaming became unreliable / unstable - moving back over to the original hard wired setup works fine.

We don’t do anything that is in any way “out of spec” as far as Ethernet traffic is concerned, we use the same recognised, published and approved function libraries for Android and iOS that everyone else HAS to use so it becomes a bit difficult when presented with a request to “make it work with my kit” and we ask for diagnosis to be done by connecting devices by cables.

In this case Keith it is going to be effectively impossible to know why Mosaic is now getting intermittent contact back to your UPnP server - is your UPnP server connected to the same Mesh Extender that your Bartok is connected to? If not then that would certainly be worth just checking to see if it makes a difference but the reality here is that we’re really looking to try to find out whether there’s a way around the shortfalls of the Mesh kit…



Thanks Anup and Phil for your replies and it does look like curtains for the Dlink. I have used Powerline for many years without problems but recently I have experienced pauses on films - my Oppo is on the same switch as the Bartok in turn fed by Powerline. It made me wonder how clean the Bartok feed was and I have to say the Dlink is a clear improvement - unfortunately a wired connection is out of the question. The Dlink is actually a WiFi repeater so I guess the mesh part is just future proofing… I would have expected the Dlink to work in tandem with my router but it appears not or at least not always. I am looking at the Netgear EAX20 as a replacement but probably overkill just to send a WiFi signal to the next room.