Lina DAC doesn't play from Tidal Connect and Spotify Connect

I purchased a Lina DAC and Clock in January 2024 and am very happy with it apart from this intermittent problem.
After turning the Lina on, connecting to Roon, Mosaic (iOS phone), Tidal Connect (iOS phone) and Spotify Connect (Android phone) is sometimes very difficult. Once a connection is made everything works. The desired track is displayed on the DAC screen but playback will not start.
I contacted Roon support and they suggested restoring factory settings on the Lina and reinstalling the Roon Server. This worked for a few days but the problem is back.
I have a reliable ISP provided router with 50 Mbps down and 12 Mbps up

what you describe is not unknown and virtually always has a simple solution related to your network and specifically the settings of your router.

You need to open your router’s settings and check them. In particular ensure that IP sniffing is disabled.

We also see issues arising from mash installations but that may not apply here so let us know otherwise.

By ”IP sniffing” Pete means IGMP Snooping (and mash=mesh)…

Can you describe your network? Just the ISP-supplied router? What make/model? Is the LINA connected directly to it with a cable? No other switches/MESH/WiFi bridges involved?

Serves me right for writing at 3:30 am, half asleep on the way back from a nocturnal visit to the loo ( the penalties of age) :grin:.


Jeff, as Pete and struts001 rightly point out, the likely cause of your problems with Spotify/Tidal Connect is your home network, not your dCS Lina (otherwise we’d be seeing hundreds of complaints :grin: ).

By home networking I mean the networking device(s) in-between your Lina and your Tidal/Spotify Control-Points (your iOS/Android devices), which includes your WiFi Access Point, any Ethernet switches, and potentially your Internet Router - if it’s in the chain between your Lina and your iOS/Android device.

Both Tidal and Spotify rely on mDNS in order to (a) discover your dCS component, and (b) use the received responses to control the dCS component to connect over the Internet to the Tidal/Spotify Servers. mDNS works on the basis of multicast packets. So, if your home network has any issues with multicast, including any filtering, it will fail.or not work reliably.

One way to test your network for proper compliance is to use an “mDNS browser” - a good example for Apple MacOS is [Discovery - DNS-SD Browser on the Mac App Store (there are similar “freeware” mDNS browsers for Windows as well) - when you use these mDNS browsers, if your network is running properly, your dCS Component will show up in the tool.


Useful tool, thanks @Anupc.

Something I don’t understand though. Presumably the discovery mechanisms in Spotify Connect and Tidal Connect work similarly, and the device identity is provided by the device itself. However in my case the two services seem to be receiving different information. My Vivaldi Upsampler identifies itself to Spotify Connect as a Rossini (although the MAC adress is correct) whereas it identifies itself correctly to Tidal Connect. Strange…

Those specific lines you’re looking at are the respective Connect “agent’s” responses (so to speak, from within the Vivaldi Upsampler) to the mDNS Browser’s Service discovery query.

Without getting into the weeds of why - I don’t know the full technical details anyway :laughing: - the way each of those agents are coded/bound within the dCS Network board is different, hence the difference you’re seeing.

What matters though Is that when the Spotify/Tidal Apps are launched, they will issue a similar mDNS Service Discovery query across the network, the dCS component responds, and each App will register their respective agent’s response in order to control the dCS. At which point the dCS component shows up in each App as an available Spotify/Tidal Connect device.

1 Like

My router is a TP-Link model VX220-G2v and is the only network device I have (I assume it is a combined modem and router)
The Lina DAC is connected directly to the router by ethernet cable.
Thanks for the helpful tips regarding “changing router settings” but I don’t know how to access this. I will phone my ISP provider, as no documentation was provided with the router.
Most of your responses relate to Tidal and Spotify. My primary use case is Roon. Do you think the IGMP Snooping setting will also fix my Roon experience?

I phoned TP Link Technical Support regarding a IGMP Snooping setting. They advised the TP-Link VX220-G2v does not have IGMP Snooping functionality.

Thanks @Anupc
The attached screenshot from Discovery DNS-SD app shows the Lina, but the system was working normally today. The Lina was playing from Roon at the time. As I posted above my router doesn’t have IGMP Snooping functionality.

Jeff, I went back to your original post to revisit your actual problem statement.

A couple of comments/Questions;

  • First of all, Roon has nothing to do with Spotify/Tidal Connect; if you’re using Roon for your personal music collection or even accessing Tidal via Roon, it does not utilise Tidal Connect (and neither does Spotify, which isn’t support on Roon anyway)

  • When you mentioned “is sometimes very difficult” did you only mean the one problem where the track is displayed by doesn’t start? Or were there other problems?

  • Do you experience the exact same problem with Roon as with, say, Spotify Connect from your iOS/Android?

  • Your Broadband speed of 50Mbps/12Mbps is pretty low, I assume you’re on an xDSL service since your ISP’s Router is the TP-Link VX220-Gv2? (Are you Australia based? In which case did you mean 50Mbps/17Mbps Down/Up)

  • On IGMP Snooping, it’s not clear that’s the root cause of the problem you’re encountering. That said, I do wonder if TP-Link Support was telling you the truth, because according to the VX220-G2’s Specifications, it clearly claims to support “Advanced Function IGMP V1/V2/V3” ← which typically means it has the ability to Snoop IGMP. Problem is TP-Link doesn’t make a detailed configuration manual available for that model (presumably because it’s meant for Service Providers), so we can’t be sure.

In any case, if you can provide some additional clarity to the problem you’re facing. Also, it’s probably more appropriate to call in the dCS cavalry @Phil and email [email protected] so Phil can log this issue.

Thanks for your quick reply and your help Anup.
@Anupc @Phil
Further details in response to your dot points:

  1. Yes, Tidal Connect and Spotify Connect have nothing to do with Roon, but I am having intermittent problems getting all three to play the first track of a session. When attempting to play from Roon to the Roon Ready Lina DAC, the DAC can be selected as an output device but when I try to play a track, often no music is played. Roon skips a number of tracks after unsuccessful playback and eventually gives the ROON Error “Too many failures, stopping playback”. Track names appear of the display of the DAC but music is not played. After scattergun actions like powering off various devices and trying multiple times, I can eventually get music to play. Not fun.
  2. It is always the same problem - the track will not play
  3. It is always the same problem - the track will not play
  4. I don’t understand wrt speed. The Speedtest app test speed was 50 Mbps DOWN and 12Mbps UP this morning & it is now 50 Mbps DOWN and 16Mbps UP. Once a connection is made to Tidal, I can stream 24 bit / 192 kHz with no difficulty. Yes, I live in Australia. TPG is my ISP through fibre to node NBN infrastructure.
  5. On IGMP Snooping, I opened the router’s web configuration and looked through all the tabs. There was no mention of “IGMP Snooping” or “IGMP”. I have good general computer skills, but know little about networking. I followed your link to the TPLink VX220-G2v Specification and noted the reference to “Advanced Function IGMP V1/V2/V3”

Hi Jeff,

Couple more questions/things to try:

  • Is your Lina the only Spotify/Tidal/Roon endpoint on your network? If not are the others working fine or are they showing similar problems?
  • I presume you are using the Roon Ready Lina device (the upper one in the pic below) and not the AirPlay device (lower one). If so, please could you try the AirPlay device and see if you experience the same problem?
  • Can you describe your Roon Core (now Server)? What sort of device is that and how it it connected to the Router?

My thoughts so far:

  • IGMP Snooping (which is poorly named IMO, should be called “IGMP Filtering” or “IGMP Pruning”) can be problematic because different vendors’ implementations vary widely. If the Snooper prunes/filters incorrectly clients that have advertised interest in certain multicast traffic might be blocked from receiving it. There have been a number of examples of this causing problems with audio streaming so this was a fair suggestion by Pete. However it is a little bit of a shot in the dark since when it works correctly it is not an issue. I have IGMP Snooping enabled on my (Unifi) network and Roon/Tidal/Spotify work fine. It could feasibly be the problem here but I would personally have it as a bit of a rank outsider.
  • Your network is extremely simple and you haven’t made any configuration changes, this rules out a raft of possible causes. However, the symptoms you are describing would still seem to point towards a networking issue so it could just be that something in the default configuration of your Router is not playing nicely with these services. Testing different transports (per my suggestion above) might shed some light on this.
  • Absolutely fair to tag Phil and he may be able to help. However given that Roon is the “piggy in the middle” here and has good logging capabilities (unlike Spotify and Tidal), this might actually be easier for Roon support to diagnose. I suggest opening a ticket there too and uploading log files from your Roon server. That will show exactly what chain of events is leading to the “Too many failures…” error.
1 Like

Thanks for your help Struts101,
I have already filed a support request on the Roon community forum. They recommended resetting the Lina to factory settings as well as reinstalling a Roon server instance. This worked for a while, but the intermittent problem has returned.

ROON Server - M2 Pro MacMini 16 Gb RAM Roon V 2.0 Build 1407- Ethernet to router
Local music files - USB external hard drive , ALAC music files
Tidal streaming
72,000 tracks

Control - iPad Pro 2nd generation mid 2020 Roon V 2.0 Build 1407

The dCS Lina DAC is the only serious Roon endpoint in my system. I can always play music to my iPad and iPhone as endpoints without any problems.

At the moment, the problem isn’t occurring so trying Airplay will not prove much. I brought up the intermittent Tidal Connect and Spotify Connect failures so that the dCS forum wouldn’t blame the Roon server for all my problems.

Just now, I changed my router settings to reboot the router every day at 3AM to see if this helps.

Did someone from Roon support actually look at your log files or was that just standard troubleshooting advice from other community members (it was good advice but it doesn’t seem to have helped)? If not I would upload them and tag someone from Roon Support.

Given the simplicity of your setup I’m afraid I can’t think of any other troubleshooting steps to suggest at this point. If/when the problem recurs please test with the AirPlay device. That might just shed some light on the root cause.

Yes, a Roon staff member looked at my logs and the error message.

Sorry Jeff, then I’m out of ideas for now. Unless @Anupc has any other angles I think we will have to see what dCS support suggests. Tagging @James as Phil is in Munich.

Please report back when you solve it. This one really has me scratching my head.

Apologies for not picking this up sooner. I am also in Munich, just found a quiet corner with some Wi-Fi.

Jeff, I am sorry to hear you’re having such frustrations with streaming. We can also pull logs from the Lina to look through, and I think that will be useful here as the same issue is happening both on Roon as well as Spotify and TIDAL.

You can see instructions for downloading the log files here:

if you can please send them to [email protected], I’ll get them over to our engineers to look at.

Thanks @James
I read the instructions regarding extraction of logs. They seem to indicate “reboot your device” means Powering Off the Lina DAC and this erases log files. Up until now, Powering Off the DAC is one of the only ways I can overcome the errors and listen to any music. I am also in the habit of Powering Off the DAC (rather than putting it into Standby) after each listing session because the device runs quite hot and I have environmental concerns.

The errors are not currently occurring and the DAC is powered off. I will extract the logs but don’t expect them to provide useful information. Now that I know about erasing log files with Power Off I will extract the log files when I next have a problem.

Hi Jeff,

Sorry for the delay - as James just mentioned I’m out with the guys in Munich for the show.

(By the way guys, James is no longer in support so please tag me if you don’t mind - or better still email [email protected] and it will come and find me.)

What we need is the logs extracted from your Lina DAC JUST AFTER you have had an issue - whether that’s playing from Roon or playing from TIDAL etc.

If you can pull the logs from the unit as quickly as possible after you’ve had an issue then post it over to [email protected] along with a covering email letting me know exactly which issue you have had just before pulling the logs then I can get that over to our software guys to take a look.

Given that you are having so many intermittent issues then it would be interesting to actually get your Lina onto a different network (maybe a friends or your dealers) just to confirm to yourself that you don’t get the same issues there - I’m very much of the opinion that this will turn out to be an issue with the underlying network getting itself in a mess somehow - the difficulty is finding it and fixing it as domestic networking kit (especially that from ISPs) seem to have so many “undocumented features”…