Issue in reproducing DSD files

Hello. I’m having issues in reproducing DSD 256 files purchased on Blue Coast. I’m using Nucleus streaming through a dCS Bartok (which perfectly supports these files) via Roon, and when I try to play the music the app loses connection with the server. Can you pls help? Thanks.

None of the dCS DACs support DSD 256 files. The maximum rate is DSD 128. So even if the Nucleus serves the file to Bartok , Bartok cannot do anything with it. That would appear, in your case, to also produce some sort of outcome with Roon.

Thanks Peter. :frowning:

Peter, what format would you recommend purchasing with respect to DSD files? Should I get DSD 128 or it doesn’t really matter because I can upsample it? Thanks. F.

A DSD128 file and a file upsampled to DSD128 are not the same. An upsampled track contains no more information than the originating track. A native DSD128 track actually has more information captured during the recording.

One further issue is that you need to verify the provenance of a purchased DSD128 track. Many on sale are just upsampled from PCM masters which may even have been. 16/44.1. That will not be the case for Blue Coast nor if you buy from e.g. Native DSD (who normally show the original recording format on their website). HD Tracks and Highresaudio are also reliable. However in recommending download vendors I am aware that not all may be available to you depending upon your country of residence as the rights to sell given recordings are normally territorially limited.


Thanks Peter!

I’ve tried with a DSD128 file and it gives me the same issue. What am I doing wrong?

No issue in playing a DSD64 file.

Can you play the DSD128 file using dCS Mosaic instead of Roon?

1 Like

I am trying now. Copied files onto a USB.

Yes Peter it works on the Bartok. So it must be a Rob setting.

Rob? I know Roon Operating Core but not Rob as an acronym.

1 Like

Lol I meant Roon. :slight_smile:

Yes, I think that you are probably right and your problem needs to be raised with Roon:

Thanks Peter. I’m doing that already.

Roon can deliver any, and I do mean any,DSD file to Bartok (and any other dCS DAC). Roon will automagically downsample tracks to 128. I am playing Polarity Project, a 256 file, right now this way. It requires no special settings, but the fact that your Bartok will play 64 and nothing else suggests you might have changed a setting that prevents Roon from operating correctly.

FWIW, like Pete, I recommend purchasing/downloading your hi-res files in the format of their original recording/engineering. Blue Coast, Sound Liason, Native DSD provide this information about their recordings.

1 Like

As @PaleRider says, Roon has no problem playing DSD files.

All info here:

In order to stream from Nucleus over ethernet to the Bartók, the DSD needs to be in DSF or DFF format.

1 Like

Erno, thanks. Confirmed that they’re all in .DSF format.

Roon supports uncompressed DSD64, DSD128, DSD256, and DSD512 content in the DSF and DFF file formats.

In Roon, go to Settings - Audio, select your networked Bartók settings (2 gear wheels), and check under SHOW ADVANCED at the bottom if the Max Sample Rate (DSD) is set to: Up to DSD128

If you change something there: first click Save before leaving.

1 Like

Here is the screen @Ermos is describing:

1 Like