Error when trying to update to Control Board 1.4.3

Hi there,

Tried to update to 1.4.3. The app updated fine, but Control Board update failed at the verification stage (tried 3 times) on my Vivaldi:

…but worked fine on my Bartók (eventually, it failed to reboot after installing the update so I power-cycled it whereupon it disappeared completely, but magically reappeared on upon restarting the App):

1 Like

I have a similar problem trying to update my Bartok. Tried contacting support, as suggested, but no reply.

Hi Struts,

Give the Vivaldi Upsampler a reboot (fully power it off, give it 30 seconds, then power it back up). Does that clear the issue?

1 Like

Yes, thank you James, that did it. After a reboot of the Upsampler just prior to updating the update downloaded, verified and installed without incident, and the Upsampler rebooted and reappeared in Mosaic completely of its own accord.

Incidentally, that may have been why I didn’t have the same problem with the Bartók. I hadn’t been using it so it was newly switched on when I performed the update, whereas the Vivaldi Upsampler had been switched on for a few months beforehand without a complete power cycle.

1 Like

Hi Ian. I hope that you will find the forum useful and enjoyable.

When it is necessary to reboot Bartok before installing the Mosaic update this means switching it off from the rocker switch on the rear panel. Then wait for 30 secs. I hope this fixes your issue.

Oddly, this is the first update where I did NOT have to do a full reboot! My Bartok was in the sleep state and I ran the update from the mosaic app on my iPhone - Super smooth this time!

On my Rossini Apex the network board software has updated but the App version has not and is stuck on 1.4.2 (150). Check for updates shows nothing to update.

Any clues

You don’t say what you are doing.The app is not updated from your device but from either the App or Play store. Have you done this?


I have Mosaic on my iPad and a mac mini (apple silicon). Going to the Apple App store on both devices shows there is no update available.

Mosaic on both devices showed the update for the network board and that’s been installed.

Screenshot 2024-05-09 at 13.54.52

Dear guys,
If you have the dcs device in standby, you must turn off with the rear button, wait 30 sec.
Turn on, start the update, when finish turn off, wait 30 secs and all is fine
I have do this with my dcs rossini apex dac.

It became available in the Apple App Store earlier this morning. It wasn’t in the queue of apps waiting to be updated but when I refreshed (click on your avatar top right and then swipe down) it popped up.

1 Like

I am sorry that you are having problems but there certainly is an update available on App store. I have just installed it.

Note that you may need to find Mosaic App in the store and select it. Only then will an " Update available" text appear.

A wizard. A true star. :grinning:

Interestingly it hasn’t yet appeared as an update for me.

Thanks Pete I have found it now. Now for the fun bit updating the Vivaldi.

Hi Ian,

I’ve not had anything through on the support email address - who or where did you contact?

Are you now sorted?



1 Like


I don’t know what actually changed but now with the new Network 513 firmware, it takes roughly 60s to kick off playing internet radio URL from my media server (Mosaic radio do not have that delay). I checked on the log and I could not pinpoint anything an issue that I could related to that specific issue.
Everything else seem to work like before but it is quite annoying as I did not have to really use Mosaic except for the updates.
As I guess it will not be possible to get more details on what has actually changed in the code, is there an official way to roll back that update?


Nothing has changed on Mosaic v. 1.4.3 regarding radio. In fact I was listening to BBC Radio 3 last evening with the new software and it was the same as before.

Remember that radio services on Mosaic are provided via airable in Germany. I would guess that you may have been experiencing an internet delay. These tend to be temporary so I suggest that you try again now that it is some hours later.

If you like let me know what station you were trying and I will see if I also have issues. However your message is a bit confusing as I read it that the issue may be playing from your media server and not Mosaic.

1 Like

The update doesn’t work from my app. Should I do it on the hardware? Thanks.

1 Like

Have you downloaded the latest version of the Mosaic app?

You will need to do so in order to effect the update.

1 Like