Error when trying to update to Control Board 1.4.3

You mean delete the existing app and installing a new one on the App Store?

I’m taking about the upsamper software update 513.

You don’t need to delete it, just update it.

I suggest that you do an app store refresh.

In the iOS app store, select your profile icon (top right of the screen), then swipe down to refresh.

That should result in the latest version of the Mosaic app appearing…

Once the app is updated, the control board update should be available…

1 Like

Hello Pete,

Thank you for your reply.
When I am talking about delay, I am not saying that the sound has a delay vs the “aired” one (as far as I know there is always some delay taking into account that the source broadcast can be received via various channels which will introduce processing delays as they have to receive it before it is set available), I meant that now it takes roughly 60s between the moment I click to “play” and the moment it does it. It is enough for my default controller (which is not Mosaic) to consider that the action failed.

In order to present internet radio to my other controllers (BubbleUpnp, Lumin) I use a router as media server which accept URLs. It was a solution in place long time ago and so far has never been an issue. This is on that setup that I have an issue now in 513.

As I mentioned, it is not on Mosaic (from which radios are still fine) as I gave up long time ago to use Mosaic to manage my music library (way too basic).

Something has definitely changed in UPnP processing. My concern is only when a controller presents weblink that it will relay. The same weblink added as custom radio in Mosaic is Ok. The media server presentation of the weblink was fine before 513 and still fine with my other renderers (the dCS is not my only way to test UPnP) …

Thanks. What about the firmware? That needs to be done in the hardware?

The firmware update is accessible in the Mosaic app.

Press the support icon

Then press versions

then press check for updates…


All good now. Thanks for your help :heart::+1:

1 Like

That’s good.

It’s my pleasure.

1 Like

Thank you. However you say:

So Mosaic works fine, yes? Frankly I do not understand exactly what else you are doing with your router nor how Mosaic v 1.4.3 comes into it. Sorry.

Mosaic is not my main controller and it simply cannot with the basic set of features it has.
But you are right, I probably should have opened another topic as regardless of the title, this one is about Mosaic 1.4.3 and not much the control board itself in fact…

Yes. Incidentally I understand that routers can have limited ability as servers ( mine displays a few UPnP albums) but I think that this is all out of scope as far as Mosaic is concerned. You could try support at dCS who might be more help than me.

[email protected]

My concern is definitely not related to the software Mosaic (the controller app running on Android or Iphone) but the control board firmware embedded in the upsampler itself that is upgraded from Mosaic.

I will eventually send a message at the email you provided.

I have dCS devices for quite a while. In the past I would not have post anything about that here. However the last time I contacted them directly, I have been told to use the forum to begin with. This is the reason why I tried (without much hope but…)

Not sure they will bother more taking into account that the change of behaviour is visible outside of their own application. But who knows, I can be lucky…

Actually, (this thread is mislabeled), the 1.4.3 update was to the dCS’ network board, not the control board.

Interesting problem you have, which Router are you using if I may ask? (You’re right that dCS wouldn’t need to solve this considering it’s outside of the dCS ecosystem, but the solution may potentially be a simple one).


I am using an old FRITZ!Box 4040 for that purpose. Funny thing, the issue is only on radio URLs. Local files work fine. I checked the “logs” which are available for us without pinpointing a consistent cause. The Upsampler seems to pause for a while. To be frank I don’t necessarily expect them to change but I just would like to know what they did on UPnP processing and having the ability to roll back if eventually I cannot find a way to cope with the new behaviour.
Next step is to put a port redirection to capture the traffic to check if it is really “sleeping”. :rofl:

I definitely recommend opening a new Support thread on this issue, and/or emailing [email protected] directly.

The network board firmware can be rolled back if you want, especially as there were no other corresponding dependent code (except for Mosaic Control). dCS would need to supply you with the 1.4.2 (511) firmware directly though. Edit: Rolling back Mosaic Control (if required) would be much trickier.

By the way, just so that I get your setup straight; you’re using the FRITZ!Box 4040 as the UPnP Server, your dCS as the Renderer, and BubbleUPnP as the control point.

Is that correct? In which case it’s similar to Mosaic controlling MinimServer/MinimStreamer for Internet Radio rendered on dCS (except MinimStreamer requires .m3u files for the streaming URLs though, not plain URLs like the Fritz!Box). It’s been awhile since I played around with MinimServer/MinimStreamer, but just gave it a very quick spin, there’s definitely some funkiness going on :laughing:

Roughly speaking yes.
The actual setup is a bit more complicated. My main uPnP server is a minimserver (v1.x so no subscription) on a dedicated server. I tried MinimStreamer and I don’t remember why did not keep it (stability issue as far as I can recall and useless complexity but not sure).

I am using Lumin as control and therefore had to introduce BubbleUpnp Server as OpenHome “proxy” for dCS upsampler as network card is not OpenHome client (I also like the OpenHome added features but it is another discussion). The Fritz!Box was added just for internet radios. It replaced another router/media server in that role. This is a long time choice because I simply could not find the radios I wanted in the mainstream providers and allowed me to alleviate that from my list of requirements for the controller.BubbleUpnp app is my “backup” app. I used it for a while and it is still a quick way for me to check if an issue is linked to my usual controller. The same way, in the discussion, I removed the BubbleUpnp proxy from the path to investigate.

Thank you for the idea on Minimstreamer. However as far as I know, it is a paid option of Minimserver and now with their subscription model it is exactly what I want to avoid.
If I can understand what is actually happening during that delay I can think of a proper solution. For the time being it will be just a bet. Let’s see if dCS support has so me time to waste with me :rofl:

That’s a lot of hoops you’re jumping through :slight_smile:

MinimStreamer is actually a “free” module available with a paid MinimServer annual subscription (which isn’t too bad really, just the price of a couple of CDs).

1 Like

As I said, it is the concept of subscription for something that does not require any central infrastructure nor not that much packed with features that changes regularly that kills me. For me it is just a way to ensure regular incomes.

About the complexity, I fully understand that it may sound complicated. But it is not much more than the old Roon architecture (simplified now from what I saw) they sold a lot in the past.

So far no answer from dCS. I guess, as expected, I will have to find my own way… :rofl: