Device discovery issues

Have now had a while to explore the latest iteration of Mosaic. Seemingly it takes a good bit longer than before to locate our Rossini. It gets there but noticeably much slower.

Can you describe the issue that you’re seeing in a little more detail? Once you’ve connected to a device the reconnect on restarting the app or bringing it into the foreground should be nearly instantaneous.

Nothing has changed in the device discovery code although we do rely on the underlying operating system (iOS or Android) for those functions. Have you done an OS update recently as well? Are you running iOS or Android?

Hi @Andrew
Thank you for your response. When I select Mosaic ( the units are already on) a spinning wheel appears saying searching. It does this consistently. It takes around a minute to locate the Rossini. We haven’t changed anything except iOS 13 on the iPad - that said the previous iteration of Mosaic ran on that platform without issue. Hope this helps. Happy to add whatever else you may need.

We retained the previous app simply for the scrolling ability - you may have seen my earlier support for that feature here online.
We now can’t access that - network error it says. Maybe iOS 13 clash?

That’s definitely not normal. If I see the spinning wheel at all it’s for a fraction of a second and that’s only when I’ve explicitly killed the app. If I’m just bringing the app into the foreground it’s a near-instant connection.

The way the mechanism works is that once connected the app remembers the network address of the Rossini and uses that for all subsequent connections. If it can’t find the device at the cached address then it will display the device selection screen after about 10 - 20 seconds. There are a couple of scenarios where this can take longer, but those aren’t common.

If you power down your Rossini (fully off, not just standby) then you could be encountering an issue where its being assigned a new address when you power it on, but the app is looking for it at the old one. The timeout before you’re taken back to the device selection screen should be less than 20 seconds.

Another issue could be that you’re experiencing some intermittent connectivity issues on your wifi network and that’s causing the initial connection to be made, but data transfer between the Rossini and iPad is intermittent. The app won’t timeout in that case but it could take longer to establish the connection.

As a first step remove and reinstall Mosaic Control on your iPad. This will remove all of the cached data and give you a fresh start. See if that helps and please report back. If that doesn’t help then we can dive into your network.

Forgot to respond to this.

When you see that error in the old app you should be able to pull down on the device selection screen to get it to refresh. Give that a try.

Evening @Andrew Just back home. Will give your suggestions a go tomorrow morning and report back. Thanks!

Good morning @Andrew

Our IP addresses are fixed

I removed the Mosaic App and re-downloaded as you suggested. No change. The blue wheel just kept spinning. I attempted to find the Rossini again just before beginning this response and it took in excess of a minute for Mosaic to find it.

Re the previous app. I did as you suggested and pulled the tab down to refresh. No luck. A message appears saying “Error. Connection failed” - it won’t play at all.

Look forward to having your further thoughts.

Kind regards.

Ok, it was worth a shot :wink:

When you have some time can you please describe how your network is setup in terms of hardware used (switches, router, access points, etc)? What’s most critical is the pathway between the iPad and the Rossini, but having a clear picture of the total setup is useful.

Do you have an alternative device that you can use to run Mosaic (iOS phone or Android phone/tablet)?

Hi @Andrew. Mosaic runs on our iPhones. It’s exactly the same experience - blue wheel spinning.

We haven’t changed anything in the chain - this delay in finding our Rossini only arose with the new Mosaic software and the effect was immediate.

Our Rossini is connected to our Router by an ethernet cable. Our Router assigns IP addresses - the Rossini has a fixed IP address. The Router is connected to the NAS by means of another ethernet cable. I’ve just double checked to ensure the IP address is the same as usual for the Rossini and it is.

Are you assigning the Rossini’s IP address using a DHCP reservation in the router or via a static address assignment via the Rossini’s embedded web page? If it’s the latter are you absolutely certain that the DHCP address range that the router is set to hand out doesn’t overlap with the fixed address of the Rossini.

In general static IPs aren’t necessary and provide no benefit, but can cause some problems at random intervals if the network isn’t carefully managed. If you have the Rossini setup with a static IP assigned through the webUI then I’d highly recommend switching it back to DHCP. If you feel you need to access the embedded web page frequently then you can do that using http://dcs-rossini.local/ (the trailing / is required as some web browsers attempt to do a search instead of hitting the host)

Please download the log package from the Rossini (via the web page) and send it to me in a private message through the forum. Best to do this after the Rossini has been online for a bit and you’ve had several instances of the delayed connection.

Beyond that it’s worth doing a factory reset of the network interface via the webUI. This will convert it back to defaults (including DHCP) and you’ll need to login to streaming services again as well.

@Andrew thank you for your reply. I’m afraid you are assuming I have a reasonable understanding of all this - I don’t.

I’ll answer what I can.

The IP addresses for all connected devices are issued by the router. No problems at all up to date and the Rossini has behaved faultlessly since installation. That is up until the recent Mosaic software update.

Perhaps the best course is to send you the log package you seek from the Rossini. I would need a step by step idiots guide from you however as I have no idea how to set about this procedure.

Here are the instructions for retrieving the device logfiles:

How to download your device log files

We may occasionally request that you send us a copy of your device logfiles for further analysis. This is a simple process, but there are a few things that you need to be aware of:

  1. The logfiles are erased every time you reboot your device.
    Keep this in mind if you observe a strange behavior or a repeat of one for which we’ve previously requested logs. If you’re tempted to reboot your device to clear an error condition please grab the logs before you power cycle it.

  2. The logs may contain some personal information.
    Depending on the level of debugging enabled the log package may be capturing additional information about your network, playback, or streaming service credentials. As a matter of practice, please don’t post your log packages in a way that’s publicly accessible (that includes uploading them to a service like dropbox and then posting a link to the file in the forum). Please send directly to Andrew via a private message in the forum.

Download Instructions

Grabbing the logs is easy:

  1. Find the IP address of your device. If you don’t know how to do this then you can find instructions >>here<<

  2. Enter the IP address into a web browser on a computer:


    46%20AM



  3. Click on the Device Settings tab


    03%20AM



  4. Find the “Download system logs” section and click on Download


    27%20AM



  5. Depending on your browser and operating system you’ll be asked to either open or save a file called tmp_data_logs.tgz. Choose the option to save the file (remember where you put it). Some operating systems will partially decompress the log package so you might find a file called tmp_data_logs.tar instead.


    34%20AM



  6. Attach the file to a private message on the forum and send it to Andrew for analysis. Please include a link to the forum post that describes the issue illustrated in these logs, otherwise these things become hard to track.

If you want to do a reset of the device then that option is available on the same screen as the log file download. Be sure to download logs before doing a reset.

@Andrew. We’ve been digging further and it seems that despite the Fing app telling us the Rossini IP, further investigation suggests the Rossini has moved IP. Can you hold off any further investigation till we get thus checked? I don’t want to take up any more of your time until we have this looked into.

If the Rossini IP has jumped that would explain why the Mosaic app is struggling to find it though quite what has happened to cause all this we don’t yet know. We are absolutely certain that when out IT guy left us he ensured that the IP addresses were static. Something would seem to have happened which has upset this. I’ll get back to you with more info when we have our IT guy have a look.

1 Like

Hi @Andrew. Right our IT guy had a look at this earlier. We are now back up and running and the Mosaic app is working perfectly as is the refresh on the older app. All good!

I’m struggling to put into words what he discovered and as I confessed further up my knowledge of all things computer, codes etc is very limited indeed.

That our IP addresses are fixed is indeed the case. That said there was another item, a wifi extender which seemed to swap places with the Rossini IP. That would explain why the app couldn’t find the Rossini. Why they were able to perform this swapping places feat is less clear. The wifi extender has now been assigned a different fixed IP and the Rossini is happily sitting at its old spot.

I can only sincerely apologise for leading you on this bizarre journey. Why all was working perfectly up until we updated the Mosaic software I don’t understand - but it was.

Thank you for your time and patience!

1 Like

Fantastic! Glad to hear that you’re back up and running.

I had suspected that this was an issue with two devices fighting over the same IP address as that would lead to the exact behavior you were observing.

No need to apologize and I’m happy to hear that it’s sorted for you.