Bartok will not update

Tried to install update, downloaded ok but failed verification?

Hi Steve,

Did you try fully rebooting the Bartók before commencing the update? (Switch it off with the power rocker switch on the rear panel, leave it for 20 seconds, switch it back on again)

Hi, i have a message error when make the update.
What can i do?

Hi Francis,

Exactly what error message do you get?

Have you fully rebooted your Bartok before doing the update (as above)?

Thanks, I have now and it’s updating :pray:

1 Like

Now working !

Thanks for letting us know Steve. Make sure to update the app on your iOS / Android device as well, either from the App Store or Play Store.

James am I missing something but on both my i-pads the App store is still showing Mosaic 1.2.1 version not the new one (in the UK)

I updated iPad in UK ok. Had to search a few times though

The iOS version is definitely live. If you open up the App Store, go to Account (the blue person icon in the top right), and refresh this page by swiping down (like you do to refresh most apps), dCS Mosaic Control should show up with an update from there.

Does that work?

Thank you, James got it now

1 Like

Phil, I reboot the Bartok
and all is ok now. Thanks
Francis

2 Likes

I had to perform it twice. On the first instance, it did not complete the download of the 4,096 chunks and displayed a Checksum message on the screen. Switched it off and tried again and it went thru.

Seems to be going on fine now, was getting stuck on the first few attempts,

Seems IOS needs to be on before the firmware not after.

Hello,
In Canada, Power cycled the Bartok before updating. Began the update and download. Appeared to download, update and verify then screen prompted…“Bartok did not reboot. Restart the Bartok”. Power cycled but nothing further happened. Now the screen is white and shows no further progress.
Should I power cycle again?

Hi Warren,

Can you send a phone-photo of the display on your Bartok and a screenshot of any information that Mosaic is giving you to [email protected] please?

Phil Harris

Hello Phil,
Did power cycle and the update hadn’t installed properly so reinstalled.
Appears fine now.
Versions show:
App Version 1.2.2 (131)
Front Panel 2.00
Control Board Version (2.0)
Network Board Version 1.2.2 (508)

Note this version list is displayed in a differing format from the page in your Bartok 2.0 release notes which leads to some confusion but it appears I have completed the update.
My thanks,

1 Like

I had the same error. If this is essential why was it not made clear in the instructions? Mine failed and now says ‘CHECKSUM’ on the front panel. This is very annoying.

Third time lucky for me. I have to say dCS, knowing what the key steps in the process are before starting would have been helpful.
If I see a button that says ‘update’ these days you expect to be able to click on it and it get on with it. Not to have to search the internet to find out why it failed. Getting a message saying ‘CHECKSUM’ on the screen and a circle of doom on the app is a bit scary for a non technical person and in all honesty not good enough I’m afraid. Even having found out I needed to restart the Bartok and beginning again seeing a message on the Bartok screen saying ‘please restart’ while there is a circle of doom on the app is concerning. Do I restart now? Wait for the app to confirm this? It’s too much guess work. Instead of getting all over excited in your PR first please think about your users/customers a bit more and how the user experience of an update will work and what we need to know in advance. Push us a message with clear instructions or better still programme that in to the app visuals. For a 21st century tech company this is not acceptable and feels more like trying to restart a Microsoft pc in the 90’s. We’re not all geeks and techies you know. We just buy your equipment to listen to music!

I was stuck at this screen for around 10-15min, then i read here and power cycle my Bartok.

Then i got this screen

And when i click “check for updates again”, there is no finding.
It can play music, but just fail to check for update. Or is there server side problem, maybe too busy ?