Bartok stops playing on Network mode

Hi,

My BArtok does not seem to like playing via Network anymore.
No matter the source ( Roon, Spotify, Tidal), it plays then stops. Might be a minute or 10.
No issues through Roon-USB.
Seems like it<s losing it<s path or connection.
No other changes have happened in my home network.
Thanks
Bernard

1 Like

Normally these things are down to the network but here are a couple of questions:

Are you using Mosaic controller app to select the services that are stopping after a few minutes? Have you tried uninstalling and reinstalling a fresh copy on your device from App Store or Google Play Store?

Is your Mosaic control app installed on an iOS device? Has the device been updated to v. 13.5 during the last few days? If so this update is causing problems with all sorts of 3rd party apps and that may be the root of your issues. A reinstall as above seems to be the most common solution.

As is often the solution with many computer equipment and peripherals issues, have you tried switching your router /network switch off and on just to refresh it?

Hi,

Did all of your steps; Reinstalled Mosaic on Android and Ipad; rebooted router and switches.
Is there not an error app I can send to troubleshoot?
I lose connection every 5 minutes for no apparent reasons.
thx

Thanks. Your issue seems not to be part of the global problems that we ( and owners of other marques) have been experiencing over the past day with the non-local services interface.

There is one other member here, Robertt, who may be reporting a similar issue as he has also says he has issues with loss of program via Mosaic every few minutes. If they are the same issue then as far as I can tell from this forum it seems both unusual and limited to Bartok.

As I said earlier such problems are usually related to the network but that is hard to deal with remotely as there are so many possible permutations and it is probably beyond my competence anyway.

I am unaware of any error wizard for Bartok.

It may be that one of the dCS staff guys ( Andrew or James) could assist when they next log in? They may be aware of such a problem occurring for Bartok owners who do not post here.

Thank you.
We’ll see what they say.

dCS?? No help here?

Hi Bernard, I’m not dCS support obviously :grin:, but maybe I can make some suggestions;

First off, try streaming again after you do a reset of the streaming interface on your Bartok - you can do that from your PC/Mac using a Web browser to your Bartok’s IP address. Select the “Device Settings” tab, and click on [Reset streaming interface] in the second to last section (see below);

If that doesn’t help, you might want to check if you have a home network/Roon problem from the point of view of your Bartok. You can do that by;

  1. Plugging your PC/Mac into one of the Ethernet switch ports same as your Bartok (disable any WiFi on the PC/Mac)
  2. Install and run a Roon Bridge on that PC/Mac - https://roonlabs.com/downloads (scroll to the bottom for “Roon Bridge”)
  3. Enable that PC/Mac as another Roon end-point via your Roon Remote (the same way as you did with your Bartok previously)
  4. Select that PC/Mac as the Roon Zone, and try streaming an album as you normally would.

That should tell you whether you’ve got a network problem somewhere, or something possibly faulty going on with your Bartok.

Good luck and let us know how it goes! :crossed_fingers:t3: :slightly_smiling_face:

1 Like

Thanks so much.
I will try these steps and let you know.
Regards

Hi,
So I did a streaming reset as you suggested. I did not know we could do this.
I also downloaded Roon Bridge but I don’t see it in my zones. I do not know anything about Bridge, never needed it.
At any rate, so far, after 4 hours of streaming, no drop offs, no stoppages.
This could be the fix.
Thanks so much.
Bernard

Hi,
I believe I set up Roon Bridge, I renamed it but it says it’s ’ airplay streaming '.
What does this mean?
Is this less quality than thru my Network?
The Network has shut down a couple of times, seems to happen when I use my phone/phone wifi, even though my audio system is cabled.
Thx

One more thing… the Networked Bartok loses connection now frequently and disappears from my Audio zones, yet the Bridge is still visible.

Can dCS help me troubleshoot please?

Bernard, I’m not sure if I might have inadvertently confused you; just to be clear, the suggestion to try Roon Bridge was so that you could check your home network/Roon Core, independent of your Bartok - the Roon Bridge client makes your PC/Mac a Roon end-point, just like how your Bartok is a Roon end-point.

Back to your issue though, from your description above, it looks like perhaps you’ve got Roon misconfigured for your devices.

Let’s simplify it. Using dCS Mosaic, does the problem of the Bartok “losing network connection” happen?

Hi, thanks for hanging in there.
It works with the bridge.
All apps work thru Mosaic. It seems that when I open up Roon, with or without Mosaic. I get network drop off. Not with USB, only Network
I’ve now taken it up with Roon.

Thx

Glad to hear it. :slightly_smiling_face:

Hi dCS, My Bartok still loses network connectivity every few minutes and is unlistenable. I’m forced to use USB.
I’ve tried in vain to figure it out.
I will call my dealer and he’ll just stare at it , not knowing what to do.
Can anyone out there help me?

The network board is pretty similar in all current dCS products that feature it. So the problem that you have would likely be well known if related to the board as it would affect owners of Network Bridge, Bartok, Rossini and Vivaldi. But , insofar as this forum is concerned, I know of only two people reporting it, both Bartok owners, yourself and Robertt though identifying the source of his problem seems to me to be complicated by his need to use the text to voice translator on his i-pad to navigate Mosaic.

So there may be two rogue network boards out there or the problem may not be related to it at all but to the network which I know that you have tried to isolate as its source . However reading the whole thread I still think this may be a network problem. Why? When you used Roon and it all worked OK Roon was not using the wired connection but was “airplay streaming” i.e. using Apple’s answer to Blue Tooth. Lossless but limited to 16/44.1. You then say :

But if you were airplay streaming you were not actually using the cable. So this too suggests that it may be that it is a network problem, perhaps wholly or partially related to the wi-fi. Have you checked its signal strength?

If it is not a network problem then that seems to leave the possibility of a faulty network board as I think everything else has been tried by you . If so it cannot be solved here. You would need to involve your dealer whom you do not appear to have much faith in from your remark above.

In the UK I would pick up the phone to customer services at the dCS factory at this point just to ask if they had any experience of this problem. Is that possible with dCS Americas?

Incidentally I once had a problem running Qobuz on a a PC where it kept dropping out.I was convinced it was Qobuz’ fault. The solution? Changing the port I was using on the router. It seems that not all ports may be equal.

Finally, before involving your dealer or dCS have you a friend who uses streaming? Could you take your Bartok to him/her to try it out to see if the network connectivity problem recurs in their setup?

Bernard, is Mosaic-Bartok not working properly anymore? If so then I’m pretty sure your local dCS Dealer can help look into it, no?

When you say the “Bartok still loses network connectivity”, there could be at least half a dozen individual things going wrong, and maybe only 1 or 2 that are actually due to the Bartok.

So, isolating the underlying problem you’re experiencing will be a matter of systematically isolating the problem domains with explicit details of what works and what doesn’t. Otherwise we’re just making guesses.

Start with the basics; Does the Bartok ever lose its allocated IP address? Or is the Mosaic App ever unable to see the Bartok?

Apologies for being so late to the party here! There are a few things that will help narrow down the cause of the issue, but dropouts rarely suggest faulty hardware with networking, more to do with setup or compatibility of devices.

  • Firstly, could you give me a brief rundown of your network? How is the Bartók connected to the network, does it go through any switches or directly in to your router? What router are you using?
  • When the Bartók loses network connection, what exactly is happening? Does the music simply stop playing but you can still see the app in the same way as before, or does it kick you back to the device selection screen and begin searching for the Bartók again?
  • I’d like to confirm exactly how you are playing back with each streaming service, as playing back via AirPlay brings with it a lot of other potential issues. When you are playing back via Tidal, do you do this from within Mosaic or do you use the Tidal app on your device?

Thank you Anup and James for your questions.

Let me describe the network to James’ first point.

Modem/Router supplied by Service Provider: ComCast Gateway (made by Technicolor Model: CGM4140COM); This is new, since 2 months and could be the culprit, even though the service provider techs see no issues;
Internet is fed to living room via Powerline devices, used for 10 years with no issues;
There is a dlink switch in living room, then to my NAS, Bartok, Mac Mini and TV.

The issue is: When using roon, the music stops as Roon seems to lose the Bartok Network in it’s Audio Devices; I sometimes have to restart Roon or the Bartok to get back to my Bartok as an Audio Device. all other Audio Devices are still present in Roon.
This only happens in Network mode.
When not using Roon but Spotify or Tidal thru Mosaic, Bartok will stop playing suddenly also. I still see the Spotify logo on the Bartok screen when it sops playing. I have no other information on this, sorry.

How I play music:

  • Open Mosaic; Open roon, select Bartok Network as the Audio Device; Chose sont, Play;
    Never use AirPlay; All is cabled, no Wifi.
    Tidal is played mostly thru Roon, but sometimes using Mosaic ;
    I have had stoppage playing Tidal or Spotify with Mosaic also.

My NAS is played thru Mosaic;

The situation only happens in Network mode, not USB.
Thanks again,