Bartok skips first DSD track or even crashes!

I have a few DSD64 albums (dsf format files). Now sometimes, when told to play a full album, the Bartok will skip the first track. If I force it to play the first track only then it will often then play but sometimes will refuse BUT a few times it’s completely rebooted the Bartok! After the reboot then the track/album plays fine. It’s not just one album. I have half a dozen and it will randomly display this behavior with any of the albums.

Playing from UPnP server using Mosaic (later versions).

I’ve been testing it for several albums over the last couple of hours and it’s rebooted several times now. btw I saw the same reboot issue the other day when I accidentally double clicked Play All on an album selection. May or may not be related.

Any suggestions please?

What UPnP server software are you using?

Just to clarify; when you say it is rebooting is it that you select Play track 1, it does not do this but Bartok switches off and then reboots itself without you switching it back on from either the front panel or rear switch? Or is it really going into sleep mode rather than cutting mains power? Or have I misunderstood?

Asset UPnP

Yes… full reboot without me touching anything. I get the clicking of the internal relays etc… just like when I manually power up.

Zero issues playing flac files.

Is it perhaps an issue with the UPnP server slow at delivering the data stream? The ‘server’ is a Windows 10 PC (i3) with a 2TB Samsung SSD for music storage. The Asset is running on the same Windows PC.

I hope that this is may be straightforward. Please read this FAQ:

You are using Asset and it appears that some commands being sent by Mosaic are not understood by Asset so it will not serve the file for track 1. Why it only happens with DSD64 .dsf files I have no idea.

That brings us to the reboot. Again there seems to be some kind of misinterpretation where a play command is being interpreted as Sleep. It cannot be Power Off as recovery from this requires a manual action. It is not possible via remote as, of course, being unpowered the Bartok cannot then recognise any commands.

I would suggest initially installing MinimServer2 for Windows and MinimWatch2 for Windows.

That will hopefully solve the Play issue. Will it affect the sleep/reboot problem? It is difficult to say as that would not at first sight appear to relate directly to the UPnP server. But it may, for some odd reason, be indirectly connected.

Well I already have minim installed so it should be a quick test.

will advise… :slight_smile:

Well tried three albums and they all started playing the first track with no issues. I tried the same test with Asset and Minim2 and performed flawlessly with both servers… darn that’s annoying! :wink:

Hi both, I have a Melco running Minimserver 2 and I have the same issue but without any crashing/restarting of the Bartok. If I play try to play a whole dsf album it will usually just do nothing until I try again (once or twice) and then when it does play it starts the album from the 2nd track. Also if I play individual dsf tracks after playing flac/aiff then I often have to tell it to play more than once before it will play.

No problem with flac or aiff files.

When I play some music tonight I’ll make a note of the exact behaviour as my description above is a bit “loose”.

I should have flagged it before but I had (probably foolishly) assumed that it was a known problem and would get fixed with the next release of Mosiac…

Regards, Mike,

That’s interesting. I too have a Melco as server running MinimServer. Never experienced any difficulties at all with DSD64.dsf files.

Are we both using the same version of MinimServer? I can’t look right now as my system is not available tonight but it is not MinimServer 2 and from memory is v.8.

Steve, which version do you have?

Hi Pete, I’m on Minimserver 2.0.16, update 175 and Melco firmware 3.9.2, both of which are the latest I believe.

Regards, Mike.

Thanks Mike. I hope that Steve also responds regarding MinimServer versions but as the issue also happens with Asset that may not be required to work out where the problem may lie.

So we now have two respondents who find it occurring with Bartok + Mosaic. It happens with both MinimServer or Asset as UPnP servers both + Mosaic. It does not happen with MinimServer + Mosaic and Vivaldi ( that’s me). So that kind of leaves Bartok as the source of the problem or at least in combination with Mosaic. Mosaic is common to all 3rd generation dCS products reinforcing the idea that it is a combination of the two ( Mosaic and Bartok) where the issue emerges.

Are there any other Bartok users out there who have difficulties in paying DSD64 .dsf files?

Would dCS come in on this at this point? I have posted before about the exceptional number of posts here over the past year concerning odd behaviour with Mosaic and specifically Bartok especially in regard to programme loss/closing.

Hi Pete, I’ve just been playing around and it’s quite random in nature which makes it difficult to pin down, although it does only happen with dsf.

When I started listening tonight I started with the Mark Knophler Shangri-La album in dsf format and it immediately skipped to 2nd track when I tried to play the whole album. I then went back to the AIFF version and back again, same again. Then I played some individual tracks, no problem, and went back to whole album, no problem! Tried various dsf albums and tracks from then with no problem.

Settled down to listen to the Knophler album for a few tracks and then decided to try The Well by Jennifer Warnes in dsf format. This time it skipped to the 4th track, having tried to play each of the 1st three tracks initially (I know because they each appeared in the play window before jumping to the next). Once the 4th track started playing, I could then select the whole album again and it would start at the 1st track.

So it’s a definite problem but quite erratic in nature.

Regards, Mike.

1 Like

Yeah, intermittent faults are always the most difficult to solve.

1 Like

2.0.12 update 175.

Strange that @Mnemarks says 2.0.16 because I check for updates and my minim says ‘all packages are up to date’. I’ll goto minim site and check versions.

Right… so it’s 0.12 latest on windows and 0.16 on Melco.

Sounds like it’s not just me being daft then…

Just tried two albums that were ones that were showing this issue and both played perfectly - well they started at track one correctly, I didn’t play the whole albums. This is with Asset.

However I did some working tidying up of my server: Defragging the drive (even though it’s an SSD), emptying recycle bin, etc… Since then it’s played everything perfectly. This might be a coincidence… can’t say. I’ll carry on testing.

Spoke too soon. Just tried one of these same two albums again and it skips track one. This is with Asset. Then tried again and correctly started at track one!

I’ll switch now to only testing with minim since that’s the server dcs have most experience with.

Mike and Steve, is it that the problem arises when you switch from PCM format to DSD? Or does it also occur with both albums if you play two DSD ones sequentially?

The other thing I am thinking of relates to the blue " Play All" button in Mosaic. Are you by any chance not just selecting " Play All" but inadvertently this and/or the “Play Now”, “Add Next” and “Queue” options which are selected in the same button but in its right hand zone ( where the downwards pointing chevron is) ? There have been a number of issues reported here about odd behaviour when trying to play track 1 that were caused by what appears to be a single button actually having two selection zones within that blue rectangle. The user may inadvertently and simultaneously be selecting all of these contrary commands . I doubt that this is the case if all PCM albums play without error but it may explain the intermittent appearance of the fault and I thought that I would mention it.

It’s definitely NOT due to incorrect pressing of the button. If it was then I’d sometimes see it on other format albums and I don’t

However it’s a difficult test because it doesn’t happen all the time. In fact only once this morning despite trying my best to break it! :frowning:

Thanks. What about the two DSD ( .dsf) albums in sequence question? The reason I ask is that if it only happens when moving from PCM to DSD this requires Bartok to perform some switching and I am wondering if this is related to the crashes.

When I last saw it playing up I could switch dsf albums and it still played up. Would this be the same as asking it two times in a row to play the same album? Unfortunately, on my system, the tendency for this to happen has reduced in the last 24 hours - why? No idea :frowning: