Audio dropout between Bartok and LG OLED TV using Toslink

I’ve seen some similar queries to this on the forum but never a satisfactory answer. I have a dCS Bartok connected to my LG OLED TV via a Toslink optical cable. I’ve noticed when watching live TV I get audio dropouts lasting fractions of a second every 10 minutes or so. The video is uninterrupted. Strangely I don’t get this problem when watching Netflix. Does anybody else see this and does anyone have a solution? I tried a cheapie powered optical splitter as described elsewhere but this didn’t make any difference.

I thought that the answer was clear. The acceptance tolerance of the dCS optical input is tighter than the lower tolerance output provided by LG TVs. Note it seems to only be LG sets as no similar problems have been reported with Sony, Panasonic or other TV sets.

To widen the acceptance window of the dCS optical input would degrade the performance of the DAC with other sources.

As this problem seems only to arise with LG TVs I would suggest that a solution is simply to buy another brand of set.

Thanks for your swift response Pete. I understand the problem is down to the LG TV but what I don’t is why Netflix is glitch free but live TV is not. I’ve only had the TV 3 or 4 months and it wasn’t cheap so I wonder if I could claim it isn’t fit for purpose and get an exchange, but I don’t fancy my chances of success. I’m in no way denigrating the Bartok, it’s a wonderful device and do not expect them to change anything. Sod’s law I carefully picked my TV on picture quality and never bothered about sound knowing I was routing it through my Hi-FI and then there’s a compatibility problem because the dCS is superior to my previous DAC which was glitch free (albeit using RCA instead of optical). I hope I can find a workaround but the problem isn’t a major one as I rarely watch live TV and my music sounds wonderful. Thanks again for your reply.

I don’t know why this may be. What about other streaming services such as TV stations’ catch up apps?

Beware, Samsung TVs also suffer from this problem.

Stephen, did you flip through this previous LG TV thread? It might have some solutions worth trying;

I came across this issue, I didn’t much like the LG user interface anyway so reverted back to my trusty Apple TV.

I run an Apple TV sound over airplay to the DCS and HDMI to the TV. The snag is that each time you wake the ATV you need to select the audio output as it doesn’t appear to remember it, which isn’t ideal but it does work.

I haven’t tried anything else yet, only live and Netflix. I’ll try Amazon Prime and a few other services and see what happens. Thanks for your input.

I’ve tried using someone’s suggestion (forget who, my apologies) on this forum regards using an optical splitter/repeater. I bought an el cheepo powered one but alas it didn’t work. I’ve ordered a more upmarket one for a trial, so I’ll update later when I’ve tried it out. My TV is fairly new so not keen to replace and I definitely want to keep the dCS DAC. Thanks for your reply.

Someone from DCS suggested to me using a toslink to rca converter as the rca input can be more tolerant of jitter he said. Quite cheap off Amazon. I have same problem with a Samsung TV.

I like the sound of this idea. Please update us with your results if you give it a try. This problem seems to be more common than I thought so a positive outcome could benefit more dCS users. Many thanks.

Only getting a new cybershaft clock resolved my issue with the lg tv

I run my television into my Vivaldi upsampler via co-ax. I have my own co-ax splitter which allows me to run into my Bryston sp3 for surround sound at the same time

Thanks Bruno however the problem that we are discussing relates to modern TVs which have no coax output, only toslink. The issue is that the implementation of the toslink output on LG and Samsung TVs is incompatible with the tighter specified dCS toslink input. Do you convert the TV’s optical out to coax or do you have an older TV with a coax digital audio output? If the former which converter do you use?

Ah thinking about this again I realise the difference. I have a panasonic pvr as well as a panasonic tv, and I run the coax off the pvr not the tv. I suppose if I was bothered re the tv I would get a cable hdmi to co-ax which I believe exists? I rarely watch tv “live” and record anything of interest to play back when I feel in the mood for whatever my recordings are

It isn’t a cable that you would need but a converter or an HDMI embedder/de-embeder. However you need have no worries as the optical connection problem appears not to relate to Panasonic TVs but , so far, only to LG and Samsung products.

I too am a wholly Panasonic TV/video home and would try the toslink out to check but as my TV is in a different part of the room to the audio system I would need an optical cable circa. 6m long to reach the DAC. I won’t buy one just for an experiment as then the sound would in any case come from my speakers 4 metres away and at right angles to the screen :grin:. For TV I just rely on the pretty effective Technics soundbar that is a dedicated part of my Panasonic OLED TV.

Just got a Vivaldi dac + upsampler yesterday. First, it’s great. Second, it has the same issue with my LG tv. It’s only occasional but a minor pain point. From the thread someone mentioned trying the wyred4sound remedy, which I had laying around from years ago and it does seem to work now an hour in. One drawback is the remedy upsamples to 96 before the Vivaldi upsampler does its thing, and I think it sounded a little better going direct tv->upsampler. The latest apple 4k tv only has hdmi out otherwise I’d just do optical from there. And my Xbox causes lip syncing issues at least on prime video.

Anyway, to the original poster I hope this helps. I’ll keep the setup as is and report back if I still get the drops with the remedy.

1 Like

The Wyred4Sound Remedy helped, but not quite 100%. Very rarely there was a blip of a dropout, like maybe a tenth of a second instead of the previous second or three. On the plus side the incoming feed being 96 instead of 48 I think helps it lock on much faster so it really is a blip. No matter what I tried though upsampling to DSD was not happy on toslink from the LG, with or without the remedy. Not a big deal as I can leave it on DXD, but it adds to the list of Vivaldi quirks.

Additionally, due to a lip sync issue I changed the LG audio settings to -1 which for awhile I thought cured the issue by perhaps buffering the audio internally momentarily and spitting it out more well-formed or whatever. Eventually I got a blip here too, so I don’t know if it helped or perhaps I was using a different app or maybe the Apple TV instead of the internal LG apps. Anyway, the blips without the remedy was maddening and I’m now happy enough with the Remedy. Good luck.

I finally got my Wyred4Sound Remedy last night and I haven’t noticed any dropouts in the short time I’ve listened to live TV. I wasn’t having problems with Netflix or Amazon prime with the LG/Bartok combination so that in itself is an interesting result. Time will tell how successful the Wyred4Sound Remedy is but fingers crossed.