Bartok and Rossini dac problem using optical connection

have an interesting problem that i couldnt solve whatever i tried: my LG 65C8 tv is connected to Rossini Player with an optical cable and every 30-40 minutes i have sound switching off for like a sec and the dac makes the click sound that it usualy do when loosing connection. Same problem with my previous Bartok dac.
no external clock is used.
i changed optical wires, changed the tv, Changed Bartok to Rossini- the problem stays. Changing clock settings in the dac from Master to Audio makes the problem even worse- the soun dropouts every several minutes.
is it a known issue? are there any solutions?

This appears to be a synchronisation issue. However you have so far:

  1. Tried all dCS DAC clock synch settings to no avail.
  2. Tried 2 different DACS.
  3. Tried different TVs.
  4. Tried different connecting cables.

All offer no solution.

Are you able to listen to the TV’s sound direct ( not via a DAC and your audio system) with no problems e.g. through its speakers or using headphones plugged into the TV? Is the programme source the TV itself or is it being fed by something else e.g.a streaming service including TV catch up apps, a TV box or a DVD player? I am just speculating here that as you seem to have tried every different combination from TV to DAC could you be experiencing something being passed forward through the chain from the original source? I would have imagined that buffering somewhere should have dealt with such a possibility but let’s not rule it out yet.

I am assuming that you have specifically changed the synch settings for the optical input, they are not universal. I am sure that you know that but it just occurred to me as something to check…

the problem in both netflix and built in TV satelite reciever.
actually there is no sync options on tv except pcm\auto option, but changing that didnt help, also Netflix wont work with “auto”

Thanks. So it seems that the source is the TV itself rather than an external box feeding it. But you say that you have already tried a different TV and had the same problem.

I wonder if someone from dCS can suggest a solution?

The correct configuration on your LG TV is for “Digital Sound Out” to be PCM. While the correct Sync Mode setting on your Bartok/Rossini is Audio (so that the DAC’s is sync’ed to the incoming TV PCM bitstream).

With those settings, if you’re experiencing drop-outs, then I’d venture a guess that your LG TV is outputting digital silence every now and then, and the DAC has to re-sync when the TV streams audio again out of silence - you can verify that this is happening if you observe the incoming bit-rate on the DAC, if it periodically goes to 0, then you know for sure your TV’s outputting digital silence.

I don’t think there’s a simple fix for this, the DAC is behaving as it should.

When you swapped the TV for a different one, was this an identical model (LG 65C8) or was it a different model?

Do the dropouts occur in the middle of a stream, when you change stream, or both? For example, changing channel on the SAT receiver?

Netflix does do some strange stuff with regards to output signals when you’re browsing the menu, so I would expect the DAC to need to re-lock when moving between titles on the menu if they’re set to autoplay a trailer.

  1. tv’s were same model
  2. in the middle of the strream- you are watching some program and get dropouts in Master mode every 30-40 mins, audio mode every 2-3 mins

i did try connecting tv to oppo 203 by hdmi in arc mode and then by optical cable from Oppo to Rossini- no problem.

Your dCS DAC is fine with an optical connection to the Oppo. The Oppo is fine with an HDMI connection to the TV. You have tried two samples of the same model TV and the same problem of optical connection to two different DACs occurred using either TV .This accordingly suggests that there may be an issue with the way that LG has implemented the tv’s PCM optical output. Everything else seems to be working OK.

I think Pete hit the nail on the head, it very much seems as though the optical output of the TV is the source of the issue here. Running audio over ARC to the Oppo and using optical from there causes no issue, and having two TVs of the same model show the same behaviour suggests that it’s not something faulty with the individual TV unit itself.

Running the audio through the Oppo seems therefore to be a valid workaround.

The pauses in audio are a result of the dCS unit receiving a bad signal from the TVs optical output, and needing to re-lock periodically to maintain audio. I think it’s likely the LG is outputting a slightly incorrect sample rate over optical, but seemingly not via ARC.