Welcome Mosaic 1.1.1

Just a reminder in case the bug I found and reported some time ago has been forgotten:

My modus operandi each day (with MinimServer always running on my NAS) is to start up Mosaic, which brings up the Network Bridge, then select UPnP, then select my Synology NAS library, then select genre, then select albums, select among alphabet letters and finally select a specific album. I add the required tracks to the Play Queue. The first time in the day I do this I find that on many (perhaps the majority of) occasions the 1st track plays OK but play then stops and I have to select the second track in the queue.
I’m not sure whether the problem is related to Mosaic or MinimServer or their intercommunication but as the later is the UPnP server you support can you please fix this?

Otherwise I’m very happy with Mosaic and grateful for your commitment to develop this software further.

This happens to me too, but not very often

Thanks for the feedback David, I’ll get this passed on. I haven’t been able to replicate the fault myself so any info you have on how to make it play up would be really useful:

  • Do you queue up just one album at a time, or are you queueing up multiple albums at a time and finding the first track skips?
  • Has this happened after the Mosaic 1.1.1 update?

@exnimrod thanks for letting me know on this. Are you also using a Network Bridge, or a different unit?

To answer your questions James:
Mostly I queue only 1 album, sometimes two.
Yes it does happen after the Mosaic 1.1.1 update; I’ve waited for a little while before re-reporting.
When I first reported this dCS had difficulty in reproducing it, particularly as it does not always happen.
For your information I’m running Mosaic on an Android tablet.

James, I am experiencing an annoying problem with Vivaldi/Mosaic since installing v.1.1.1.

If I leave the Upsampler powered but in sleep mode after a listening session ( my normal procedure) when I return for a new session, bring it out if sleep and reopen Mosaic ( I am opening a fresh session) the latter cannot find Vivaldi UPS . The front panel display on UPS confirms, however, that it is on the network.

I can only get Mosaic to find Vivaldi UPS by hard rebooting the latter and opening another Mosaic session.

Any ideas?

Pete, does the same thing happen if the Upsampler is left on instead of in standby?

Can the system be made to function properly again by booting one and not the other (Mosaic or Upsampler)?

I’ve installed Mosaic 1.1.1 (109) on my Android tablet, controlling Rossini.

Mostly working fine but I’ve notices a selection problem for the Wake/Standby button and expanding the Volume “control line”, both of which worked fine before the update. Several times I have experienced a couple of frustrating minutes to actually wake the system with repeated attempts.

Thanks James.

  1. it happens whether the Upsampler is left in standby or on.
  2. I have to reboot both hardware and app.

Further to my initial question Mosaic will now not not discover UPS at all. Except tin the following circumstance;

I am referring to the iOS version running in iOS 14.3. However I have no problem using my Android installation of Mosaic 1.1.1. So if the iOS version is in permanent search mode and I then open UPS with the Android version iOS immediately switches to display the correct information.

I have tried a reinstall of 1.1.1 iOS which seemed to work initially but it is not stable and, once again, cannot find UPS at all.

For clarification the Android installation connects immediately it is opened. Unfortunately it is on my phone and the screen is too small for a good user experience.

Apologies for butting in here, but I thought I would test this problem on this side of the pond. If I have misunderstood the issue, please forgive me.

I have no trouble with Mosaic 1.1.1 accessing VUps over the network on an iPhone or iPad running iOS/iPadOS 14.4, even with the VUps in sleep mode. I’ve tested this three times, and twice, I briefly got the “Lost connection” message over a blurry screen and then everything snapped back into focus as Mosaic reestablished the connection.

Greg, I am 14.3. I just checked and there is no 14.4 available to me. I don’t know if Apple issue updates in tranches rather than the whole world in one hit ?

I’m a beta tester. I suspect the .3 or .4 differential is not the answer, but I have no easy way to find out. I’ll see if I can borrow my wife’s iPhone or iPad.

Pete, I’m on iOS 14.3 same as you, but like Greg, I don’t have a problem accessing my Vivaldi, asleep or awake.

I’m wondering if the issue you’re seeing has to do with iOS’ Private WiFi addresses feature - your Ethernet switch’s ARP cache may have gone wonky for whatever reason.

Hard reboot your Ethernet switch that front-ends the Vivaldi, and see if that solves the issue.

If not, then turn-Off “Private Address” and see if that resolves it. (Apple’s “Private Address” feature where the iPhone uses a virtual MAC address is really only useful when you’re on Public WiFi networks, less so when its your own home, so you’re not really compromising your privacy/security :slightly_smiling_face:).


Good points. I had forgotten about Private Address, but FWIW, mine is turned on.

Thanks . I will give it all a try tomorrow ( now 01:00 in the UK).

I tried hard rebooting the switch but no result.

I cannot find any way of turning off “Private Address”. I have been through just about every Settings menu on my i-pad and cannot find this option. It is also not mentioned in the User Guide. Could you tell me where it is located?

So, the current situation is that the Android version of v.1.1.1 connects more or less immediately it is opened. The iOS version will only search and not connect. However if I open Mosaic with the Android version , leave it connected, then open the iOS version it immediately displays what the Android version has selected and thereon all commands work as normal. So that suggests to me it it may not be a network problem.

I would add that an extended ( in time) search for connection via the iOS version dates from the installation of v.1.1.1. when it was taking up to a minute to connect. This has since become no connection at all. However updating to iOS v.14.3 occurred at around the same time as v.1.1.1 so it is difficult to separate the two from memory.

Pete, from iOS Settings—> WiFi—> the blue “(i)” info on the right of your currently selected Access Point, you should then see the “Private Address” setting on the resulting page. Give it a try.

What Access point are you using by the way that your iOS device connects to?


Anup, thank you so much. Having switched off " Private Address" my i-pad is now connecting to VUPS immediately. So it looks as if my problem has been solved.

My i-Pad connects to my Fritz!box 3490 router.


That’s great to hear. “Ease of a toaster” (Steve Jobs’ famous standard for ease of use that guided part of the development evolution between the Lisa and the Mac) remains an elusive goal.

Pete, glad to hear it!

That said, it suggests there’s likely a bug with your Fritz!Box. Do you activate any filtering or security on it? In any case, if everything else works fine, then don’t touch I suppose :wink:

No, no security other than its password. No problems other than this issue with the i-pad and private address. The router is now three years old and other than this has behaved faultlessly. So, yes, don’t fix what isn’t broken seems the right strategy.