Vivaldi UPS discovery with iPad

Some months ago I wrote that I was having difficulty connecting Mosaic app running on my iPad. This was solved by switching off “Private Address” in iPad settings.

However I still have an annoying issue with connecting. When I open Mosaic I will still not get a connection and see a buffering icon for as long as I let it run. Yet if I then close the app and reopen it a connection is made immediately.

Any ideas why it requires two attempts to get the connection? NB: Never have any similar issues running Mosaic on my Android phone.

That would suggests the issue has to do specifically with the iPad/iOS and your home network somehow not working well together. :thinking:

Are you still using the Fritz!box 3490 Router as the Access Point for the iPad?

Afraid so. I am finding difficulty in replacing it with an alternative as I cannot physically accommodate anything with large antennae sprouting from the box such as models from TP-link, Asus or or Netgear etc. I could change to an updated Fritzbox 7530 or 7590 but presume that might just mean more of the same.

I took a quick look at the Fritz!Box’ manual, I wonder if the “Green AP mode” is where the problem might be? (Is the initial TCP SYN packet from Mosaic Control getting gobbled-up waking the Fritz!Box WiFi module from it’s “Green” slumber? :laughing:)

There’s [a] simple way to test this hypothesis; from your iPad when you expect you might encounter the problem, first use Safari to browse the Web, and only after, launch Mosaic Control.

See if it still chokes the first time? :face_with_monocle:

1 Like

I checked the Fritz!box setting and no port has Green AP selected. However I think you must be on the right lines as I did use Safari then opened Mosaic which connected immediately. So something or other needs to be woken up first.

The way the Fritz!Box’s Energy Saving function reads, it seems you can’t defeat the “Green AP mode” for the WiFi module :persevere:

Albeit, the problem could just as easily be something weird going with your iPad, requiring a kick on it’s networking stack. The symptoms would look similar. :thinking:

1 Like

The fact that shutting off private addressing had any effect shows that there is something wonky in your network that is doing cacheing it shouldn’t of interface MAC addresses and the like.

All private address does is generate a temporary MAC address for each Wi-Fi network the device connects to rather than use the hardware address.

This will have zero effect unless:

  1. Your network is cacheing information about which device has which MAC address and is filtering/forwarding accordingly

  2. Your DHCP server is set to distribute IP addresses based upon MAC addresses and Mosaic expects to see requests from a particular IP address

1 Like

Thanks Bill for your input. So the problem is again most likely to lie with my switch/router and that part devoted to DHCP functions. The practical issue, therefore, is that I am not a professional network manager ( nor do I think I should need to be one - I just want to listen to music :thinking:). So I really do not know how to go about fixing this. Frankly for much of the technical discussion of networks on this forum I can feel a little breeze on my scalp as the subject flies over my head :wink:.

Not really Pete. DHCP doesn’t play any part in normal traffic flows.

As Bill suggests, having to turn off the Private WiFi MAC address on your iPhone was likely a band-aid. Theres some other root problem that hasn’t been resolved.

This issue of failing every first time you launch Mosaic Control sounds like a different problem though. The Fritz!box apparently turning modules on and off on its own isn’t great, but there’s likely a more complex issue going on between Mosaic Control on the iPad and the Fritz!box.

If you have a choice, I’d say dump that Fritz!box and get something better :laughing:. If you’re looking for external antenna-less ones, check out Aruba’s WiFi Access Points - I use their flagship AP-555 for home; being Enterprise grade, it’s a little more complex to setup then normal consumer APs, but well worth it for performance and stability.

Thanks Anup. As I have aid I am not exactly a professional network manager and as Aruba is sold in the UK only on a B2B basis I both doubt that I would be supplied with one ( B2B relations normally require a business account) and am aware that I am not equipped even to have a meaningful conversation with my local supplier about the product.

In any case I do not now believe that the Fritz!box is the problem. Firstly there is never any issue with Mosaic app running on my Android device, only with the iPad. Secondly I have found that I do not need to close and reopen the Mosiac app to get a connection. All I need to do is to minimise it then resize it to full screen. Of course when doing that there is no communication with the wifi router which I conclude removes it from the suspects.

My iPad Air 2 is old and was bought refurbished. I have decided that having to minimise the app then resize it at the start of a listening session is such a small hassle that it isn’t worth the expense of buying a new iPad or any other hardware. So I will just live with it.

Thanks again.

1 Like