Vivaldi Audio dropping out with SPDIF input from Trinnov Altitude


I have a homethearter use case where the Trinnov Altitude16 decodes and processes audio from media players. The L&R output is then sent via optical SPDIF to the Vivaldi DAC (2.11) with Vivaldi Clock. I don’t have the Upsampler.

I found that when playing from AppleTV (via the Trinnov->Vivaldi chain) the audio would dropout from time to time, presumably loosing sync. This is with the sync mode set to Audio. This is unexpected as I thought in this mode the Vivaldi DAC would sync to the incoming data’s clock using PLL?

I tested other sync modes and found that, surprisingly, the Universal Master Mode works without any dropout. From reading the manual this should not work as the mode is intended for the Upsampler which I don’t have.

The dropout frequency also varies depending on what streaming service is being used. Under the Audio sync mode, Streaming AppleTV+ (@48khz) would exhibit dropouts frequently (once every few seconds) at the beginning but slowly it goes away after a few minutes and stay that way. By contrast, streaming Amazon Prime would have dropouts occurring continuously with no improvement over time so is unusable. Finally, playing Youtube (@44.1khz) seems fine with no dropout whatsoever.

I also tried the two buffer modes but it makes no difference.

Appreciate any advice on what I may have configured incorrectly or ways to mitigate this.

Thank you.


I notice from the A16’s manual that it has an internal or external clock mode (similar to my Trinnov ST2 Pro). When you selected the AppleTV as the source and experienced dropouts with dCS DAC in “Audio” clock, did you notice if the A16 itself was pulling its clock from the AppleTV TOSlInk or was it internal clock mode?

Thanks Anup for the reply.

The AppleTV connects to the Altitude via HDMI so the Altitude is syncing to AppleTV data stream’s clock. AFAIK, except during calibration runs, the Altitude always sync to the incoming data stream’s clock.

The Altitude also outputs the L&R channels via its own balanced analog output. That one doesn’t have any dropouts as expected so this suggests that the Altitude is able to sync to the source.

The Vivaldi is very picky about the clocking on input signals. I have the same problem with my LG TV and tried a whole bunch of things with no success. Somtimes switching to the Master mode would sometimes help but it would eventually completely fail to sync, or sync but with a sort of muffled sound.

I eventually found success by putting a mutec mc-3+ usb in between the TV and the Vivaldi and clocking it to a 10Mhz mater clock that also fed the Vivaldi clock. Hard to recommend this though, considering the expense.

1 Like

Thanks Jeff for sharing your experience. Looks like I’m running into the same issue you found. I was hoping this could be resolved without adding more boxes (and expense).

Hopefully our dCS support colleague can offer some insights or advices.

Hi Jack,

I think I’ve been discussing this issue with someone but I can’t find the discussion that I was having to check … I also had this issue with an LG TV and its unstable TOSLink output (as it seems did @Gibraltar ) but I changed the audio sync for the LG source (the TOSLink input) to “M” as “A” was giving me semi regular dropouts - “M” in theory shouldn’t work but in this case when the input sync is quite variable then it can be a bit more resilient in that it doesn’t try to resync when the input drifts.

I’m sure I made that suggestion - has it been tried?

1 Like

I had the same issue using the Toslink output from my Sony tv to the SPDIF input of my Rossini, regularly dropping out / clicking. In the end the only fix I could find (at an acceptable cost) was to use an Ifi SPDIF ipurifier2 which reclocks the signal. Not had a single drop-out / click since…


1 Like

Hi Phil,

Thanks for chiming in. This is my first post here so I’m not the one you discussed with earlier.

I tested the two M modes, the normal one reduces the dropout but cannot eliminate it. It is the Universal Master Mode that eliminates dropouts completely. I didn’t compare in more details but I can’t say it sounds as good as the A mode.

I’m curious why setting the buffer mode to 0.72s can’t get rid of the dropouts. Do you have any insights into that?


Hi Mike,

Thanks for sharing your experience and the ifi SPDIF ipurifier2 suggestion. I’ll look into that.

I tried the ipurifier2 with my TV before the Mutec and it did not help. I think the signal from LG TVs must be particularly bad!

Hi Jeff, that’s interesting as it was an immediate and permanent fix for me. I tried taking it out and the dropouts started again. Just checking, I use optical from TV to ipurifier2 to SPDIF 1 input on Rossini with DAC clock set to Audio on that input, which I believe means it’s taking the clock from the iPurifier2. Were you using it in the same way?

Cheers, Mike.

I finally solved the issue using a mutec mc-3+ usb like Jeff mentioned above. I do experimented with three clocking methods which gives different results. In all cases, a mutec REF10 SE120 serves as the master clock reference for the Vivaldi Clock and the mutec mc-3+ usb.

  1. Vivaldi DAC clock sync set to “W”. This utilizes the Vivaldi Clock and based on my understanding should offer the best performance.

  2. Vivaldi DAC clock sync set to “A”. This utilizes the DAC’s internal clock with PLL to lock into the incoming data stream’s clock.

  3. Add a new clock cable to connect mutec mc-3’s word clock output to Vivaldi DAC’s IN3 Clock input. Vivaldi DAC clock sync set to W3. In this setup the mutec mc-3’s word clock drives the Vivaldi DAC directly.

All three setups work fine with no dropout. They sound different though.

Surprisingly, #1 is worst. It sounds foggy as if things are slightly out of focus. #2 is much better, with very well-defined and articulate sounds. #3 is best, with more body and even tonal balance. In comparison, #2 may sound more transparent and is more hifi while #3 is more natural and analogue sounding.

I hope this could be useful for others running into similar use cases (hometheater).

1 Like

In another thread (USB to AES/EBU digital converter)
there was a problem with syncing the Vivaldi Clock to the Mutec REF10 SE120.
The Vivaldi Clock seems to properly sync to the Mutec only in AC mode but not in TTL mode, supposedly because the output level of the Mutec only reaches 2V.

Very interrsting, Jack. Thanks för posting!

@meltemi: Yes, I posted that as well. Using the Vivaldi Clock in AC mode solves the problem and works well. The above observations were made with that configuration.