Using Mosaic app on IPad Air or IPhone XR unable to see Bartok

I see earlier posts this year mention the problem of Mosaic unable to see the Bartok. The app just keeps searching with no success. I have tried the various solutions- uninstall/ reinstall Mosaic; power down Bartok. I have powered down my Dray Tec router. Nothing has cleared the problem. The iPhone XR has version iOS 13.6.1, the iPad Air is12.4.8.

Hi Colin. It looks like you are new to the community forum so welcome.

The problem that you have is almost certainly to do with your LAN and the settings thereof. Just rebooting your router will probably be insufficient to provide an answer (as you have discovered).

I am not a LAN expert by any means so I hope that you will have the patience to wait for someone who is. Obviously the dCS staff members who post here may be unavailable over the weekend. However Anupc may pick up on this as he is an expert.

In the meantime use your computer to check whether or not your Bartok is appearing on your network.

Colin, there’re a few basic things you can do to help identify what the problem is.

Start with the Bartok’s IP address; from it’s front-panel, you should be able to tell if the Bartok has picked-up a proper IP address. With that address, as Pete says, check if your PC/Mac (or even your iPad/iPhone) can connect to the Bartok from a Web browser, that’ll confirm physical/logical connectivity.

Also let us know how is your Bartok connected to the Router exactly, just an Ethernet cable directly between the two or is there anything else in between? And are your iPhone/iPad connected over WiFi to that same Router? What’s the model of that Dray Tec router?

Hi,
Thanks for the reply. The Dray Tec model is Vigor 2860n Plus. The Ethernet cable runs straight from the router to the Bartok. I have caused a further problem in that I asked the iPad Air to forget the network with the idea of reconnecting with it. Now it will not do this so I am using iPad through the iPhone to answer you.

Hi Anup,
Follow up from your reply. The Bartok’s IP address is completely different to the IP addresses on my iPad/iPhone. Is that usual?
You suggest I check if iPad would connect to Bartok using a web browser. How do I carry out that task? Thanks

Hi Anup,
Using Fing shows that the network cannot see the Bartok. Is this the problem?

Colin, a couple of questions/suggestions;

  1. I assume the DrayTek Router is your main VDSL/ADSL connection to the Internet? If so, we’ll have to be very careful with any configuration change so as to not screw-up your main connection to the Internet! :crossed_fingers:t3::grin:

  2. Is your iPad not able to find the Router’s WiFi? Even if you “forget” it previously, the iPad should be able to scan for and connect to the Router’s WiFi again. I’d recommend you get that working directly to the Router’s WiFi.

  3. Do you have a PC/Laptop that you can connect to that same Router over WiFi or through an Ethernet cable? Best to use a PC/Laptop if you need to make any configuration changes to the Router later.

[Edit]
I just flipped through the DrayTec 2860’s Manual, this Router has a very rich set of features that makes it’s configuration somewhat complex. So much so that you may not be able to continue with 4. below until some configuration changes are made. But let us know how you get along with the above first, especially getting a PC/Laptop connected to your Router.

  1. From any browser on your PC/Laptop or iPad, you should be able to type in your Bartok’s IP address and get a webpage response (I’ve attached an example fro my iPad to my Bartok below). That’ll help to validate connectivity to the Bartok fro your PC/Laptop/iPad.

We’ll revisit the IP addresses question once you’re done with the above, so, don’t worry too much about what Fing is showing you for now.

Hi Anup,
The issue with iPad/router has been solved.

I have tried to start up an ancient windows laptop that has not been used for years! It is full of security issues in that my internet if Avast Antivirus is to be believed is not encrypted, my location is exposed and my IP address is visible. It is connected but a bit reticent to use it. Do the above issues need to be fixed by Avast if we want to use the laptop to sort out the issue with the Bartok?

I have entered the Bartok IP address both on the iPad and the laptop and no details come up.

Thats good. From your iPad, are you able to access the Router’s configuration web-page as described on page 21-22 of the Router’s User’s Guide? (This is my first encountered with a consumer Router that has over 900 pages in it’s User Guide :laughing: )

Once you’ve accessed the Router’s configuration Web-page, can get to the LAN -> General Setup settings configuration screen as described on Page 148 of the User’s Guide, and take a screen snapshot from your iPad and post it here?

It appears that the Router has some unusual default configurations that may be impeding your WiFi clients (like your iPad) from communicating with devices connected to the LAN ports (like your Bartok). Which physical port is your Bartok connected to by the way?

Depending on how you get along with the iPad, we may or may not need your PC.

Hi Anup
Here is a screenshot of LAN general setup

Here is photo of the back of the Draytek router. The black Ethernet cable goes to the Bartok- port 2


Look forward to hearing from you.

Excellent capture.

It does looks like the configuration will need some change. While I check the manual to see what exactly needs to be changed at a minimum, couple of additional questions;

  1. What IP address does your iPad get, a 10.10.95.x or a 192.168.x.y?
  2. What IP address doe your Bartok get? 192.168.x.y?
  3. Were you reserving LAN port 1 reserved for some other use?
  4. I notice you’ve got ports 3, 4, and 6 connected to devices, are any of them able to talk to each other? (I’m guessing not since they all appear to be in different subnets).

Hi Anup,

The iPad IP address is as you say.
The Bartok is IP address is 169.254.10.96 which is not what you think it should be!
There is no reason why the Ethernet cable is in port 2. It was put there by the IT company who installed the cable as it involved a lot of work to get it to the Bartok.
The other ports are being used by a cctv recorder, a laptop and a stand alone cctv camera.

Colin, sorry, which is it? A 10.something address or a 192.168.something address?

I’m going to suggest some configuration change to the Draytek, but I’m a little worried that if your iPad loses connectivity to it for whatever reason, you’d be locked out.

By the way, in case you’re worried about Internet security, the IP address ranges of 10.something and 192.168.something are private addresses that everybody uses behind NAT’ed private networks, so you’re not compromising your personal network security by posting exactly what IP addresses your devices are getting assigned :slightly_smiling_face:

That’s a self-assigned address. Likely because Port 2 on your Draytek isn’t actually active - the configuration screen shot you attached has no tick mark under [Enable] for Ports 2 to 6, and they’re greyed out).

I’m guessing these other devices are also not currently working through the Draytek yet are they?

Do you have access to that IT company for assistance?

If you feel confident, here’s what I suggest. From your iPad, access the Draytek’s VLAN settings page, and change it to look like the following;

Then go back to the LAN General setup page and [Enable] ports 2 to 6 (it should no longer be greyed out).

You may need to reboot the Draytek, but I’m hoping that should get all ports active, bridged, and with DHCP. Your Bartok should then get assigned a 10.something address, and hopefully your iPad as well. :crossed_fingers:t3:

Hi Anup
The iPad address is 10.10.95.x
Had a go at the Draytek router settings. No problem with Vlan configuration, all boxes ticked as shown on your screen shot. Then hit a problem. I clicked okay for the changes and was asked to reboot
router in current configuration or factory default. I chose the former. Clicked ok. Told router would system reboot and in 10 seconds I could go back by clicking the routers IP address. The iPad message appears saying the internet connection is lost. Tried the laptop and iPhone with same result.
Logging back in to the router and going on LAN General Setup shows the enable column greyed out apart from DMZ and IP Routed Subnet.


Any thoughts

So that means the Wireless subnet is the same as LAN1, while the rest of the ports are different. That would suggest that if you plug your Bartok into port 1 instead, Mosaic control on your iPad should be able to connect to the Bartok.

Give it a try? :wink:

But the rest of your devices on ports 2-6 would still not function properly.

It’s normal that the Internet connection would be lost while the Router is rebooting and coming back up. Since we didn’t make any changes to the WAN configuration, it should have no problems reconnecting you to your ISP eventually once the Router is fully rebooted.

Do you have any idea why the configuration has reverted back to before VLAN was enabled?

Hi Anup,
I have move the Ethernet cable to Lan port 1. No change.

As to last point you make I do not know. I assume that after I ticked VLan boxes the router may not reboot to take on board the changes (would you notice the reboot or is it done all internally and there is nothing to see) and therefore the boxes in the LAN General setup up page remain greyed out.

Not sure where we go from here!

Thats odd :thinking:… What’s the Bartok’s IP address now with it plugged into Port 1 on the DrayTek? It should be 10.something (instead of 169.254.something). You might want to just reboot the Bartok with it still plugged into port 1 on the DrayTek.

There’re a couple of other things we could try with the LAN configurations. Interestingly, DrayTek has a Router configuration simulation accessible online, but it doesn’t work all that well across configuration changes, so I can’t test changes.

If all else fails, I would definitely recommend you get in the IT guys who set the Router up in the first place, and/or your dCS dealer to help you in person.

Hi Anup,
I’ve solved the problem! With the Bartok still reading an IP address of 169.254.10.x which ever port we used I decided to go back to basics and check out the Ethernet connection to the Bartok. I moved the unit next to the router and plugged in a different Ethernet cable. The Bartok IP address changed to 10.10.95 x. I moved the Bartok back and connected it back to the original Ethernet cable and the IP address changed back to 169.254 etc? Not sure why!
With the new Ethernet cable and the right IP address the iPad can see
the Bartok and the system is up and playing.
So the problem it seems stems from a break down in the Ethernet cable I had installed.
May I thank you for all the time and effort you spent with me trying to come up with a solution. This was my first time using the dcs community and it’s nice to know there is support out there.

Glad to hear it Colin, enjoy the music! :metal:t3: :smiley: