USB drive not seen after a while

I have an USB drive connected to the USB socket of my Rossini Apex. Rossini stops seeing it after a while until I power the Rossini off for a few minutes. Unplugging and plugging the drive back in doesn’t help.

I can click on USB in Mosaic but it says Nothing found.

Not a big problem as I only use the USB drive to quickly copy music on it to temporarily play it and also wanted to compare the quality but I found this strange and wonder if others have also experienced this and if there’s an easy fix.

I’m used to other mysterious issues, like the volume changing in Mosaic but not on the DAC. Restart helped. In some other cases the file to be played appears on the screen of the Rossini it just never starts playing, nor does anything else. Restart helps again.

The most dangerous thing that happened was when changing the volume in the range of -60–50db in Mosaic caused the volume to go to maximum for a moment. My Rossini drives my amp with the preamp bypassed so I was super lucky the speakers survived. Not sure if the output voltage had been set to 6V my speakers would still be ok.

This nearly put me off using stuff without a real volume knob.

The above only happened once or rarely but the USB issue happens all the time, that’s why I chose to post about it, while mentioning the others issues too, in case someone has experienced anything similar.


Please see p.19 of the user manual.

USB input 1 is for computer connection and I assume that you are referring g to USB input 2. This input is only configured or flash drives and was designed as a convenience facility should, for example, a friend visit with a few tracks on a memory stick. Further it may not be capable of supplying sufficient power for e.g a 3" USB desktop drive. Further only certain formats are supported; FAT16, 32 and unencrypted NTFS. So if your USB drive is not of the supported type then issues such as what you report may occur.

1 Like

Thanks Pete for your prompt response.

I’m using the USB 2 port, it’s a small small pen drive/usb stick, formatted to FAT32, tried different ones with the same results. So in theory it should work. Not so important but still expected to work.

My first suspicion was it is not powered so I tried a different one with an LED on which was on.
And powering off Rossini for a few minutes makes it work most of the time. Powering off for too short doesn’t.

Thanks Tom. Mine were the most straightforward reasons that occurred to me. I note that the issue is arising using other flash drives so I feel I should recommend that you talk with the experts like @Phil at dCS support:
[email protected]

Thank you.