Toslink S/PDIF 3 input - clicking

Greetings chaps.
Got my Bartok but small issue when watching TV via optical (Toslink) cable to input S/PDIF 3 on the Bartok.
First of all there was a lag on voices - so I switched off the buffer - and voices back in sync with pictures. Voila!
Next issue is the red gear wheel that is in the display and the pausing / clicking of the Bartok which seems like it’s losing signal - hence why the red warning sign appears.
Is this what the buffer is designed to alleviate ? But obviously with TV you need it off.
One thing I am puzzled with is which sync setting I need. I have no world clock.
This clicking and pausing is driving us all nuts!

Weirdly the Bartok I had on loan didn’t do this at all …
Any thoughts?

When using the Toslink for TV, set your Sync Mode to AUDIO. That will solve the problem.


I’ve sorted it - the menu options were locked.
I unlocked and changed settings.
All sorted!
Thanks :smiley:

1 Like

If you’re plan is to use the Bartok for the telly and also normal network playing then do you have to change the sync back to Master (or Auto) and turn the buffer back on each time you change source?

Can I quickly just ask Erno…In Device > Sync mode, should “Audio” be enabled (Blue) in normal playback of dCS Radio and Roon? Thanks

@Merlot52 AUTO WORDCLOCK should be selected when using the Rossini Clock, MASTER when using the internal clock.

From the manual:

@solwisesteve The Bartók remembers the sync mode you have set separately for each digital input, so if you set it to Audio Sync for SPDIF/ Toslink, and leave it in Master Sync for USB and Network, you are set. The buffer needs to be corrected, when you change source.

1 Like

Oh… so having to reconfigure the unit when ever you turn the telly on is a bit of a pain. Why is this setting not remembered dependent upon input source?

I wondered that too - buffer off for TV, buffer on for network. Given the complexity of the menu system - it crossed my mind why you couldnt set it for each input (and why you cant name each input via Mosiac as well !)

tbh… having to go into the settings and changing the configuration whenever I change the input source precludes it from my required use. Using it for the telly and also hifi (streaming) would have been very useful. Another demerit :frowning:

@LeeB @solwisesteve Unfortunately this is indeed the case: the buffer setting seems not to be remembered separately for each digital input.

From the manual:

Thanks Erno :+1:

So what are the implications of running Network source with buffer off? Says he whilst listening to an album with buffer off…

The buffer/ delay gives the DAC time to detect changes in sample rate or clock frequency and mute before the change causes audible clicks or other noises.

So, running a networked source with buffer off might bring you that: audible clicks or other noises.

You probably won’t notice anything until you play two consecutive tracks of differing sample rate. For example a 16/44.1 file followed by a DSD 64 one. It takes time for the DAC to change from PCM to DSD or between other differing rates . Without the buffer being set there is a strong likelihood that you would experience the first second or so of the second track going missing whilst the DAC reconfigures itself ( you may hear some relays switching). This is masked by setting the buffer which delays the data from reaching the DAC so that all of it is subsequently processed including that first second.

Steve, by the way, if you use Roon, you can mitigate the need to have the dCS buffer on by turning on Roon’s Resync Delay setting (to 100ms) under Roon’s Audio device setting for the dCS. :+1:t3:

1 Like

Yes and other media players offer a similar facility in their settings e.g. JRiver MC.

1 Like

Cheers… running without buffer at the moment though, I admit, all the albums have been the same sample rate so far.