Rossini Clock Synch issues - "Wrong clock detected"


I am currently using Rossini dac and clock with Aurender W20 SE (dual AES). The clocks 3rd output feeds the Aurender’s WClock input. I am also using the RS232 control dongle to toggle (the frequency at output 3 can be changed to either 48 or 44.1kHz by RS232 commands to match changing data rates). This was working great until recently.

Recently, i’ve noticed that the DAC is unable to lock on a rate, instead it’s displaying a red W and “?”. Reading through forum posts, i see that this is an indication of “a wrong clock signal was detected”, but I am unclear why and how I can fix the issue.

:thinking: … The Aurender’s control of the Clock’s 3rd output should have no effect on the two primary clocks going into the Rossini. Have you tried unplugging and replugging the Clock cables, and ensure your Synd Mode is correctly set to “Word Clock 1-2 Auto”?


I did unplug and plug the clock cables, but that did not fix the problem. I just noticed that it is able to lock on 24/96k, but not 14(24)/44.1… so it’s something with AES1?

I think have the setting correct

Thanks in advance

Your Sync Mode configuration looks wrong (the first item on the left of that screenshot you pasted); it should be just “W” (for Auto Word clock 1 & 2), not W2. That explains why 24/96 works and 44.1 doesn’t.

By the way, try MAP 1, you might like it a fair bit more than MAP 2 :grin:

1 Like

Thank you! Not sure how this setting changed, but it seems to be working now!

Also switched to map1… :grinning:

1 Like