Random Network Disconnections - Rossini non APEX

Ok so this has been bothering/annoying me for the past months(started 3 months ago i think). I keep on getting random network disconnections. I am unsure where the problem is as this was working fine previously. Could it be the network port? as I have tried 2 cables, even upgraded my router 2 weeks ago. Still has this random disconnections.

It happens most of the time at startup(I always turn the dac off every listening session). The behaviour is always like it was connected at first then you will get a “No Input” display then it will connect again after a short time. It was like this from the very first time I have own the Rossini so I assume its normal behaviour? Can anyone confirm?.

But now at times it would stay on the “No Input” display then I have to restart multiple times before it would connect, even plug/unplug the lan cable. I am unsure anymore w/c one had fixed the connection.
The disconnection happens randomly sometimes I could have a long listening session then get a disconnect in the middle. On a good day I wont have any disconnect, the next day after startup it wont even connect again.

I did try using the loop port, but it is also a hassle as it wont connect the first time and you need to restart multiple times. I am unsure though w/c one would give a more stable connection(main vs loop). I always use the main.

Really think its a port issue, I am due for an APEX upgrade just waiting for the board to arrive at the dealer. So a question are the network ports part of what is being replaced with the upgrade? Please advise.

*Forgot to mention, there were instances where it would connect and disconnect in succession like as if the cable is loose(Where its is not).

As far as I’m aware, it’s only the Ring DAC board that is replaced, I don’t think the ethernet board is touched.

That said, I believe your Rossini will be bench-tested after the upgrade and, if you point this out to them when it goes in, they should be able to look at this and replace, if necessary.


Firstly, I have no idea. And if you or your dog or your kid have not been tugging on the ethernet cable, I cannot imagine there’s a physical connection problem there internal to the Rossini.

Out of just sheer desperation, maybe you want to try this: In a browser go to your Rossini web interface. If you know the IP then it’s just that IP, but going to http://dcs-rossini.local should work. Once there, in the “Device Settings” tab, hit “Reset Streaming Interface” and see if that fixes it. I would recommend power cycling once the reset has happened just cuz why not.


No, only the DAC board is replaced. Everything else is untouched.

1 Like

Thanks for the input guys, figure as much about the apex upgrade leaving the input boards. I just hope the ports are ok. Also hoping no one had accidentally tugged the ethernet cable. In any case if it actually happened it would just broke the main port. I always use the main port.

As for the network reset i have actually tried it already, twice. First time a month ago troubleshooting this same issue, then just recently actually before i posted here about the issue. I think it does something after the suggested powercycle as it does connect successfully after. But after some time, or after a restart the issue is back.

Anyway i think i need to isolate the issue some more. I also ordered 2 more cables.

Try the Loop port, they are effectively equivalent.

1 Like

This type of issue has often been reported and there is lots of information in the archives.

It is unlikely to be a hardware fault . I have been here a long time and every instance of failure of a dCS unit to discover the network or subsequent disconnection has been related to the network and its setup. Replacing your router will have had no effect if the replacement is set up similarly to to the earlier model. It may be that the setup has been amended at some point which may have happened without your knowledge ( e.g with ISP supplied routers).

I suggest that you search the archives on network issues first so you get some idea of the problem. The solution requires you to access the software of your router ( I assume that you know how to do this from your computer) and make sure that the options offered ( usually check boxes) are appropriate. In particular ensure that IPMG Snooping is not selected.



It would be really handy if you could report this to [email protected] and we can pick it up with you there - it’s just much easier to do directly than on the forums as forum threads invariably end up getting messy and things get missed - however if you want to work it through on here instead then I’m happy to do so, nothing to hide, just not as convenient and threads can get pulled off-course.

You can say that “of course I would say this” but very rarely are these issues actually a hardware problem with the Bartok / Rossini / Vivaldi and generally come down to an underlying network issue …

Best regards

Phil Harris


Please can you give us an update on how the problem was fixed assuming it was, as this could be useful for everyone. Many thanks!

David whilst I appreciate that a “silver bullet” solution would be great unfortunately as Phil says:

Network issues are not a uniform problem with a single solution and before even looking at a solution the reason for the network issue has to traced. This may be unique to the questioner’s system and how it has been configured. So details are normally needed first and there may well be several exchanges before the answer suggests itself.

As Phil suggested earlier in this thread given such issues:

1 Like