Qobuz login issue


I am using the Dcs Network Bridge. I just started a free trial with Qobuz but login keeps failing in the Mosaic app (iPad). Tidal works fine & Qobuz works fine in my laptop.

Could someone please advise if I need to configure something else to make this work?


It should work fine but from early memories sometimes Qobuz will work if you enter your user name moniker but sometimes only with your email address instead ( assuming that you are using the correct password). This isn’t a Mosaic issue, it’s at the Qobuz end.

So I would try both ways of entering user.

I used both options (username and email) but both fail in Mosaic. It works fine in my Windows laptop as well as in iOS. So it doesn’t look like a Qobuz issue when I am able to log to Qobuz anywhere outside of the Mosaic app and play tracks.

I also downloaded the DCS Network bridge app. Qobuz doesn’t even show up as a streaming service in that app…I can only see Tidal & Spotify.

That is correct. The Network Bridge app predates Mosaic and Qobuz is/was not available with it.

If you cannot log in to Qobuz using either your moniker or email address then I can only suggest:

  1. You are making a repeated mistake when entering your password.
  2. The version of Mosaic that you have installed on your ipad is corrupt. Reinstall a fresh copy from the App Store.
  3. The Qobuz API is not compatible with the new iOS v. 14 if you have that installed. I may install this on my i-pad later to find out.
  4. The Qobuz API will only give access to full Qobuz members ( unlikely but who knows?).

Thanks Pete. After a few hours, I tried logging back in and it worked (no changes from my side). Looks like there is a delay between the time you create an account in Qobuz and when it gets synced up within Mosaic.