Problem with Upsampling to DSD from AES source on Upsampler

Hello, i’m using Vivaldi DAC, Clock and Upsampler at latest HW and SW release. I’m trying now to use the system with an external source on the AES Digital input of the upsampler. This source is a 3dlab Nano Player v4 that is integrating the Leedh Processing on its digital outputs. The Nano and the upsampler are connected through an AES cable.
I have no problem to listen to music stream from the Nano through the AES cable and to the upsampler as soon as the output of the upsampler remains PCM till 352.8 or 384 kHz.
When i ask the upsampler to upsample to DSD or DSD2, music plays for few seconds, then stops and play again. The streaming is not stopping but is is like the upsampling is not working fine.

I don’t have alternate source to the Nano today to test if it could from this product and this is why i’m sseking for your support in order to see if somebody already tested this configuration and would have the same problem.

With the upsampler connected to the ethernet and upsampling to DSD2 is not a problem at all.

Thanks for your support

I can only speculate but I would think that something like this may be the reason:

Vivaldi Upsampler can convert PCM or DSD inputs. However if the Nano applies a form of DSP to the digital output in the form of Leedh Processing then Vivaldi Upsampler may not “recognise” the result as a PCM file ( or at least a PCM file of the type it is expecting) and cannot successfully apply its upsampling algorithm from PCM to DSD. However PCM to PCM remains viable.

Does that sound reasonable?

It is, indeed, an option. I will remove the Leedh Processing and check

Just tested without any Leedh Processing : same problem.

In which case I can only stroke my chin and say " Hmmmm" :thinking:

Does this happen continuously, with the music stopping and starting, or do you only hear one dropout for a few seconds and then playback is normal?

Have you set your Upsampler Sync mode to “Audio”?

Since the 3DLabs player doesn’t have a clock input to sync to your Vivaldi stack, the Upsampler source clock has to be derived from the Nano’s AES PCM stream.

Hi James, it happens continuously: dropout, sound, dropout…

Hi Anupc, sorry not sure to catch. The upsampler clock is set on that :

  • Set the Upsampler to the AES source, like you would for listening to the 3D Labs player.
  • Go to the menu of the Upsampler, then into settings. Change the Sync Mode setting from Word Clock to Audio Sync:

Audio Sync

  • Connect a BNC Clock cable from the Word Clock Output of the Upsampler to the Word Clock Input 3 on the DAC.
  • Set the DAC to the same input as you would for listening to the 3D Labs player.
    Go into the settings of the DAC like you did with the Upsampler. Go to the Sync Mode option and change this to Word Clock 3:

WC3 Sync

That should stop these dropouts. The issue here is that there are two clock domains running in your system currently, so things are getting a little out of whack. As above, the workaround is to lock your Upsampler to the 3D Labs player, then the DAC to the Upsampler.

Let me know how you get on with this!

1 Like

Thanks James. Will try tomorrow and come back to you.