Problem with Puccini. Help


I own the Puccini device, and I have this problem where the device is stuck on this stage

The device is not responding, not via the button nor the remote.
Also, all the fuses looks good and not burnt.

Any idea why is this happening or how it could be fixed ?

Thanks in advance

Very beautiful couple. Sorry for off-topic ))

You need to turn the units fully off so that when they are rebooted they can reconfigure. Turning the units off from the front fascia button or from the remote does not fully disconnect them from the mains. You need to use the rear panel power switch to switch them off then to switch them back on again.

Please let us know how you get on.

Hello. Thanks for your reply !
Already tried this. With the power switch, and also trying to plug and unplug the power cord itself but nothing helps.

Any thoughts ?

Is the Puccini pair a new acquisition from the used market or have you owned them long term with trouble free past use with this problem occurring only recently?


The devices were brand new when I purchased them and I have been using them for the last few years trouble free. Never had problem like that before, and when contacting specialists none of them had idea why is this happening.

OK, I was trying to establish if it was a new purchase of which you may not have had a previous opportunity to check for correct operation. However that is not the case.

I have looked through the archives here and cannot find any precedent for your issue nor do I recall one.

It superficially looks like Puccini’s OS is not loading ( but see my new thought below). I had hoped that a rear panel switch off and reboot would have reset the machine and it would then behave as usual. With some other devices there is a combination of buttons that will force a reset like e.g. hold down both volume button and power button at the same time for 5 secs but sadly I am unaware of anything like that with dCS equipment.

Given the age of the Puccini and the unusual character of the issue and that it is not fixed by rebooting I think that this may need the attention of a dCS engineer. Are you in a country with a dCS distributor? I don’t know whether @James or @Bashcroft ( dCS engineers who sometimes contribute here) are able to offer assistance. Have you tried your dealer or local distributor for help or were they the specialists with no idea why this is happening?

Just before I leave I have had a new thought . Checking the User Manual the switch on display for Puccini shows the product name and dCS. Your picture shows the SACD logo instead of Puccini. If I recall from my days with Paganini correctly the SACD logo only appears when an SACD is loaded. Could you have left an SACD disc in the transport which may now be jamming it? Just a thought.

Hey @Thisisab, welcome to the forum. I must agree with @arzojaan - Your Puccini Clock and Player look great in your photograph!

I will contact you via PM on what your next steps should be.

Thanks for the tag @PAR.


1 Like