Problem with DSD128

I am no more able to play DSD128 files on my Bartok.
They start to play and after few seconds the sound get distorted and than it skip to an another song…and so on,
No problem with DSD64.
I use Roon and it’s Nucleus.
I have tried to play the files without Roon and Nucleus (just minim server and DCS Mosaic) but I got the same result.
So, I think, the problem is the Bartok.
What is really strange is that one week ago I didn’t have problems.
And I don’t have mess up with the settings.

Can anybody of the support team help me?

Hi Stefano,

Are you able to put a couple of the DSD128 files onto a FAT32 formatted USB pendrive and try playing the files from the pendrive when it is plugged directly into the rear of the Bartok?

This will allow us to identify whether the issue is with the Bartok itself or external to the Bartok (i.e. network or a network device).

Best Regards

Phil Harris

Ok I will try
Thanks Phil

Ok Done.
No problem with a USB pendrive.
Same file with Nucleus +, doesn’t work.
Same file with Nas + Bartok, doesn’t work.

Same file one week ago with same sources, worked very well.

I understand could be or maybe is correct to say must be a network problem.
But what can be happened?
And have any advice about what can I do?


Can someone help me?

Hi Stefano,

OK so what is between your Bartok and your router and what is between your NAS / Roon Core and your router? It looks like you have a bandwidth limitation there somewhere that is choking on higher bitrates and given that DSD128 isn’t very high in itself that is likely to be a fairly major bottleneck.

Are you using any kind of ethernet extenders or relays? WiFi extenders? Mesh? Ethernet over Powerline? “Audiophile” network switches?



Hi Phil.
My router is connected via Ethernet to the NAS and also to the Nucleus.
Also the Bartok is connected to the same network.

Just between the Nucleus anche Ethernet exit there is a switch that serve other 2 devices.

But since I have problems both with Nas and with Nucleus (with internal memory) I don’t think the problem is the switch.

However I have just discovered that I have problem of connections with my provider.
Problem that is getting worse day by day.
I have, right now, called its technical support.

At this point the problem could be that.
So I think the better is to wait for them unless you have some advice.


Hi Stefano,

Are the NAS, the Nucleus and the Bartok all connected to the same switch? (…and then the switch uplinked via an Ethernet cable to the router?)

What sort of switch is it?

Just the nucleus.
The switch is a Netgear 605.

Would that be a GS605 or an FS605?

Can you connect all three of them to that switch to test please?

It could well be that your router is running a software switch rather than a hardware switch (quite common especially with routers that can have ports retasked as WAN / LAN ports) and the router is causing a bottleneck.

If you can connect the Nucleus, Bartok and NAS to the switch then the traffic there should all bypass the router completely.

Sorry Phil I miss the GS.
Is a GS605.

Sorry but is impossible to connect the NAS Bartok and Nucleus to the same switch.
I have the devices all over different rooms.
Really is impossible to do.

I forgot even the NAS is linked to a switch.
Only the Bartok is directly connected to the Ethernet exit

One friendly suggestion to help @Phil help you would be to draw out your devices and signal path and then upload the image on this thread. Phil and other highly skilled network folks on this forum may be more useful then

Just my 2c. Good luck!

Hi Stefano,

It isn’t possible to move them for the purposes of trying to identify the cause of the issues that you are having?

Well Phil I’m sorry.
Let say is really problematic.
But ok I will try to do it.

@keiserrg How can I do it?
I really don’t know where to find those informations

Hi Stefano,

It would certainly allow us to start to identify where your issues are being created if you can and then we can work from there.

Hi Stefano,

Have you been able to make any progress on this?

Hi Phil.
In this moment I am away from home.
I will try to do what you ask as soon as possible.
Thanks Phil