On a Rossini Player is there a way to eliminate the latency on S/PDIF 3 (TOS)

I have a TV connected to a Rossini Player via S/PDIF 3 (TOS).
On occasion, the sound lags the TV by a very small amount. Is there a way to eliminate this lag?
Thanks,

I am unaware of any such option on any of the dCS DACs that I have owned. However check your TV’s or streamer/player box’s user manual. Some sets/boxes do have an option to alter the synchronisation when connected to external equipment with SPdif. However that may possibly exacerbate the problem rather than cure it if the synchronisation option only offers a delay and not an advance . You need to check your own TV’s particular options in its Sound menu.

There’s a “Buffer” configuration in the Settings --> Device menu which I believe is On by default - delays the data stream into the Ring DAC by over half a second for Redbook rates - turn that to Off and you should be good to go.

Thanks for the suggestion.
I already have the buffer set to off but still encounter the latency.

Then, assuming you don’t have any DSD Upsampling configured (that would add some extra delay), I wonder if you might see a fix by switching the Mapper to the legacy “Map 2” configuration (rather than the higher rate “Map 1”) just for your TV viewing.

Do you have the option to connect with an optical lead? I do this into my Rossini, turn off buffer and no issues.

Hope that helps.

Paul

Hi @qlsuzdcs395,

With the buffer turned OFF, the maximum ‘delay’ in audio seen across all the digital inputs of a Rossini is no more than 5ms.

With the buffer turned ON, this is considerably higher. (0.72s at 44.kS/s, 0.16s at 192kS/s).

I understand that you have already checked, but can you just take another look at your Buffer settings?

As a reference, the symbol for Buffer OFF is as follows: Buffer%20OFF%20symbol
That is what you want it set to.

This option can be found under the unit settings of the Rossini front Panel.

(Menu -> Settings -> Buffer mode)

Please let me know how you get on!

Thanks for everyone elses suggestions, too.

Thank you,

Ben

1 Like

Thank you all for your suggestions.
Anupc - I use the default Upsampling = DSD, but is that applicable for a signal from a TV?
Paul - Yes I am using TOS link optical. Thanks

Hi Ben - I normally control the unit via mosaic but I did recheck via the front panel and I can confirm that the buffer is indeed on.
Thanks for the details on the timing delay. Very good to know.

Do you think that a 5ms delay is perceivable?
Do you think that the buffer mode is the only thing that could cause a perceivable delay in the audio?

I will continue to monitor the situation. This issue tends to be minor (not a constant problem).
If the buffer mode is the only thing that could cause a delay, perhaps the issue is not with the Rossini but rather with the source material. Further review is needed.
Thanks again for everyone’s suggestions.

Thanks for rechecking @qlsuzdcs395. This should fix your problem. Please feedback if you are still experiencing an issue.

The delay caused by the Buffer being ON is unnoticeable during music playback. This is actually true for both buffer settings.

However, with Buffer mode ON, the audio has been known to play out of sync with the picture when using with a Television for example. As you have recently experienced!

1 Like

The threshold of perceptibility is apparently +45ms to –125ms (timing variation of Sound-with-respect-to-Video) based on ITU’s broadcast standard for Audio/Video synchronisation (ITU-R BT.1359-1). So, sounds like (pun unintended) you’re all set :grin: