No mosaic connection

Bartok will no longer connect via mosaic.
I can find the player but it immediately disconnects once selected.
If I disconnect the Ethernet cable it shows no network, reconnect the Ethernet cable, network is immediately present.

So far I have

Uninstalled and reinstalled Mosaic
Tried a different Ethernet port on router
Reset the router
Switched Bartok off and on
I don’t have a spare Ethernet cable suitably long to try alternative.

Still no joy
Any ideas?

I am having the same problem here in Omak Wa. using an Iphone X. have tried all your solutions above
My Bartok has run flawlessly since i got a fiber connection to the internet about 8 months ago, and i am hard wired.
So wondering if there was a Mosiac or Bartok update this weekend?
unfortunatly cant stay connected long enough to get to the setup menu in Mosaic to check for updates
thanks for any help

Just managed to reconnect after about 90 minutes fruitless changes.

It’s just decided to work. No idea what changed.
It’s as if the server had crashed and has now recovered.

Yes, me too with Vivaldi . Connection then connection lost after a second or two. Happened with both iOS and Android Mosaic installations.

I have spoken with dCS and first line response did not have explanation and I am awaiting a call back.

It seems to have been something “out there”.


OK I have just been talking again with dCS and it looks like something has occurred on the internet which affected Mosaic which was connecting but then throwing out the connection after a second or two. Investigations are continuing but as I understand things currently we are all reset and working fine. I hope that this will be permanent :thinking:.

Thanks for that.
I always assume it’s me.:grinning_face_with_smiling_eyes:

1 Like

Yesterday Bartok started to lose the network, the connection was absolutely unstable, so I could not even start the playback. I tried another cable from the provider’s router, removed all IP reservations, rebooted all network equipment but nothing helped. Then I performed a complete reset of Bartok network interface, for a while the connection was stable, but then it was repeated again. I have not noticed that there have been any Mosaic or firmware updates in recent days.
Does this sound like a global problem?

I can check it again after work.

By the way, after resetting the Bartok network interface to the default settings, it worked stably while I was playing files from the local network (DLNA). As soon as I logged into the Qobuz account and tried to start the track, the connection was immediately lost. It might be a coincidence, but I don’t understand the dependency. Bartok is connected to the local network, why is the IP address lost?

Yes , it seems to have been global as it affected me in the UK and @Jmhenrie in the USA . I am unsure where @Dcs2021 is situated.

The problem occurred very roughly between 10:00 and 14:00 GMT. so many American users will have been asleep and many European users at work when it occurred otherwise I expect we would have received many more reports.

Mosaic works using several online facilities provided via airable (including Qobuz) so maybe there was a temporary issue affecting that side of things?

1 Like

I’m UK also.

Russia the same

I have found over the past week where several times my Rossini has shown no network connection on is from panel. It has been flawless for over a year

That is a slightly different issue from yesterday’s problem . in that case there was a connection maintained by the network board throughout. However Mosaic would connect then disconnect within a second or two. Even when Mosaic disconnected the network connection itself was stable.

I am surmising that Mosiac discovered the dCS device but was then unable to populate the home screen with services so reverted to searching for other devices.

Gregg as you will be aware most of network disconnection / non discovery issues are related to LAN/switch issues and that is not my area of knowledge. Perhaps if you post a new subject topic with details one of the experts like Anupc would be able to help?

Thanks Pete
The issue has stopped occurring (for now) so I do not want to start bothering anyone unless it starts to reoccur


in my case, Bartok was constantly losing IP, so the Mosaic became inaccessible, I thought it was a broken Bartok network interface. Now it looks like everything is in order. But I do not understand how this could be caused by outside influence.

It is because Mosaic is connected to the internet as services e.g. Tidal, Qobuz, radio etc are provided via airable in Germany. So even if you are not selecting them Mosaic still requires them.

OK, but Bartok is connected to the local network and receives IP from the local DHCP. How does the Tidal or Qobuz account cause the loss of IP?
I tried static, automatic IPs, binding by MAC address, but nothing helped.
at some point I could not even play local files through DLNA, this immediately caused a loss of connection

If you read back over the thread I have pointed out that out that yesterday’s issue did not involve any loss of network connection. It was a loss of Mosaic functionality and it seems that due to this it could not maintain the app to hardware connection, The network board was still connected throughout and displayed the correct IP address. This needed to be checked via the dCS device display as it could not be displayed by Mosaic for obvious reasons.

I made a video yesterday. This is how it looked to me. For obvious reasons, Mosaic also lost connection. And now I don’t have this problem, like everyone else here. It’s hard for me to explain it.

Interesting, I haven’t encountered any Mosaic connectivity problems all week, I wonder what that “outage” you guys experienced earlier this week was :thinking:

Typically, the IP Address will switch to “N/A” when your dCS loses the Ethernet carrier signal, like when the Ethernet cable is unplugged. My guess would be that you’ve coincidentally got an intermittent Ethernet physical connectivity issue somewhere [in] your setup, either with the cable, or with one of the associated Ethernet ports.

I also thought so at first. But I tried to check it with two different routers and lan cables. I have not changed the network configuration before.

The other possibility is of course that there’s a problem with the network board on the Bartók, but thats highly unlikely, and I don’t think we’ve ever seen anyone reporting such a problem before. :thinking:

[Another remote possibility is that] some Enterprise Ethernet switches do support (uplink) network link failure propagation down to the client ports. What Router/Switch is your Bartók connecting to?