Network Bridge LED blinks and Mosaic app does not find the unit

I’m having trouble with my dCS Network Bridge.
The blue LED blinks and Mosaic app does not find the unit.

Troubleshooting steps:

  1. power-cycled the unit

  2. tried with a different, known working, Ethernet cable.

No use.

Installed dCS software version: don’t know since cannot communicate with unit, but was latest versions at least up to the day before yesterday.

Thank you.

Hi there,

Firstly, welcome to the forum!

Is this a new Network Bridge, or have you had the unit for a while and only started seeing this issue recently?

Thank you.

Acquired new 11/2019. Issue first occurred yesterday.

Furthermore, tried connecting Bridge:

  1. directly to router
  2. directly to iMac (which is also my Roon Core)

No luck.

The LED on the switch port to which the Bridge is connected is off, as opposed to the LEDs of the ports to which other devices are connected, which blink happily.

Is it visable on your network? I use Fing app to see all devices on the network.

When you power cyckled it did you leave it of for a while?

  • Have you tried the Network Bridge connected to another working port on your switch or router?
  • Have you ever set the unit to a static IP address, or has it been left on DHCP (the default setting)?

FYI, if the front LED constantly flashes it indicates that the unit is not receiving an IP address from the router. This could be because the Network Bridge is trying to use a different subnet to the router because of a static IP, or if you aren’t seeing flashing lights on the network sockets of the switch / router could be indicative of a hardware fault somewhere in the chain.

Thank you for your kind replies.
NB is not visible on my network.
I did leave it both off and on for a few hours after power-cycling.
I tried the Network Bridge connected to other ports on my switch, as well as directly to the router.
Never set the unit to a static IP address.

Dear @James, I wonder what the next step in troubleshooting or servicing would be?
The rest of the chain seems to function normally.
Thank you.

Thank you for the additional information.

It sounds like this unit requires servicing. I will send you a private message and we can take this from there.