Network Board update error on Rossini DAC

Was Wondering if anyone has had trouble updating software on your Rossini DAC…Mosaic shows an update available for the network board…it’s currently version 504. Every time I try an update it says error and to try again. Can’t get it to update no matter what. Any advice?

  • Buck

I recall having the same issue on the Bartok a week or two ago.

Have you tried turning the Rossini off using the rear switch before starting the update? (Turn it on again afterwards so you can actually do the update, of course :-))


Buck, do you have a Firewall on your Internet access? If so, temporarily turn off the firewall, and try updating again - the dCS firmware servers [generally] need direct non-firewalled access to your Rossini. :grin:

The update on my Rossini DAC went, in fact, smoother than the first time I did it. I just switched off the DAC with the switch on the rear, switched it on, then launched previously-updated latest Mosaic on my iPad, and let it search for new firmware for the DAC. Which it found - so I initiated the update. Then leaned back, a LONG time (20 minutes or so?) and did not let the inconsistent messaging about Mosaic not being able to reboot the DAC and/or not finding it fool me - it did finish correctly in the end.

1 Like

I had to switch my Rossini DAC on an off a few times before the update was successful.

No problems at all with mine

Well, I finally got it to work, didn’t really do anything special, just tried it about 20 times! Eventually it loaded and updated. Who knows! BTW, what exactly does the network board update do just out of curiosity?

  • Buck

From: Release Notes: dCS Mosaic 1.1.3