MQA displays on Roon but not Mosaic?

Yesterday I purchased a Bartok Headphone unit and am incredibly impressed, the Susvara headphone never sounded better.

I’m having an issue when playing MQA files via Mosaic the MQA icon does not show on the Bartok display, if I play the same song via Roon it does. I’ve tired this with several songs with the same result. Am I missing something in the Bartok settings to enable MQA via Mosaic? I’ve attached four photos showing the Bartok display and the Mosaic app that demonstrates what I’m seeing. Thanks for any advice you can offer.

Hello kdogitis and welcome to the dCS forums!

So, we can see on that second set of screenshots (the one with the Tidal icon) that Mosaic is not receiving an MQA stream from Tidal.

What you should be seeing is something like

Just as a first troubleshooting step, and perhaps another user or even one of the dCS guys might have a better idea, can you check in your Tidal account settings if you have MQA streaming enabled? (I assume so, since Roon can get it, but, just in case)
And also if in the Mosaic app if you see the little MQA logo next to the albums? So, in my case, after logging in to Tidal in the Mosaic app I can see a TIDAL Masters list option.

And clicking there I get a list of MQA albums, all with the little MQA logo next to it.
Can you see those as well? Or is the MQA logo absent?

Skywatcher, thank you for getting back to me. My screens look exactly the same as yours, the MQA logo shows up in Mosaic in the same way it does on the screen-shots you included.

There was one time where the MQA logo showed up on the Bartok display (using Mosaic) but it was there for less than a second and then disappeard. I only saw that once though.

I have logged out and back in to Tidal in the Mosaic app. I logged out of Tidal on Roon to see if it was causing a conflict, but no luck.


Are you sure you have the latest Mosaic update, 1.1.3? Just checking.

From your Tidal screenshot of your Mosaic app I see: MPEG:778.8 kbps. This is not correct.

There is a long topic on this community about it, which you might like to read:

I just received Bartok yesterday and downloaded the Mosaic app, so I do have the latest version.

I read the thread you linked to but I couldn’t tell if there was any known fix. It seemed their was speculation Tidal changed something and then fixed it.

Like you, I have Roon and do not have to worry, it works.

Mosaic is not just an app. I trust that your new Bartók itself is up to date with its (network) firmware, but please check.

1 Like

As Erno pointed out, this issue was encountered by the community over a year ago when Tidal unilaterally changed their MQA streaming tag.

Is your Bartok a new unit? You might want to double check that it’s running the latest network board firmware. From your Mosaic Control App click on the three-bar menu (top left) → Support → Versions → [Check for Updates] at the bottom of that versions screen.


Bingo. I purchased a demo unit and needed to update the Bartok firmware. All is well with Mosaic MQA now.

Thank you all for you kindness helping a new guy get up and running.