Mosaic updates NEVER go smoothly

Is it just me, or do updates never go smoothly?

For example, despite power cycling my RP with the power switch before applying an update, it always takes forever and the “rebooting” step done by the Mosaic app never does. Unlike the firmware upgrade to Mosaic 2.0, there was no progress report ala “XX/XX” for the network update, just the words the update was occurring on the front display panel.

This time around my Rossini hung at this step (I figured thirty minutes was long enough), and when I power switch power cycled it without first quitting the Mosaic app my RP immediately went back into “updating” mode.

I finally had to quit the Mosaic app then power cycle my RP via the power switch (a third time) for the network board update to “take.”


It went smoothly with my setup (Vivaldi Dac + Upsampler)…

Same for me, Bill. A bumpy road always, but at last it works.

What I do/ did:

  1. Power cycle Rossini DAC (back switch)
  2. After it comes back (have to wait for 2 instances before network is connected: no input … no input): then update the Mosaic Control app
  3. In the new app, go to Support - Versions - Check for new updates
  4. New update is downloading - Check integrity
  5. Rossini DAC goes into new network update state
  6. Does not show updating, stays in this state
  7. Mosaic control app finishes, warns for Rossini going off line
  8. Rossini DAC does NOT power cycle
  9. App lost connection, looking for Rossini
  10. Everything hangs
  11. Manually power cycle Rossini, manually close and start up Mosaic app
  12. Bingo, it worked

NOT smoothly indeed.


My approach, which has been pretty reliable:

  1. Power cycle the Bartok with the rear power switch.
  2. Browse to http://dcs-bartok.local/
  3. Switch to the device tab
  4. Click “check update” in the “Internet Update” section.
  5. Click “update”

I don’t ever update from within the Mosaic app.


Thanks, but you still have to update the Mosaic Control app.

Strange. In all my years of owning the Vivaldi stack and Bartok, I’ve never ever experienced a hang during or after a firmware updates. I’ve had to manually reboot after upgrades completed when Mosaic said to or the front-panel, but never a hang.

dCS if you are listening another Rossini owner providing feedback


Actually, whether it’s initiated from the Web interface or from Mosaic, the firmware update happens in exactly the same way; the dCS unit directly pulls down the firmware image from dCS’ fwupdate server.

When using Mosaic, it just reflects the status of the update progress and has no bearing on the actual update, and disconnects when the streaming card resets.

It’s rather disturbing that the network card provides no progress updates whatsoever.

The direct download is surprising as the Mosaic app first downloads and verifies the update before telling the DAC to download it.

No it does not.

Mosaic Control is actually just telling you that the dCS unit is downloading the firmware and verifying it before it flashes the update. The Web UI does the same thing, but uses Javascript, instead of the Mosaic Control App, to reflect the status of the download, verification, and update, all from the dCS unit, not Mosaic Control.

1 Like

That makes it even worse as far as not bothering to update the user on the front panel and the fact that it seems hung long after the app says the unit started updating.

I don’t disagree that there are areas in which dCS could improve the User experience of firmware upgrades, but I’m guessing it’s a question of priorities.

Also, although dCS makes it pretty seamless, the network board firmware upgrades and the FPGA firmware upgrades are two very different processes in very different parts of the dCS system.

After a decade of owning the Vivaldi stack, the one suggestion I can make is to exercise patiences; when upgrading using Mosaic Control for example, just let it do it’s thing, when Mosaic Control loses connection to the dCS unit, just wait for it to regain connection by itself (which it will do when the network board has finished resetting after it’s firmware has been upgraded). If there’s a DAC FPGA update as well, that’ll start by itself with the front panel block chunk counts and update progress bar, and a PLEASE RESTART front-panel message after its done.

1 Like

It’s great to get feedback but what’s “KLUNKY” about it though? What would turn it from “KLUNKY” to not clunky?



Some of the big ones:

  1. Specifically tell people to power cycle the unit with the switch prior to performing an update

  2. Provide a progress section, either in Mosaic or preferably on the front panel noting the progress of the update… the downloading/verifying process works, the install process is kind of “fuzzy.”

  3. Have the reboot actually work or just tell people to power cycle it (you do, but only if the reboot “fails” - I have never seen the reboot work.) You may actually want to tell people to ignore whatever the display says.

In my case Mosaic said it was done updating and to power cycle the RP because the reboot had failed, but the front panel still stated it was updating… where I left it for thirty minutes just to be safe as I know a failed firmware update is the fastest way to “brick” a board.

As I mentioned, I then power cycled the Rossini Player without first exiting Mosaic on the iPad, and as soon as the RP rebooted it went right back into “updating network board” mode.

It was only when I exited Mosaic on the iPad first and then rebooted the RP that things got back to normal and after a very extended delay in connecting (minutes) Mosaic connected to the RP and showed the network board was now running the proper version.

Back when Mosaic 2.0 was released, my RP got stuck on installing block thirty something of however and I needed to once again power cycle reboot and the second time the install worked.

1 Like

This is exactly what happened to me and my Rossini DAC.

1 Like

It’s a bit odd, as with both the Bartok 2.0 and the recent 509 network board updates, I had no problems at all. I just did the ‘power cycle’ thing first and the updates went through with no hitches or hold ups. There must be some reason why some people seem to have consistent issues while others do not. Maybe local network stability?

My local network is never giving me problems.

It looks like something inside the Rossini DAC does not go as planned:

From the logs: log-nSDK :

20220627 13:42:23.959 [756.777] INFO FirmwareUpdate: Checking for manifest at
20220627 13:42:24.281 [756.777] INFO FirmwareUpdate: Manifest Downloaded
20220627 13:42:24.378 [756.777] INFO FirmwareUpdate: dcsfwupdate: INFO : unit type is Rossini DAC
20220627 13:42:24.381 [756.777] INFO FirmwareUpdate: dcsfwupdate: 
20220627 13:42:24.388 [756.777] INFO FirmwareUpdate: dcsfwupdate: INFO : Unit Type is: RDC, manifest includes RDC
20220627 13:42:24.396 [756.777] INFO FirmwareUpdate: dcsfwupdate: INFO : Current Network Board version: 0.64.509.0
20220627 13:42:24.396 [756.777] INFO FirmwareUpdate: dcsfwupdate: INFO : Using comparison method: gt
20220627 13:42:24.399 [756.777] INFO FirmwareUpdate: dcsfwupdate: 
20220627 13:42:24.402 [756.777] INFO FirmwareUpdate: dcsfwupdate: INFO : Unit serial number is: RDCabcde / prod / WL
20220627 13:42:24.402 [756.777] INFO FirmwareUpdate: dcsfwupdate: INFO : Update to Network Board version: 509 does not apply
20220627 13:42:24.403 [756.777] INFO FirmwareUpdate: dcsfwupdate: INFO : FPGA version is: 2.04
20220627 13:42:24.404 [756.777] INFO FirmwareUpdate: dcsfwupdate: 
20220627 13:42:24.416 [756.777] INFO FirmwareUpdate: dcsfwupdate: INFO : Update to Main Board version 2.04 does not apply
20220627 13:42:24.421 [756.777] INFO FirmwareUpdate: dcsfwupdate: 
20220627 13:42:24.422 [756.777] INFO FirmwareUpdate: dcs-fwupdate returned 2
20220627 13:42:24.423 [756.777] INFO FirmwareUpdate: No update possible. Exiting.
20220627 13:42:24.423 [756.777] INFO FirmwareUpdate: State updated to idle. No updates must be available.
1 Like

My n/w board 509 upgrade went pretty smooth with me new Rossini Apex dac. But I did reboot the Dac before starting the upgrade form Mosaic.


Hi Phil
Nice to hear from you. We miss your presence at our USA Saturday Naim user group Zoom calls!

The biggest issue I had with the update was the fact that the Mosaic app on my iPhone instructed me to reboot the Rossini however this was while the Rossini was still downloading the firmware from the dCS server.

As others above have mentioned it is not a good idea to reboot the Rossini while it is either downloading the firmware…or unpacking it once downloaded. It seems like a good way to brick the device.


Well I’m happy to jump in again if you would like… :slight_smile:

OK … so if the app is saying to reboot the unit at a time that is incorrect and would brick the device then I’ll take a delve and see what I can find out and see what can be done.

Cheers… :+1: