Mosaic Unable to connect to streaming services?

Mosaic fails to load streaming qobuz, deezer, tidal right now? Anyone having the same issue?

Cannot search also, streaming names/tag does not appear on the search feature w/c is usually at the top?

All of the services that you cite use airable behind the scenes AFAIK . Can you choose the radio option and see if the services are listed?

Radio fails to load also:

Using mconnect right now, and its working fine. Its just when i use mconnect the track title does not display on the rossinis display. Is there a new version of mosaic? I did check for updates but none available.

Here is my current version installed:

It looks from here like there may be an issue with your local connection at some point. Mosaic is discovering the switch/router connection ( or you would just see a continuous buffering icon) but there is no onward connection with airable.

Airable and Qobuz iare working fine for me here in the UK. My initial quick fix would be to simply close things down ( including your switch/router) then reboot it. If that fails the next thought is that your copy of Mosaic app may be corrupt so delete and reinstall. BTW, you have the latest iteration.

Let us know how you get on.

Restarted my router, reinstalled mosaic on my iphone, and ipad, have one newly installed on another iphone, even reset network settings on dcs ip. Still no dice :frowning:. This was working about 2 weeks ago(last listen using streaming).

Not very technical about how this airable works, I believe its a service or api? is there other way to check it outside the dac? maybe my isp had blocked it? mconnect app works and I could get expected bit rates/sample rates but its just the metadata is messed up. Just wondering why mosaic is not working? both app works the same way right acting as a controller to access the renderer inside the dac?

OK, so if I understand correctly you have rebooted your system ( not just the router but all of the digital part) and reinstalled Mosaic app. Result, no dice.

Airable is a radio ntegrator which means that it offers numerous internet radio stations from a single point. However it also provides technical access to streaming services behind the scenes. This is really a B2B relationship. As such punters like us cannot select the service as individuals except via one of their customer’s apps such as Mosaic. However you can still check the individual radio stations using Google. An API ( Application Programming Interface) is the software that Qobuz or Tidal etc. provide to the services such as dCS so that it can be incorporated into the app.

As for an ISP blocking airable that is unlikely but it depends on where you are. In some territories e.g. PRC it might be so. Otherwise I can’t see it.

Network settings on your router have been working fine. Maybe unknown to you the manufacturer or ISP has applied an update ? Worth opening the switch’s software on your pc or mac and checking.

I wonder that it might not be a local issue behind the scenes that gets resolved over the next few hours? However the mconnect situation with messed up metadata may indicate something is amiss. Is this both for Qobuz/Deezer and UpnP streaming?

Thanks for the detailed information. I kind of get how it works now. And yes i have restarted all devices connected to the dac. The setup is just the router directly into the dac via lan, no pc, nas, roon etc…
In between.

And yup. Not from the PRC either. And my setup has been working fine with mosaic all those almost 3 years of owning the rossini. Could be another airable outage? I remember similar happening months back. And i have like the same issue. Fingers crossed its just a local issue and as you said will be fixed itself later.

Also is airable exclusive to mosaic? Just confused why mconnect works and tidal connect works. Do they use different service?

I’ll dig deeper on my network settings also something might have changed somehow.

But have you restarted the DAC itself ( which I am assuming is one of dCS’ - ah, just seen that it’s Rossini)? To do this properly the DAC’s system needs to be refreshed. This means that it is insufficient to switch off using only the button on the from the front panel. You need to switch off from the rear panel’s rocker switch, wait a couple of minutes then switch back on.

As I mentioned earlier, there is no issue with the airable service as I have been running it OK in the UK.

As I said airable is a B2B service and may be used by many customers, not only makers of streamers but makers of radios with internet facilities etc. Briefly the device manufacturer buys the service from airable and incorporates it in their device or app. Other services use competitor integrators such as Tunein Radio. Tidal connect is a different type of service where the streaming application can be a direct connection but is limited to one service i.e. Tidal. Mconnect has its own method ( unfamiliar to me) and offers playing via UpNP or Tidal, Qobuz or Chromecast, So, briefly , they are all different bits of tech offering different permutations of service access. Therefore they will not always behave similarly. UPnP or Qobuz/Tidal are not the same sorts of things even if you see them as just being choices in mconnect.

You have said that you are not very technical (nor am - others may be more help if we need to seek further) but are you familiar with how to access and alter network settings? Do you know what you may be looking for?

I can’t really tell what might be going wrong, but since you’re using all Apple devices, did you recently update them to iOS 17? As a suggestion, you might want to check that your iOS iCloud Private Relay function is turned OFF.

Yes they’re both controllers, but they work very differently, especially in how they access the Streaming Services.

1 Like


We are not aware of any specific issues with streaming services at the moment - I see that Anup has suggested checking that Private Relay isn’t turned on on your portable devices and that is a very good suggestion.

Do you have any Android phones or tablets in your home? Have you checked with any other iOS devices?

I’m more than happy to pick this up with you if you wish however things can get a little messy when there are several different people involved so please let me know what you want to do - you can always get us directly at [email protected] too.

Best Regards

Phil Harris

Hi @Phil,

I checked the ios versions of the 3 devices(2 iphones, 1 ipad) I have test with and all are still on IOS16.
I just rechecked now and still the same issue on all 3 devices. I could borrow an android device from a relative but that would have to wait since its way late right at night here now. I’ll do this early morning later. Anything we could do for the mean time other than the android test?

Just FYI i asked a friend(same country) to test his mosaic access to streaming and its working fine for him(he tested on ios also). So I think its an isolated issue for me only.


Hi @3ggerhappy,

Private Relay has been around for a while now - not just iOS17 - so definitely worth checking that that isn’t turned on but I don’t think that’s the issue - when that causes a problem it’s more subtle than everything just not working.

I’m absolutely sure that this is an issue that is specific to you and it could be that a DNS entry somewhere out on the interweb that your ISP is using supposedly pointing to Airable (the streaming services aggregator) is wrong which could well be why you’re not getting anything on any of the services that are hosted via them and incorrect DNS entries usually resolve over 24/48 hours due to how DNS servers propagate DNS entries.

Unfortunately there’s not much that I can suggest from this end given that you have restarted your router (that would force the router to pull down DNS details again) hence why I think it’s an external DNS / ISP issue …

Where are you located geographically?

1 Like

I am from South East Asia, the Philippines. I’ll check again the private relay feature if its on the devices, and restart the router again for good measure. If issue still persist I guess I will just have to wait it out, this was working fine most of the time previously so eventually i think will sort itself out. I will also test with android later. Thanks guys for the suggestions so far. I’ll keep you posted.

Ok update: Mosaic could now access the services. What i did last is to turn on the override dns in the dacs ip where you could access the network settings. Then i put a public dns googles dns in this case then restarted the dac. At first it still wont work then i gone back to using mconnect. After maybe 20mins i try again then it started loading the stations on radio.

Thanks everyone for the help!

1 Like


I’m really glad that you’ve solved the problem by setting an override in the Rossini to use a specific DNS server however I would definitely recommend that you clear that static DNS setting on your Rossini as soon as possible - in this specific case setting a static DNS server shouldn’t cause problems and obviously as it’s working then your ISP isn’t blocking access to other DNS servers but sometimes ISPs can be a bit sneaky and force all DNS traffic through their own DNS servers (it gives them the opportunity to do stuff like intercepting wrongly typed website names etc. so that they can use their own “helpers” to “assist” you - which basically means they will try to use it as an advertising opportunity which I absolutely hate).

The main reason why I’m suggesting changing it back ASAP is that often static settings on units do get forgotten and then CAN bite you in the backside a few years down the line when you change ISP and you get a new router that is on a different DHCP range or whatever and suddenly something stops working and you can’t work out why, or worse - you’ve set a device to a static IP address on your “old” network and that’s no longer in your new networks DHCP subnet and you can’t even access it to change it.