Mosaic loosing connection to VUP

I can’t predict how and when. But it looses connection every so often and takes about 30-45 seconds to synch back up. I’m using network board version 1.1.0 (503), app version 1.1.0 (84).

iPhone X iOS 13.3

Any ideas?

Hi @jcfrech,

Issues like this are typically the result of the network doing something goofy. When you have a moment can you describe the network configuration as it relates to the Upsampler along with the network hardware in place?

We are also experiencing this issue since the last update. Mosaic periodically reports that connection with the Upsampler has been lost and Mosaic is attempting to reconnect. Here it does not take as long as John’s does to reconnect - usually approximately five seconds. This behaviour new to last update.

Network board 1.1.0 (503)
App 1.1.0 (84)
iPad Pro iOS 13.3

Andrew:

Our network set-up here is Netgear Orbi local router (mesh connection to Orbi main router), Netgear non-managed switch connected to local router, all dCS devices plus NAS array, Roon Nucleus, etc. connected to Netgear switch, cabling Transparent Premium Ethernet. IP address assignment DHCP with reserved addresses (as you suggested in an earlier exchange).

Hi Andrew, NetGear Orbi Mesh. NAS drive and Upsampler wired via Transparent Ethernet cabling to Orbi satellite/router that then wirelessly connects to Orbi main wireless router/hub into a cable modem.

With the common use of the Netgear Orbi and the fact that these mesh Wi-Fi devices can do stupid stuff with network multicast traffic that’s the place I would start.

A quick search suggests that there are a number of known issues with the Orbi hardware with respect to multicast (which Mosaic uses for discovery). One reported solution is to go into the Orbi config and uncheck the box next to the setting that says “Disable IGMP proxying.”

There’s a good chance that Netgear did something in a recent software update which either requires additional configuration or just plain broke multicast.

At this point the only Wi-Fi mesh products that I’ve tested with (and have shown good results) are the products from Eero. When I researched this last I found that both the Netgear and Linksys solutions were severely lacking in terms of proper behavior with the protocols commonly used for this type of device control (namely multicast).

Just to report that, in my router configuration, ’ Disable IGMP Proxying ’ is unchecked (has been from initial setup, as I knew that was a potential issue). Plus, this behaviour of losing connection with the VUP never occurred before the last network board software update - I think that was the case with John as well. I’ve had the Orbi system since August with no issues initially.

Thanks!

Unfortunately, these issues are extremely difficult to troubleshoot since the root cause lives somewhere in the wireless network hardware / software.

For some reason, under certain circumstances, the Orbi is blocking the discovery packets that are sent out by the dCS device. In some network hardware it’s fairly easy to specify the configuration parameters that are needed and in others a whole bunch of parameters are lumped into one checkbox which may or may not accomplish the needed configuration.

After a quick perusal of the Orbi manual I saw a few items which may have an impact here.

  • Fast Roaming: Just shut this off. It’s a nightmare feature that promises performance and delivers instability.
  • WiFi Multimedia quality of service: Shut it off.
  • UPnP: Again, shut it off (should be off by default, but there was some erroneous information floating around at some point that this should be enabled)

To be honest, I doubt that any of those will have an impact (well, fast roaming might). You may want to toggle the IGMP multicast proxy setting back to disabled (box checked) and see if that makes a difference. Normally I would recommend that setting be checked (proxy disabled), but some anecdotal evidence from other users suggested the opposite.

The really nasty thing here is that this could be some outside interference that’s causing contention on one Wi-Fi channel. I’ve seen this in the past and it can cause some very strange behavior where the iOS device loses signal due to interference and then either connects to a different band (i.e. 2.4G to 5G) or to a different access point. The Wi-Fi hardware attempts to be smarter than it should and ends up blocking traffic since it was used to seeing those packets flow over a different interface.

There was a change in the device discovery in 1.1.0, but that was unrelated to what you are seeing.

Well, ’ Fast Roaming ’ was already off, but, ’ Turn UPnP On ’ was ‘on’, and I specifically had intended for it to be ‘off’ not sure why it is 'on. ‘Off’ now. And, is your second parameter called ’ Enable WMM (Wi-Fi multimedia) settings ’ in the Orbi settings? Toggle-able on each frequency band?

According to the manual it should be under ADVANCED > Advanced Settings > Wireless Settings and appears to be configurable for both bands independently. Uncheck the box on both.

Try disabling the IGMP proxy (box checked). This is how it should be and how I would set it if I were configuring one of these out of the box.

I went ahead and unchecked ’ Enable WMM (Wi-Fi multimedia) settings ’ before your reply came back, and I will see what happens and report back if all is well. If not, I will try checking the box for ’ Disable IGMP Proxying ’ and continue observation.

Thanks!