Mosaic issues and desires

I have several issues with DCS Mosaic:

  1. It is hard to adjust the volume, even with the expanded scale. Your finger covers up the control and you cannot tell what is happening.
    Why not have + and - buttons like the use on BlueOS? One tap is a .5 db change.
  2. I have not found a way to quickly switch from playing something in my UPNP library to using Qobuz. There needs to be a home button that takes you directly to the music source page.
  3. I’m not sure if UPNP can do this, but I have program booklets (pdf) files in each Library album directory. It would be really wonderful to read the booklet while I listen to the album.
1 Like

in answer to #2 at least on the iPhone version of Mosaic the bottom left button on the screen acts as a home button going to the source select page. next button I think is the list of tracks you are playing

It is on my android phone, but on only some of the screens of my iP{ad.

I would also like an upgraded Play from Here button. its hit or miss if I see it.

  • The booklet is also (usually) available on Qobuz too.
  • And track names and album names need to scroll. For classical music, these can be very long.

Hi - thought I’d try jumping on this thread as once again I found myself having trouble with the Mosaic app on both my iPad (and iPhone) this evening controlling my Bartok. All up to date software wise btw.
I accidentally played just the first track of an album rather than the whole album.
Tried to pause it to start again - no response. Other controls worked… volume (not that I normally use it as it’s set to max), search other artists etc.
Wouldn’t allow me to play anything else until the track finished. Received an error message saying my command had been refused (can’t remember exact wording). Before the track finished - Closed the app. Reopened it. Still ‘stuck’. Showed the timing on the track ticking down etc so not ‘frozen’. Just not controlling the Bartok.
Before anyone helpfully says it must have been my internet connection - it wasn’t. I have super fast (400mb) fibre broadband that is very stable. I’ve spent serious money getting that right.
This is not the first time, hence the post.
I regularly get a message saying the Bartok has lost connection. Most infuriating. It maybe happened twice in 7 years with my Linn Akurate with the same web set up and indeed its predecessor that was nowhere near as fast or stable. This is happening 2 or 3 times a week since I got the Bartok. Any thoughts?

  • Yes, Mosaic is not ready for prime time. I also get lost connections. I have to reboot my Bartok weekly.
  • And Mosaic is often unresponsive. Nothing happens when I tap something. It is really hard to adjust the volume since it often changes when you remove finger from the slider. Why can’t we have +/- buttons?
  • Often while sitting on my lap, one of the bottom buttons gets hit accidentally, and it is often impossible to get back to where I was without starting from the beginning (which is hard to do since there is no home button). We need a back button that remembers its history. A forward button would be nice too.
  • Why doesn’t the album track list show the one that is playing? The writing under the album art is tiny.

When to we get an updated Mosaic??

May I humbly suggest that you may not be as familiar with Mosaic as you think?

  • Back button: It is at the top of the screen, arrow pointing left.

  • List item playing: Bottom of screen , select the second item from the left ( a triangle pointing to some horizontal lines). This is " Play Queue" and shows what is playing with a blue bar against the active track.

If the graphics are too small use the full screen view ( just tap the artwork in the playing bar). Or use a bigger screen :slightly_smiling_face:

As for the connection problems if you read these postings regularly you will find that these are virtually always LAN configuration issues. For example read the i-phone and i-pad thread posted in the last couple of days.

Yes volume +/- buttons would be better than the current arrangement.

There is a back button on some screens, but not all. For example the device screens. And if you are in a different bottom button screen (by accident) you are not returned to where you were in the other bottom button.