Mosaic is frozen - help

I’m having a problem with my Vivaldi stack (DAC, clock, Upsampler) and Mosaic.

I was practicing guitar last night, playing along with A Horse With No Name, put the DAC on pause for a brief moment, and now Mosaic is stuck on that track, and the play button won’t work. I can switch from my NAS to Quboz, or other streaming services, and get search results thru Mosaic, but the play button still won’t work, and the panel in the lower left of the screen still shows A Horse with No Name.

I did a hard restart (cycled off/on with button on the back) of the DAC, no joy.
I did a hard restart of the Upsampler, no joy.
I did a hard restart of the clock, no joy.
I closed Mosaic on my IPad, turned everything off, and started from scratch, no joy.
I deleted Mosaic from my IPad and reinstalled it. It eventually found the Vivaldi (took nearly 10 minutes), but still stuck on one song, and none of the playback controls (play, advance track, etc) are functioning.

The system worked perfectly after my Dealer installed it and has been for the last year. I changed nothing in the settings or network immediately prior to the problem happening. I was listening to a song, put the DAC on pause, and now it is stuck there. I’ve been dreading this day…

I’ll call the dealer this morning for some help, but in the meantime, and suggestions from the community on what to do next would be muchly appreciated.



That is an odd one.

Everything seems to work on Mosaic except for this issue, yes? One thing I am not clear about. Is Horse With No Name a local file served from your NAS or is it via another streaming service?

I think we can forget about discovery issues with your network. You also seem to have taken all of the “first responder” remedial actions. What does not seem to have been considered is your NAS server if it is a local file. Try rebooting this. What server software are you using?


Thanks for the prompt response, some of us never sleep, I’ve been working on this since around 3 this morning.

The track on which the system is stuck is a DSD version from Quboz. I’ve tried tracks with regular sample rates from Quboz with no joy.

I can access everything on my NAS thru Mosaic, but when I select a track, and hit play now, nothing happens. The lower right of Mosaic’s screen shows no album artwork, but the song on which it is stuck shows up in the text box, and the play button is inactive.

I’ve also tried changing the orientation of my iPad to landscape in case I have a dead spot at the play button on my screen in landscape, no joy.

Since I can get to my NAS thru Mosaic, and use the search function if I bring up Quboz, I don’t think network connectivity is the issue.

TBH, I’ve really dreaded this day - my system is inoperative I don’t know how to fix it. I have not messed around with many of the settings on any of the stack components from the day it was installed hoping today would never arrive. I have the same bad luck with Apple products - when they work they are awesome but when they break they are a bitch to get running again.

I’ve given up trying to fix my song truncation issue when the system switches between a DSD track and one at normal sampling rates, so this current issue is more than a bit irritating. I was hoping to hear from dCS on this issue, but that ain’t happened yet either…

I didn’t change anything at all in the system, and now it ain’t working.

I have some other stuff to handle today, so if I don’t respond quickly to any advice you offer, it’ll be because I’m out in the yard gardening or mowing the lawn since the sun is coming up now. It is gonna be a long day.

Thanks again for your help, I really appreciate it.



Just a further thought after rereading your post. You say that Mosaic took 10 minutes to discover Vivaldi after reinstallation. I had said that discovery is not an issue but it seems I may be mistaken. However are the play controls working OK with Qobuz, internet radio etc. Or are they not functioning there too? I am assuming that it is OK but am not wholly clear.


Nothing works, I’ve tried Quboz, internet radio, and pulling from my NAS. The system is stuck.

So, I needed a little humor to calm me down…the system is stuck on one of my favorite songs to play (2 easy chords), A Horse With No Name…see below…


Mitchimage image

1 Like

Mitch your response posted while I was writing my follow up!

First point, There are no DSD tracks on Qobuz. DSD internet streaming is not viable . Qobuz is entirely PCM. So do you mean that it was a hires Qobuz track that you upsampled to DSD?

I do have issues with iOS with Mosaic discovery and my ipad. I have found that when booting up if I get searching, searching, searching… plus the buffering icon all I need to do is hit the home button on my ipad then go back to Mosaic by touching the dCS icon and it connects immediately. May not be of use to you but I thought it worth mentioning. Which iOS version are you running?

Thanks for the images :smile: :smile:

A “Horse with No Name” memory. In the 1970s America toured Europe with Poco. The last concert of the tour was at London’s Victoria Palace. The tour closed with Horse with No Name but with America and Poco playing together. Harmony Heaven :grin:


I’m running iOS 14.4.2, and the track on which I’m stuck is hi Rez from Quboz I have set to upsample.

I can try rebooting my network, but I really doubt that’s the problem since the search functions work in mosaic for quoboz as well as my NAS so I must be connected to the network, and the Upsampler confirms that…

I can match them note for note on that song on my carbon fiber 12 string from Emerald guitars in Ireland…they are a really cool company with amazing guitars. Best thing about their guitars is they don’t need to be stored away and constantly humidified, and they stay perpetually in tune. Especially convenient for a 12 string.



OK, this is not really help but hopefully may help to analyse the problem.

If your pictures are of the system as it is stuck on Horse etc. then there are some odd displays. Your upsampler ought to be showing the tile of the track . Qobuz has the track as 24/96 so it ought to show 0/96>DSD x2. not 192>DSDx2. However are your pictures not as it now is?

Screenshot of what you should see ( though I am not upsampling and have clone lock on):

NB: My pic shows the bit rate as the track is actually playing. If paused it will show 0 not 24. Ignore the DAC display below as my previous selection was an SACD and I didn’t change DAC input for this shot.

Lovely guitar. I will show it to my guitar fiend friend as I am sure that he will enjoy it.

Hi David,

Is this issue still ongoing?

Do the front panels of the units behave normally? So, can you change settings, volume controls etc.?

Do you have any non-Mosaic sources that you can try to see if they playback properly? Could be Roon, Spotify, a TV via optical, just anything that doesn’t need Mosaic.

1 Like


I have a Mac mini connected as well, so with some help from the dealer from where I purchased the components, I tested that out too - no joy. No matter what I tried, the play button is dead in Mosaic.

I’m tied up for a couple days helping my GF get thru a nasty tooth extraction (two actually), so I’ll not be home again until Monday to continue troubleshooting this.

The dealer spoke with Jesse Luna and they are going to engage with me again Monday to see if we can get thru this. Worst case scenario I understand is a processor is stuck and I’ll have to ship the upsampler off to ya for repair. Best case is if I fiddle around with some cables it might come back to life. Considering it takes me 20 minutes to clear a path to get behind my rack, that’s not too appealing either.

Since we’re working this too, do you have any insight for me on the other issue I’m having with truncation of the first fractional second of songs if the stack needs to switch from DSD to normal sample rate tracks? That’s not a big issue for me, but still something I’d like to get resolved too. There is a much longer description of this on another thread I started.

Thanks for your help



While I am trying to fix this dead play button problem in Mosaic, could you comment/update on fix for the issue described in detail in the attached thread?



The good news, I’m up and running again. I’m not sure which of the steps I retook were successful but the last thing I did is a hard reset of my network. I guess the upsampler needed a fresh handshake with the network.

The not so good news is I’m still waiting for dCS to tell me if there is a fix in the works for the song truncation issue I’ve described elsewhere. I’ll restate it’s not a deal breaker for me (I’m not going to sell off my Vivaldi stack) but I’d really like to know if this is a systemic problem, if a fix is in the works and if newer Vivaldi stacks have the same issue. If this issue is not going to be fixed, I need to rebuild a whole bunch of playlists to avoid the truncation between songs.

Hope everyone has a great day!


Complete radio silence on the DSD truncation issue for most of a year now.

The lack of an answer tells me there ain’t no good answer.

There are a couple of threads on this issue dating back a couple years, and some of our most seasoned and experienced colleagues here put in a good deal of brain power to look for a solution and no joy. So, I assume this is a systemic problem, that can’t be fixed by fiddling with settings, swapping around cables or just hoping to have it go away. I’ve asked the question directly several times here as have you, and others.

If I’d known of this before I decided to sell off some components I really liked (also from dCS - brand loyalty might only run one way it seems) to underwrite a Vivaldi stack I, might have gone a different route. Or just been satisfied with what I already had (Rosinni DAC and clock). If I knew this was gonna be a problem, and dCS wasn’t gonna do anything about it (other than tell me to subscribe to Roon), that woulda influenced greatly the first decision. If ya want me to subscribe to Roon to solve a problem inherent in your components, then you owe me $14.99 a month.

Another thing I’d like to know is what purpose does the DAC buffer serve if not this?

Another thing I’d like to know is does dCS think maybe they should let prospective customers know about this at the time of purchase decision? I bought my DAC and Upsampler used from a dealer I like and trust, and the clock I bought brand new. If I’d paid retail for the whole kit, and had not been told of this before the purchase I’d be more irritated than I already am.

Stupid analogy - imagine buying a hearing aid that needed a second to activate when it sensed sound - you’d spend your life wondering how a sentence someone spoke to you started…I’d go look for a better hearing aid myself.

So, am I gonna sell off what I already have? Nope. But it is a bit embarrassing when I have friends over and want to show off my system with the highest quality recordings available in DSD, and have to explain why the first second of some songs is missing if I switch to a normal track. I get some wrinkled eyebrows when I explain why, and answer in the negative or a shrug of the shoulders the logical next question - “is it gonna get fixed”?

My level of irritation grows as the simple question continues to go unanswered - you guys gonna fix this?

When a data stream is first received it takes a while to determine whether it is PCM or Dolby Digital or other data.

Without the buffer, Dolby Digital sent to a DAC in PCM mode will be played as full volume digital noise.

Sadly, the buffer does not seem to be able to buffer enough data to be able to hold the DSD data sent while the DAC determines whether it is PCM or DSD, so if the bitstream is DSD at that point the DAC is switched to DSD mode and samples received to date are simply dropped, resulting in the issue.

Other DACs seem to be able to do this, but there’s either a bug or limitation that makes this difficult to do on the dCS hardware.

Would I have pulled the trigger on the Rossini hardware had I known about this bug? Probably.

Would I have knowing that this long after discovering it dCS would still have no solution? Maybe not.

But I did and I just hope they release a fix before they release a new model as dCS doesn’t release firmware updates for superceded hardware.

Also sadly, dCS seems about as willing to discuss future software plans as Apple.

The thing is, when you pay between the equivalent of a new car to a new house for a DAC, your support expectations are modified commensurately.


Thanks for the explanation of the buffer’s purpose.

I had a choice when I was assembling my “the best you can find anywhere” Vivaldi stack - the Upsampler or a network bridge. Does the NB have the same problem?

Maybe we’ll hear from dCS today. I won’t be hovering over my IPad waiting though.



okay, I’ll ask the question directly in hope someone at dCS sees it:

Does dCS have a plan to resolve this issue?