Mosaic does not connect

Since yesterday Mosaic does not connect to my network bridge. “Looking for devices” goes on for ever using both Apple and Android.

Tried to use the IP address to reset as this has worked in the past. But though the IP adress is visible when searching for connected devices, it just does not connect when using the browser “the URL can’t be shown” is the response.

Other devices on the network all appear in the normal way.

What am I doing wrong?

Best wishes


If you mean you can’t reach the dCS Network Bridge’s Web UI via it’s IP address, then you definitely have a network connectivity problem of some kind to it, and Mosaic surely won’t be able to discover it.

How are you searching for the NwB’s IP address? If it’s from your router/DHCP Server, you might want to refresh IP address allocations and check that the NwB has a proper IP address allocated.

You could use a network scanning tool like “Angry IP Scanner” on your computer (PC or Mac) to see if you can “see” the Network Bridge on your network or not.

How is your Network Bridge connected to your network? Is it cabled directly to your router or are you using any kind of extender (whether mesh, wireless or Ethernet over powerline / coax) to connect it to your network?



what is the ip address of the network bridge? Can you ping it? Is it assigned by dhcp, and if so what allocation does your dhcp server give?

I also cannot connect today, was fine friday, didn’t try yesterday, but as said today it won’t find it?

All sorted, network switch decided it wanted to play up and change its settings, all by itself.
Re programmed it and its all working nicely once again