Mac Mini won't recognize Puccini U-clock

While my Vivaldi is on the bench for an Apex upgrade I’m hooking my old Puccini player + U-clock to my Mac Mini M2, which I’m using for a music server. I have the clock on USB class 2. When I plug the clock into the Mac, it should recognize it as a USB device, is that correct? Yet it doesn’t.

(More, albeit unnecessary, detail: on the Mac I’m using Theoretica’s BACCH spatial audio and XTC system, which is great. The Mac gets audio from a Babyface Pro and outputs to the DAC, or in this case, the clock.)

I’m talking with Phil and Ben about this, but since it’s the weekend I thought perhaps someone might have solved this before.

Jeff

Jeffrey, on the U-Clock, try switching to USB Audio Class 1, and then back to Class 2 again before you plug the Mac into it again. dCS actually recommends doing this when the PC/Mac has problems detecting the USB port.

1 Like

Thanks, @Anupc. I think I did that, but not sure. Can’t hurt to try again.

Another odd thing, dCS mentioned:
“You’ll also want to set the U-Clock to Auto for USB by pressing the Frequency button until both 44.1 and 48 are lit.”

But I couldn’t get that to work: no matter how long I hold down the frequency button all it does is change the frequency.

From reading the User Manual that does not seem correct. This seems to relate to switching from USB class 1 to class 2. However, according again to the manual, the clock is shipped set to class 2. The change is indicated by the LED slashing.

There is also a caveat on the generation of OS software which needs to be v.10.6 or above.

Thirdly the Audio Midi on the mac needs to be set up (Audio Midi setup/Audio Devices/dCS Puccini).

You haven’t mentioned any of this so I do not know if this has been taken care of.

I have only skim read the manual so I would suggest that you carefully read pages 7-9.

https://dcsaudio.zendesk.com/hc/en-gb/article_attachments/360026897800

Pete,

Thx – useful advice as per.

I have now done the USB 2 → 1 → 2 thing. The Mac is a 2023 Mini running Ventura 13.5.1. The U-clock I don’t know, but the Puccini player is version 1.41.

On the Mac, I go to Finder, open Utilities, then click on Audio Midi Setup. It opens a window called Audio Devices. On the left pane, I see the Babyface Pro which is also connected to the Mac via USB. The crucial moment: I plug in the USB cable that’s connected to the U-clock – nothing happens.

So that’s where I’m at.

Thanks, that covers the OS version and Audio Midi ( in the sense that it is not linking rather than the set up hasn’t been carried out).

Puccini clock underwent a number of software upgrades during its production life. Overriding auto frequency changing was part of this so it may be that the software issue installed on on yours is connected with this i.e. it doesn’t have the latest version. Unfortunately as the clock has no display and this predates Mosaic I don’t know how you can see what version you have. No doubt there is a way.

You could try a simple process of elimination to check if the USB cable or the computer or clock ports are functioning properly by swapping cable or ports one by one with the RME device as we know the latter does work. I am not sure what the RME does anyway as you say :

I was expecting a NAS or some kind of media player installed on the mac . Just me confused no doubt. Anyway this is just experimental to check those items and see if use of a different USB cable ( or mac port) allows recognition of the clock by the mac.

I am just trying some basic ideas as its the weekend as I expect you may be frustrated. However I think that you may really need to await a response from Support.

Pete,

It’s somewhat frustrating, but I have audio: I can just use the Puccini player w/ analog out to the preamp. This is a stopgap until my Vivaldi comes back w/ the Apex upgrade. The annoying part is that the drawer on my STT stopped working at the same time. But c’est la vie.

I didn’t want to supply unnecessary detail but on the Mac I’m running Theoretica’s BACCH program for XTC and spatial audio. Pretty cool stuff. Input is via the Babyface, and output is to the DAC, both via USB. So I’m trying to get the Mac to recognize the U-clock as it did the Vivaldi.

In terms of accessing the clock, I think there’s an RS-232 connection, but I don’t know how that works.

Jeff

Oh that’s too bad, sounds like the USB might be faulty. The U-Clock’s USB port is also the only way to tell what Firmware vintage its running (it doesn’t have an RS232 port).

OK, thx. It’s not the (new-ish) Mac, b/c that recognized the Vivaldi DAC fine. Maybe the dCS team can solve this during the week. In any case, just using the Puccini as a regular player is fine; I just don’t have the full spatial audio mojo. After all this time I’m struck by what a great piece it is.

1 Like

Meanwhile if anyone from dCS wants to weigh in, great. For one thing the clock should do USB as described. Also if I sell it I need to know what works & what doesn’t.

Hi Jeff,

I believe you had a reply from Ben a couple of days ago but i haven’t seen anything back on that?

Phil, yes. But Ben’s and the manual’s instructions on putting the Clock in Class 2 seem slightly divergent. Ben’s step 5 doesn’t quite work: the LEDs don’t stop flashing. But I’ve tried that and the manual’s steps – in neither case did the Mac recognize the USB device. Unless I’m doing something wrong on the Mac side, but I don’t think so: it’s very simple – the device should show up in the “Audio Devices” utility.

That said, my upgraded Vivaldi just arrived, so the point is slightly moot. But I’d still like to understand why the Puccini clock isn’t seen by the Mac.

Thx, Jeff