Lost contact between Roon and Rossini DAC

I installed a RS232 cable between my Rossini DAC and Rossini Clock. Before doing so, I turned off both the Rossini DAC and Rossini clock. After I turned both the clock and DAC on again I lost connection with my network and my Roon Nucleus and now cannot play either my library or .Qobuz. All of my music is stored in my Roon Nucleus on a Samsung hard drive. Everything was working great before shutting off both the Rossini DAC and clock and installing the RS232 cable. Disconnecting the RS232 did nothelp nor did rebooting the Rossini DAC and clock. I also deleted and reinstalled the Mosaic app, but that did not help either.

When I try to play music,I get the following error message on my iPad:
“Unexpected error communication with audio device. Too many failures. Stopped playback.”

Any help would be appreciated.

Bob, check your Ethernet connection into the Rossini, it might have inadvertently gotten dislodged or disconnected in someways.

Easiest way to see if there’s some problem with that connection is to get your Rossini’s IP address from it’s front-panel display and key that into any PC/Mac web browser on your home network and see if your Rossini’s web screen appears.

Thanks. I checked the Ethernet connection and it’s ok. I plugged in the Rossini’s IP address

I also got the Rossini’s IP address fromthe front panel display and keyed it into another Mac device connected into our home network. The DCS appears with main page appearing and the choices of device settings and network settings.

What do I do next?

Bob, I did a google search on your error message;

Looks like the problem you’re experiencing has to do with your Roon Core, not the Rossini/Clock per se; see other similar reports on Roon’s Community forum;


Thanks Anup,

The network troubleshooting link given there is very informative, and helpful:


Thanks Anup. My Nucleus was installed and hardwired via Ethernet by my audio dealer. In this configuration, I had used my Nucleus with my previous DAC, the Ayre QX-5 without indecent for months.

It’s been only 3 weeks since I’ve owned the Rossini that this problem occurred. Maybe it’s quincentennial, but suspicious? Anyway, I’ll check into the Roon as a possible cause and call my dealer later tomorrow for troubleshooting.

I turned my Rossini DAC, Rossini clock, and Roon Nucleus off all night and lo and behold, when I turned everything back on this morning, everything is working again! I guess that it needed it’s head cleared? When I initially had the problem, I forgot to reboot my Roon Nucleus. Maybe doing that might have solved the problem?

Thanks to all who replied with their help and suggestions.

Bob…I also have a Roon Nucleus with a Samsung SSD, connected to my Bartók. I get that error message from Roon quite often. Infact, just a couple of days ago.The error message last Saturday was when I was playing Internet radio. I have contacted Roon support, still waiting to hear back.

I think it’s definitely a Roon issue as I got an error message whilst demoing a Auralic Vega. (Before I ordered the Bartók)

Hi Bob…Thanks for your reply.

A reboot appears to solve most issues, but something must have triggered it initially. I turned my Bartók off from the back of the unit, same with the Nucleus. Left it for two-three minutes, switched both back on, all back to normal.
Funnily enough, whilst typing this message, Roon support have sent me an email.

"Can you please try to reboot your Nucleus via the Web UI and power cycle that DAC as well?"

For both of us, this has clearly worked. But as I’ve said, something in Roon bust be triggering this.
As this is not a dCS issue, our ‘Admin’ may prefer us to discuss this elsewhere? :thinking:


I deleted my last post and the quote from my dealer in my last reply as I don’t want to get them negatively involved as they were only speculating their thoughts in a private e-mail to me as to possible causes of my problem. Incidentally they are a well respected high-end dealer in my area and their troubleshooting has always been first rate in resolving problems such as this.

Since my Ayre QX-5 DAC paired with my Roon Nucleus via my same Network never gave problems in playing music, from either my library or Qobus, and the Rossini and its external clock were the only recent changes to my system when the problem occurred, they became suspect.

Since my new Rossini & it’s external Rossini clock are very expensive components and I put my faith, trust, and hard earned money towards their company with my recent DCS purchase, I would only hope that DCS would be helpful in resolving my problem if it becomes a reoccurring issue.

1 Like

I searched the Roon Community and it looks like the same problem has occured with not just dCS and Auralic, but also Oppo, MSB, and quite a few other Audio devices.

That being the case, if I were to venture a guess, I’d say the problem has to do with Roon Core’s communication to its end-point - i.e. the RAAT stack within the Roon Ready Audio Devices; for some reason that TCP session between the Core and RAAT end-point goes haywire, and only a reset of that link resolves the issue.

I’d guess the issue should be “easily” fixable once Roon support has replicated and identified the problem :wink:

1 Like

I agree with you Anup :+1:…The Roon post relating to the ‘Auralic’ is mine. So it’s not just happening to dCS products.

1 Like

Hi Bob…
For what it’s worth…before I demoed the Auralic, dCS Bridge and Bartók, I had a Matrix Audio, Pro Sabre MQA DAC, connected directly to the Nucleus by USB (Not an ideal setup) I didn’t have any connection issues or error messages. Obviously the sound was nowhere near to that of the Bridge or Bartók.

1 Like

There are known issues with the network board:

1 Like

Erno…It is possible, that these are two separate issues.

The issue I have, I believe is a Roon issue, as I had the same on a Auralic Vega G2 that I was demoing, before finally choosing the Bartók.

robertt and Billk are experiencing connection problems with their dCS unit, but in a different way.
I don’t know if their issues included the use of Roon?

It is difficult to determine where the problem(s) come from: either or your network setup, Roon, the proprietary Auralic Lightning Streaming framework, or the proprietary dCS implementation of Mosaic and the StreamUnlimited network board they use.

1 Like

My case is a bit different as I only lost I lost connection once with my network when I powered down my Rossini DAC to install a RS232 cable between my Rossini DAC and my Rossini clock. It was only after powering my Rossini DAC back on after installing the RS232 cable that the Rossini would no longer communicate with my Roon Nucleus until I rebooted the Nucleus. Otherwise my former Ayre DAC worked perfectly with my Roon Nucleus in my network for over the 3 months until I bought DCS Rossini, and then perfectly with it too until I powered the Rossini down to install the RS232 cable between it and it’s clock. Otherwise, in my setup I’m having no issues.

BTW, my dealer originally connected my network to my Ayre DAC and then the DCS. What he said which I deleted from this DCS thread above applies to my situation only and not to the others here who are appearing to loose connection with their DCS and Roon Nucleus spontaneously.

Roon just published Roon 1.7 Build 710, which contains stability improvements for the device discovery protocol. It might be useful to update, and see if it improves current issues.


Thanks Erno…just done that. :+1:

Thanks for the reminder Erno.

I received the update reminder this morning from Roon and hope that this will stop the losses in communication between my Rossini DAC and Roon Nucleus.