Listen to an entire album with Mosaic app

Hi everybody,

I have a Rossini player and my music (17To) is on a NAS which is connected with a Regen switch.

I use Rossini app or Mosaic app.
When using Mosaic, I can’t listen to a whole album.

I only can select a single track, and in every case, the music stops at the end of the selected track.

I guess it’s possible to listen to the whole album other than by clicking on each track to make queue, which is not very convenient, but I don’t know how to do?

Thank for your help.

Regards
Gilles

Giles, you should see a [Play All] button when you get to a particular album. See the Mosiac User Guide item 5. :smiley:

Gilles, just to add that if you look at the Play All button you will see that there is an arrow ( chevron) pointing down on the right side of it. The button is actually divided into two areas. If you tap to the left of the button you will play the entire album. If you tap the arrow you will then see a sub menu which gives three options ; Play Now / Add Next/Queue. Play now means play only the selected track . If it is an album and you haven’t made a selection that will be track 1 by default.

If you manage to tap the whole button at once then there is a good chance that you will inadvertently have selected Play Now. That is what is probably happening to you.

If you do want to play only part of an album e.g. say from track 6 onwards, then place the album in the play queue by tapping arrow on the right of the Play All button and select Queue. Then move to the Play Queue view ( bottom of screen, next icon to the UPnP one. It looks like an arrow pointing to the right at some horizontal lines). Then select Play from Here by tapping the two horizontal bars next to track 6 ( for this example).

If this does not solve your issue then it will be necessary to ask what UPnP sever software you have installed on your NAS.

Thanks for your two answers, but they don’t solve my issue.

Anupc,
I doesn’t have any [play all] button on my screen (ipad).

Pete,
In fact, it seems something is missing.


As you can see, I don’t have the ligne with all these informations on my screen.

I am not a specialist, can my UPnP server software be MinimServer?
Maybe I should reinstall Mosaic?
It already last version 1.1.0(84)

Thanks for your help.
Gilles

According to your images your UPnP server is SqueezeNAS . That puzzles me as I can only find a related reference to Squeeze Neural Architecture Searching. Also where it is shown at the bottom of the screen would normally display a UPnP icon. As you seem to be aware the correct operation of Mosaic is dependent upon the UPnP server being MinimServer for the various reasons that you can find in the FAQs.

Your images are also not of the screen that I was expecting as they show information at track not album level which would normally be the screen that appears when the album is actually playing rather than the screen for selection which is where the Play All button appears . However it is also clear from the right hand part of the display that looks like a phone or DAP that nothing is actually playing.

So back to basics. Close Mosaic. Now reopen it and once it has found your device ( Rossini Player) you should then see a screen with a list of options starting with UPnP, then USB, Deezer, Qobuz, Tidal, Radio, Podcasts, Spotify.

Select UPnP and you should see your server listed. Select this and you should have a screen indicating the number of albums and items ( tracks) on your server. Select the number of albums then Show All . You should now see a screen that has the Play All button and a selection including View All. Select View All and you should see a screen with the Play All button and your albums listed below.

Now the exact way all of this appears will reflect the “dialogue” between your server software and Mosaic. As you do not have MinimServer it may not appear as I have set out. Please tell me if and how it differs.

Which server do you use? Can you install MinimServer on it?

Hello Pete,

Tanks for your answer.

I have switch on/off/on Mosaic again.
When I select UPnP as you said, I see SqueezeNas.
And when I select SqueezeNas, I see three folders: Music, Photo, Video.
Then, my Music folder is shared in Classical, Pop, Jazz, etc.
When I arrive at the album level, I still dont have any Play All Button.

My Nas is a 32To Synology DS420J and I have 17To of music on it.
I have to leave, but Thuesday, I will look if I have it, or if I can install Minimserver on it, and I 'll tell you.

One detail, with Rossini app, the All Tracks button is perfectly working, but this app is less convenient

Have a nice Sunday.
Gilles

I look forward to your further advice later in the week.

Hello Pete,

I am back again.

I tried in many ways, with different NAS, but if in all cases, I can listen to an entire album with Rossini app, it’s never possible with Mosaic App. It means the issue is with Mosaic, not with the NAS.

Thanks for helping
Gilles

Gilles, I can almost feel your frustration and sympathise.

There are only two versions available of Mosaic , Android or iOS and all of us here are using one or the other. We all have a Play All button and a screen that shows albums at track level etc. So generally as far as we in the community are concerned the Mosaic software is robust. There have been problems but no others that I have seen involve missing screens or absent GUI features within them. Nearly all Mosaic problems I can recall have turned out to be in regard to stable network connection and end up being solved by changing network configurations.

So, it seems not to do with connectivity and given that you have now tried different servers (as the server software can affect the displayed information) and have found that this route does not provide a solution an obvious remaining cause may simply be a corrupt installation of Mosaic.

Have you tried uninstalling Mosaic from your device and downloading a fresh copy from either App Store or Play Store?

Ok Pete, but as I have already canceled, then reinstalled Mosaic on my Ipad, I can Imagine that I have to change something in the Rossini itself.
How can I do that?

I do not anticipate that the part of Mosaic Control that is in the Rossini has any influence on the Mosaic GUI display on the control device ( as opposed to the information that populates the display).

Incidentally what are you using Android or iOS? One thing that does puzzle me is your Mosaic display showing the server software as SqueezeNAS which, as I said, I can only identify as a product concerned with a type of searching architecture. Perhaps it may help if you could expand further than just the type of control device you use and provide an insight into your network ?

As you say that a reinstall makes no difference frankly I have run out of ideas. Your new suggestion runs into engineering detail that I would expect you could only get informative comment on from dCS engineers. So I now hope that one of them will pick up on this.

Good luck,

Pete

I just sent a message to dCS company.
Thanks

what is the upnp server used on the synology : the internal one or minimserver (other) ?

I tried them both.